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1.1.  WEB SAYTLAR:  YARADILMA VƏ 
YAYILMA ÜSULLARI 

 
  1989-cu ildə amerikan texniki Tim Berners Li tərəfindən 
irəli sürülmüş «hipermətn» prinsipi və sonradan HTML dilinin və 
HTTP protokolunun yaradılması kompüter informasiya 
texnologiyasında yeni istiqamətin-Web texnologiyanın əsasını 
qoydu. Bunun nəticəsində  İnternetin yeni xidmət növü - World 
Wide Web (ümumdünya hörümçək toru) və ya WWW xidməti 
təşəkkül tapdı və İnternet rahat və əlverişli informasiya mübadiləsi 
və ünsiyyət vasitəsi olmaqla yanaşı,  həm də böyük informasiya 
mənbəyinə çevrildi.  Bu gün WWW xidməti vasitəsilə praktiki 
olaraq bütün mövzularda informasiya əldə etmək olar. İnformasi-
ya əsasən Web-saytlar   formasında istifadəçilərə təklif olunur.  
Web- saytlar bir-birilə əlaqəsi olan və vahid mövzuya həsr 
olunmuş Web-səhifələr sistemidir. Hər bir Web-sayt unikal URL1 
ünvanına malik olur. İnformasiyanın axtarışı və sənədə istinad bu 
ünvan əsasında həyata keçirilir. 

Web-saytlar əsasən HTML, XML2 və  XMTL dilləri 
əsasında yaradılır. Son illər saytların yaradılmasında həmçinin 
aşağıdakı müasir Web texnologiyalardan geniş istifadə edilir: 

• JavaScrpit  
• VbasicScript 
• CGİ (Common Gateway Interface)  
• ASP 
• PHP 
• Macromedia Flash3 
• CSS 

Müasir Web texnologiyalar saytların funksiyalarını genişlən-
dirir, onlara dinamizm verir, gözəl tərtibat effektlərinin 

                                                 
1 URL-Universal Resource Locator (Ehtiyatların universal göstəricisi)  
2 2000-ci ildə World Wide Web Consortium tərəfindən  yaradılmışdır.   
3 Bu texnologiyanın vasitəsilə kiçik həcmli, yüksək keyfiyyətli interaktiv 
animasiya yaradılır. 
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yaradılmasını, istifadəçi və informasiya mənbəyi arasında 
interaktiv əlaqəni  təmin edir. 

Saytın yaradılmasında əsasən 2 tip proqramlardan: 
HTML və ya XMTL redaktorlardan  və WYSIWYG prinsipi ilə 
işləyən Web redaktorlardan (məsələn: FrontPage, Macromedia 
Dreamweaver MX və s.)  istifadə olunur. Sayt yaradan şəxslər–
Web dizaynerlər bu proqramları dərindən bilməklə yanaşı, həm 
də yüksək bədii  yaradıcılıq qabiliyyətinə malik olmalıdır. Belə 
ki, sayt informasiyanı istifadəçiyə dolğun çatdırmaq və 
istifadəçinin estetik zövqünü «oxşamaq» üçün gözəl tərtibatla 
yaradılmalıdır. Bu məqsədlə saytların yaradılmasında Web 
qrafika elementlərindən: şəkillərdən, diaqram və qrafiklərdən, 
animasiyalı təsvirlərdən, səs və video fayllardan və s. geniş 
istifadə olunur. Qeyd edək ki, İnternetdə sürətli informasiya 
mübadiləsini təmin etmək üçün xüsusi Web qrafika, səs və 
video formatlarından istifadə olunur. Web qrafika formatı 
olaraq Эиф, Жпеэ, Жпэ, Пнэ, səs formatı olaraq Au, 
Мп-3, Rmx, Rmj, video formatı olaraq Avi, Мpeg-3, 
Mov, Swf, Spl və s. formatlarından istifadə olunur. Web 
qrafika elementlərini yaratmaq üçün xüsusi dizayn proqramları, 
məsələn Ulead Gif Animator, 3D-Xara, XaraWeb Style və s., 
bir sıra rəsm redaktorlarının, məsələn, PhotoShop, Corel Photo 
Paint və s. xüsusi utilitləri tətbiq olunur.  

Web-saytlar iki formada: statik və dinamik saytlar 
şəklində yaradılır. Statik saytlar əsasən istifadəçiyə konkret  
informasiyanı çatdırmaq funksiyasını yerinə yetirir. Dinamik 
saytlar istifadəçi ilə informasiya mənbəyi arasında interaktiv 
əlaqəni təmin edir. Çatlar, Web forumlar, Internet mağazalar, elan 
lövhələri, qonaq kitabları, axtarış və reytinq sistemləri və   s. 
dinamik saytlar şəklində yaradılır.  Dinamik saytlar «klient-
server» arxitekturası əsasında fəaliyyət göstərir.  Belə ki, klient 
kimi Web brauzer (məsələn, İntenet Explorer, Opera və s.), server 
kimi Web server və verilənlər bazası serveri çıxış edir. Brauzer 
vasitəsilə istifadəçinin göndərdiyi məlumatı Web server təhlil 
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edərək, server əlavəsinə ötürür. Server əlavəsi göndərilmiş 
məlumat əsasında verilənlər bazası serverində axtarış və verilənlər 
üzərində nəzərdə tutulmuş əməliyyatları yerinə yetirir. Sonrakı 
addımda server əlavəsi aparılmış əməliyyatların nəticəsini 
brauzerin qəbul etdiyi formata çevirib Web serverə, o isə öz 
növbəsində Web brauzerə göndərir. Bu səbəbdən dinamik saytlar 
mütləq, istifadəçinin informasiyasını Web  serverə çatdıracaq 
forma ilə təchiz edilmiş Web-səhifəyə və  bu informasiya  
əsasında verilənlər bazasında əməliyyat aparan və nəticəni 
istifadəçiyə çatdıran server əlavəsinə malik olmalıdır. Bu gün 
server əlavəsi əsasən, CGİ, ASP,  PHP texnologiyaları tətbiq 
edilməklə yaradılır. CGİ texnologiyası nisbətən daha əvvəllər 
tətbiq edilmişdir. Bu səbəbdən İnternetdə bu texnologiyaya 
əsaslanan dinamik saytlar çoxluq təşkil edir. CGİ texnologiyasının 
əsas üstünlüyü onun klient proqram təminatından asılı olma-
masıdır. Bu texnologiyanı praktiki olaraq, istənilən versiyalı  
brauzerlər qəbul edir. Lakin, CGİ texnologiyası kompüterin sistem 
resurslarına cox tələbkardır. Proqram təminatı bazarında təklif 
olunan CGİ tipli server əlavələrinin əksəriyyəti kompilyasiya 
olunmuş proqram modullarından- exe genişlənməsinə malik 
fayllardan ibarətdir. CGİ texnologiyası əsasında yaradılan dinamik 
sayt aşağıdakı prinsip əsasında fəaliyyət göstərir: 

• Web-səhifə istifadəçinin informasiyası ilə yanaşı  
verilənlər bazasında  əməliyyat aparmaq  üçün müvafiq CGİ 
əlavəsinin adını Web  serverə  göndərir.  
• Web server öz növbəsində  həmin adda CGİ əlavəsinin 
icra olunmasını təmin edir.  
• CGİ əlavəsi verilənlər bazası serverində müəyyən 
əməliyyatlar apararaq yekun Web-səhifəni Web  serverə  
qaytarır.  

Məsələn, Bakı Dövlət Universitetinin Elmi kitabxa-
nasının elektron kataloqu CGI texnologiyası əsasında hazırlan-
mışdır və kitabxananın elektron biblioqrafik məlumat bazasında 

Fərdi kompüterlərin proqram təminatı 

 

9 

On-Line axtarışı təmin edir1.  Kataloqun ana səhifəsində 
istifadəçi  öz sorğusunu formalaşdırır, yəni axtarış üçün zəruri 
məlumatları daxil edir. Axtar düyməsini sıxdıqda bu 
məlumatlar və CGI əlavəsinin ünvanı  Web  serverə  göndərilir. 
Nəticədə, OPACServlet.exe əlavəsi yerinə yetirilərək oxucu 
sorğusunun cavabı OPACResultSimp.html səhifəsi vasitəsilə 
oxucuya çatdırılır.  

ASP (Active Server Pages; serverin aktiv səhifələri) 
texnologiyası MicroSoft firması tərəfindən yaradılmışdır. Web-
səhifəni ASP texnologiyasının tətbiqi ilə interaktiv etmək üçün  
Web-səhifədən  makrodildə yazılmış skriptə2 müraciət etmək  
lazımdır. Skript bilavasitə serverdə yerləşir və interpretasiya 
olunur. Məhz bundan sonra istifadəçi brauzerinə ASP skriptinin 
işinin nəticələri ilə birlikdə artıq hazır HTML-sənədi göndərilir. 
Ona görə də haqlı olaraq qeyd edilir ki, ASP texnologiyasını 
tətbiq etmək üçün istifadəçi kompüterində hansı proqram 
təminatının olmasının heç bir mənası yoxdur. Ancaq ASP-nin 
istifadə olunacağı Web serverin tipinin müəyyənləşdirilməsinin 
böyük əhəmiyyəti vardır. Belə ki, onların heç də hamısı bu 
texnologiyanı qəbul etmir. 

PHP texnologiyası da Web-səhifədə yerləşdirilmiş skriptə 
müraciət əsasında fəaliyyət göstərir. Skript PHP (Personal 
Home Page tools)3 dilində hazırlanmış xüsusi proqram kodudur 
və serverdə yerləşən Web əlavəyə-HTML sənədinə alt proqram 
kimi daxil edilir. Brauzer vasitəsilə skriptə müraciət olduqda, 
kod interpretasiya olunur. Məhz bundan sonra istifadəçi 
brauzerinə PHP ssenarisinin işinin nəticələri ilə birlikdə artıq 
hazır HTML-sənədi göndərilir.  Qeyd edək ki, bu texnologiya, 
əsasən MySQL bazasından informasiyanın istifadəçiyə 
çatdırılması üçün geniş tətbiq olunur. 

                                                 
1http://www.bsu.az/lib/cgi1/marc/opacform.html ünvanlı sayta müra-ciət 
etməklə oxucular  elektron kataloqdan istifadə edə bilərlər.  
2 Java Script və Vbasic Script dilində yazılır. 
3 PHP PERL-i xatırladan  interpretasiya dilidir. 
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 Web-saytların İnternetdə yayımını təşkil etmək üçün o 
Web serverlərdə yerləşdirilməlidir. Bunun üçün istifadəçi Web 
host-a malik olmalıdır. Yəni o Web  serverlərdə xüsusi disk 
sahəsi icarəyə götürməlidir. İki növ Web  hosta malik olmaq 
olar: pullu və pulsuz. Bir sıra saytlar məsələn www.boom.ru, 
www.narod.ru, www.chat.ru və s. pulsuz Web  host təklif 
edirlər. Bunun üçün istifadəçi sayta daxil olub, qeydiyyatdan 
keçməli, öz saytını «usta rejimi» və şablonlar vasitəsilə yenidən 
yaratmalı və ya hazır saytı FTP protokolu ilə serverə 
göndərməlidir. Bu xidmətin müqabilində firmalar pulsuz 
saytlarda reklam banerləri yerləşdirirlər. Bu da çox zaman 
istifadəçini qane etmir. Yayımın pullu forması müəyyən ödəniş 
əsasında, Web-saytın  provayderin və ya Web  host təklif edən  
firmaların Web serverlərində yerləşdirilməsini nəzərdə tutur. 
Bu forma daha etibarlıdır və geniş istifadə olunur.  
 
 

1.2. HTML-DİLİNİN ƏSAS ELEMENTLƏRİ 

Web-səhifənin strukturu. 

Hər bir Web-səhifə və ya html sənədi  standart struktura 
malik olur. Sənədin  strukturu məcburi bloklardan ibarət olub, 
xüsusi direktiv-teqlər1 vasitəsi  ilə təsvir olunur. Teqlər  “< >”  
mötərizələrinin daxilində yazılır. Teqlər cüt və ya tək olurlar. 
Cüt teqlər  “bağlayan ” və  “açan” teqlərdən ibarət olurlar. 
“bağlayan” teqin əvvəlində  sleş -/ işarəsi qoyulur. Qeyd edək 
ki, hər bir sənədin əvvəlində açan  <щтмл>  teqi, sonunda isə  
bağlayan </html>  teqi yerləşməlidir.  

                                                 
1 Teq ingilis dilindən tərcümədə nişan deməkdir. 
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Sənəddə brauzerlər və axtarış sistemləri tərəfindən 
istifadə olunan xidməti informasiya < html> açan teqindən 
sonra cüt <head> və </head> teqləri arasında göstərilir.  Bu 
məqsədlə  əsasən, <tıtle> … < /tıtle> və <meta> teqlərindən 
istifadə olunur. Açan və bağlayan <tıtle> və  </tıtle> teqlərin 
arasında Web-səhifənin adı göstərilir. Məsələn, sənəddə 
<tıtle>Azad Qurbanov< /tıtle> yazılışından istifadə olunmuşsa, 
brauzer vasitəsilə səhifəyə baxış zamanı səhifənin adı-azad 
qurbanov brauzer pəncərəsinin başlıq sətrində əks olunacaqdır. 
Bundan əlavə, səhifənin adı  səhifələrin avtomatik 
indeksləşməsini yerinə yetirən axtarış sistemləri tərəfindən də 
nəzərə alınır. Bu səbəbdən <tıtle> və </tıtle> teqlərini saytın 
bütün səhifələrində istifadə etmək məsləhət görülür: Səhifənin 
adı axtarış sistemlərinin nəticələrində əks olunur və bununla da 
potensial istifadəçilərin diqqətini həmin Web-sayta cəlb edir.  

Tək <meta> teqi Web-səhifənin brauzerdə əks olunma 
rejimini müəyyən edən müxtəlif növ xidməti informasiyanın 
verilməsi üçün istifadə olunur. Bu  teq səhifədə mətn 
kodlaşdırılmasını göstərmək, əksər axtarış sistemləri tərəfindən 
istifadə olunan açar sözləri müəyyən etmək üçün istifadə oluna 
bilər. Məsələn, 

<meta http-equiv="content-type" content="text/html; 
charset = windows-1251"> 

Səhifənin ölçüsü və mətn sahəsi <body> və </body> cüt 
teqləri arasında verilir. Həmçinin bu teq səhifənin 
formatlaşmasının əsas parametrlərinin müəyyən edilməsi üçün 
də istifadə olunur. <body> teqi aşağıdakı yazılış formatına 
malikdir: 

<body background=”fon rəsm faylının url ünvanı” 
bgcolor=”fon rənginin kodu” text =”mətn rənginin kodu”  link 
=” hiperistinadın rənginin kodu” vlınk =”baxılmış 
hiperistinadın rənginin kodu” alınk =” qeyd olunmuş 
hiperistinadın rənginin kodu”>    
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            </body> 
<body> teqinin background parametri fon olaraq istifadə 
olunan rəsm faylının ünvanını müəyyən etmək üçün1, digər 
parametrlər müvafiq olaraq fonun, əsas mətnin, hiperistinadın, 
həmçinin baxılmış və qeyd olunmuş hiperistinadların rənglərini 
təyin edir. Rəngin kodu  rənglərin standart adları  ilə və ya on 
altılıq say sistemilə verilə bilər. Məsələn, 

bgcolor =  “indiqo” text =  “white” 
və ya  

bgcolor =  “#4boo82 ” text =  “#ffffff” 
Web səhifənin mətn elementlərinin tərtibatı üçün html 

dilində bir sıra teqlər mövcuddur. Bu teqlər abzasların və 
sərlövhələrin parametrlərini müəyyən edir, mətn üçün istifadə 
olunan şriftin ölçüsünün və növünün  seçilməsinə, mətndə 
avtomatik hecaya bölməklə yeni sətrə keçmə rejiminin 
müəyyən olunmasına və s. xidmət edir. 

Html  sənədində mətnin abzas kimi müəyyən olunması 
üçün <p> və </p> teqlərindən istifadə olunur. Bu teqlərin 
aşağıdakı yazılış formatı vardır: 

<p alıgn =center |left| right>   abzasın mətni  </p> 

Alıgn parametri abzasda mətnin nizamlanma rejimini müəyyən 
edir. Center – mərkəzə doğru, left – sol küncə doğru, right – isə 
sağ küncə doğru nizamlama rejimini göstərir. Əgər alıgn 
parametri buraxılıbsa, o zaman abzasda mətn sol küncə doğru 
nizamlanır. Bu parametr eləcə də justify (eninə doğru düzəlmə) 
qiymətini də ala bilər, lakin bu rejim bir çox brauzerlər 
tərəfindən qəbul edilmir.  
<p> teqi cüt olmayan şəkildə də istifadə oluna bilər. (</p> 
bağlayıcı teqi olmadan da). Bu halda <p> açan teq hər abzasın 
əvvəlində qoyulmalıdır: 

<p> <$[kursiv> abzasın mətni 1 

                                                 
1 Məsələn BACKGROUND = imaqes / back. gif 
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<p> abzasın mətni 2 
<p> abzasın mətni 3 
Bir çox hallarda müəyyən mətn hissəsinin yeni sətrdən 

əks olunması tələb oluna bilər. Bunun üçün həmin mətnin 
əvvəlində sətr bölgüsünü qoymaq lazımdır. Mətnə sətr 
bölgüsünü daxil etmək üçün onun əvvəlində  <br>  tək teqi  
yazılır. 

Sənədin məntiqi baxımdan tamamlanmış mətn hissələri  
(məs: sənədin bölmələri və fəsilləri) sərlövhə və altsərlövhəyə 
malik olur. Html dilində sənədlərin sərlövhələrinin tərtibatı 
üçün  <hn> və </hn> cüt teqləri nəzərdə tutulmuşdur, burada n 
1–dən 6-ya kimi qiymətlər alır. <hn> və </hn> teqləri aşağıdakı 
yazılış formatına malikdir: 

 <hn alıgn = center |left |right>başlığın mətni </hn> 

Alıgn parametri sərlöhvə və ya alt sərlöhvə üçün  
nizamlama rejimini təyin edir və  center, left, right qiymətləri 
alır. Məsələn, aşağıda göstərilən nümunədə  <h1> teqi mərkəzə 
doğru birinci səviyyəli sərlövhəni müəyyən edir: 

<h1 alıgn = center> pulsuz oyun proqramları </h1> 
Mətnin müəyyən fraqmentlərinin qeyd olunması üçün 

(məsələn, istifadəçinin diqqətini hər hansı bir informasiyaya 
yönəltmək və ya proqram kodu nümunəsi olan mətni göstərmək 
məqsədilə) çox vaxt şriftin müxtəlif təsvir parametrlərindən 
istifadə olunur. Bundan əlavə sənədə, riyazi və ya kimyəvi 
düsturlarda istifadə olunan  sətrüstü və ya sətraltı indeksləri 
daxil etmək zərurəti  yarana bilər. Şrift üçün bu cür 
formatlaşdırma parametrlərini müəyyən etmək üçün html  
dilində bir sıra teqlər nəzərdə tutulmuşdur. Aşağıdakı cədvəldə 
bu teqlərdən ən çox istifadə olunanları verilmişdir.    
 
 

Teq Təsviri 
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Teq Təsviri 

<b>...</b> Tünd şrift  

<i>...</i> Maili şrift 

<u>...</u>  Altından xətt çəkilmiş şrift 
<strıke>...</strıke> və ya  
 <s>.../s>  Qaralanmış şrift 

<tt>...</tt> Eyni enli şrift 

<sup>...</sup> Sətrüstü indeks 

<sub>...</sub> Sətraltı indeks 

<font>...</font> Şriftin parametrləri  

Göründüyü kimi, cədvəldə verilmiş bütün teqlər cüt teqlər 
sayılır. Bir faktı nəzərə almaq lazımdır ki, html  sənədlərində 
sözlərin altından xəttin çəkilməsi bir qayda olaraq, 
hiperistinadların göstərilməsi üçün tətbiq olunur. Buna görə də 
qarışıq düşməsin deyə, imkan daxilində <u> ... </u> teqinin 
istifadəsindən çəkinmək lazımdır. 
 <font> və </font> cüt teqi şriftin əlavə parametrlərini 
müəyyən etdiyinə görə, ona bir qədər ətraflı baxmaq  lazımdır. 
Bu teqin yazılış formatı aşağıdakı kimidir: 

<font size=[+|-]1|2|3|4|5|6|7 color=“şriftin rənginin kodu” face=  
“şriftin adı ”> mətn </font> 

<font> teqinin size parametri şriftin, şərti olaraq 1-dən 7-yə  
kimi ölçüsünü müəyyən edir. Bundan əlavə şriftin ölçüsü baza 
ölçüsünə nisbətdə göstərilə bilər. Bunun üçün size parametrinin 
qiymətinin əvvəlində “+” və ya “-” simvollarını göstərmək 
lazımdır. Məsələn, əgər şriftin standart ölçüsü 3-ə bərabərdirsə, 
onda size=-2 parametrinin qiymətində nəticə   size=1 
parametrində olduğu kimi olacaq. Bu üsul şriftin ölçüsünün 
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böyüdülüb və ya kiçildilməsi üçün çox rahatdır. Bu zaman 
şriftin baza ölçüsü  <basefont>...</basefont> teqindən istifadə 
etməklə müəyyən edilməlidir. Bu teqin yazılış  formatı 
aşağıdakı kimidir. 

<bazefont size =1| 2| 3| 4| 5|6 |7> mətn </bazefont> 
<font> teqinin color parametri şriftin rəngini göstərməyə imkan 
verir. Face parametri şriftin adını təyin edir. Məsələn, mətnin 
Times new roman şrifti əsasında əks olunması üçün face 
=”times new roman” yazılışından istifadə edilməlidir. Face 
parametrinin qiyməti olaraq vergüllə ayrılmış şrift adlarının 
siyahısından da istifadə etmək olar. Ümumiyyətlə, şrift 
siyahısından istifadə daha məqsədə uyğundur. Belə ki, şrift 
siyahısı səhifədə şrift uyğunsuzluğu probleminin aradan 
qaldırılmasına xidmət edir. 

Html dili Web-səhifədə siyahıların 3 müxtəlif tipini 
yaratmağa imkan verir:  
1. Markerli siyahı; markerli siyahı hər birinin əvvəlində xüsusi 

simvol- marker qoyulmuş abzas qrupundan ibarətdir. Html 
dilində markerli siyahını müəyyən etmək ücün  <ul> və 
</ul> teqləri nəzərdə tutulmuşdur. Bu teqin yazılış formatı 
belədir: 

<ul alıgn  = center|left| right| justifu type = disk|circle|square> 
<li siyahının 1-ci elementi </lı> 
<li siyahının 2-ci elementi </lı> 

    … 

<li siyahının n-ci elementi </lı> 

 </ul>  

<ul> və </ul> teqləri siyahının sərhədlərini və onun bütün 
elementlərinin formatlaşdırılma parametrlərini müəyyən 
edir. Type parametri markerin tipini müəyyən edir. 
Parametrin disk qiymətində siyahı üçün dairəvi rəngli 
marker, circle qiymətində dairəvi rənglənməmiş marker, 
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square qiymətində isə kvadrat marker əks olunur.  Siyahının 
hər bir elementi  <li> …</li> cüt teqi daxilində verilir.  

2. Nömrələnmiş siyahı; Nömrələnmiş siyahı nömrələnmiş 
abzasların ardıcılığından ibarətdir. Html dilində 
nömrələnmiş siyahının təyin edilməsi üçün <ol> və </ol> 
cüt teqlərindən istifadə olunur. Onun yazılış formatı 
aşağıdakı kimidir: 

<ol alıgn =center| left| right| justifu start = başlanğıc 
qiymət type =A|a|İ|i|1> 

<lı siyahı elementi1 </lı> 
<lı siyahı elementi2 </lı> 
  … 

</ol> 

     <ol> və </ol> teqlərinin start parametri siyahının 
nömrələnməsinin hansı qiymətlə başlanmasını, type 
parametri  isə siyahının nömrələnmə tipini müəyyən edir.  
Type parametrin 1 qiymətində siyahı elementləri ərəb 
rəqəmlərilə,  parametrin A və ya a qiymətində müvafiq 
olaraq latın əlifbasının böyük və kiçik hərflərilə, parametrin 
İ və ya i qiymətində Roma ədədləri vasitəsilə nömrələnir.  
Siyahının hər bir elementi  <li> …</li> cüt teqi daxilində 
verilir. 

3. Təyin etmə siyahıları; Çox vaxt müəyyən terminlərə və 
anlayışlara malik olan siyahıları yaratmaq lazım gəlir. Belə 
siyahılar təyinetmə siyahıları adlanır. Onların yaradılması 
üçün html sənədlərində <dl>...</dl> teqindən istifadə olunur. 
Onun yazılış formatı aşağıdakı kimidir: 

<dl>  
<dt> termin </dt> 
<dd> təyinetmə </dd> 
<dl> 
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     Təyinetmə siyahısının sərhədləri müvafiq olaraq, <dl> və 
</dl> teqləri ilə təyin olunur. Siyahının hər bir elementi iki 
komponent vasitəsi ilə yaranır. Birinci komponent  <dt> və 
</dt> teqləridir və  təyin olunan terminlər onun daxilində 
yazılır. Brauzerlərdə html səhifəsinin əks olunması zamanı 
təyinetmə siyahısının terminləri səhifənin əsas mətnindən 
şriftin tündlüyünə görə fərqlənir. İkinci komponent isə 
müəyyən edilmiş terminlərdir. Onun göstərilməsi üçün <dd> 
və </dd> teqlərindən istifadə olunur.   

Html dili  Web-səhifələrdə nəinki mətn, eləcə də qrafiki 
elementləri yerləşdirməyə imkan verir. Qrafiki obyektlərin 
yerləşdirilməsi üçün <ımage> teqindən istifadə olunur. Bu teq 
də cütdür və aşağıdakı yazılış formatına malikdir: 

<ımg src =  “qrafiki faylın url ünvanı” alt =  “əvəzedici 
mətn ”alıgn =nizamlama rejimləri heıght=m1   wıdth = m2 
border = m3 hspace=m4 vspace =m5. 1  
Yazılış formatında src parametri vacib sayılır və səhifədə əks 
olunacaq qrafiki faylın url ünvanını göstərir. Məsələn,  

Src= “http://www. bsu.az/kafedra/informatika/azad.gif” 
Alt parametri isə brauzerdə qrafiki obyektlərin əvəzinə əks 
olunan alternativ mətn tipli informasiyasını daxil etməyə imkan 
verir. Bu parametri göstərmək məsləhət görülür. Belə ki, bir 
çox istifadəçilər Web-səhifənin açılması vaxtını qısaltmaq 
məqsədilə öz brauzerlərində qrafiki obyektlərin əks olunma 
rejimini söndürürlər. Belə olduqda, alternativ mətn 
informasiyasına görə səhifədə əksolunmayan qrafiki element 
haqqında istifadəçidə  təsəvvür yaranır. Aşağıda alt  
parametrinin istifadəsinə dair nümunə verilmişdir: 

<ımg src = “mail.jpeg” alt = “elektron poçt”> 

                                                 
1 m1,m2,m3,m4,m5 qrafiki faylın ölçülərini təyin edən ədədlərdir. 
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Alıgn parametri mətnə nisbətən qrafiki obyektin nizamlama 
rejimini təyin edir. Nizamlamanın əsas rejimləri haqqında 
məlumat aşağıdakı cədvəldə verilmişdir: 

 

Rejim Təsvir 

Top  Mətnin yuxarı küncünə döğru nizamlama 
Nowidctlpar 
middle

Mətnin mərkəzinə döğru nizamlama 

Botom Mətnin aşağı küncünə döğru nizamlama 

Left Səhifənin sol küncünə döğru nizamlama 

Right Səhifənin sağ küncünə döğru nizamlama 

Wıdth və heıght parametrləri qrafiki obyektin, səhifədə əks 
olunması zamanı piksellərlə ölçüsünü (eni və hündürlüyünü də 
müvafiq olaraq) təyin edirlər. Border parametrindən qrafiki 
obyektin ətrafında əks olunan qrafiki çərçivənin enini 
göstərmək üçün istifadə olunur. Border  parametri  
buraxıldıqda, qrafiki obyektin ətrafında avtomatik çərçivə əks 
olunur. Qrafiki çərçivəyə ehtiyac olmadıqda, border = 0 
yazılışından istifadə etmək lazımdır. Hspace və vspace 
parametrləri şaquli və üfüqi istiqamət  üzrə buraxılan boşluğun 
ölçüsünu müəyyən etmək  üçün istifadə olunurlar. Bu  
parametrlər qrafiki obyektdən səhifənin mətninə və digər 
obyektlərə qədər olan məsafəni təyin edirlər. 

Web  səhifələrin təritibatı zamanı dizayn elementi kimi 
üfüqi xətlərdən istifadə etmək olar. Bu element bir səhifədə 
yerləşən sənədin müxtəlif hissələrini bir – birindən ayırmağa 
imkan verir. Ayrıcı üfüqi  xətlərin əlavə edilməsi üçün  html 
dilində <hr> teqdən istifadə olunur. Bu teqin yazılış formatı 
aşağıdakı kimidir:  
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<hr alıgn = left | right | center sıze = n1 wıdth=n2  
noshade>1 
Alıgn, sıze və wıdth parametrləri müvafiq olaraq xəttin  
səhifədə nizamlanmasını, uzunluğunu və qalınlığını, noshade 
parametri isə xəttin rəngləmə effektini bildirir.  

Hiperistinadlar 

Hiperistinadlar cari Web-səhifədən  digər səhifələrə və 
obyektlərə istinadı  təmin edirlər. Bundan əlavə hiperistinadlar 
Web-səhifənin müxtəlif hissələrinə keçidi təmin edir. 
Hiperistinadların müəyyən edilməsi üçün < a> və < /a> 
teqlərindən istifadə olunur. O, aşağıdakı yazılış formatına 
malikdir: 

<a href =  “istinad olunan  obyektin url ünvanı  “target =  
“freymin2 və ya pəncərənin adı “> mətn və ya obyekt < /a> 

 Href parametri istinad olunan  obyektin url ünvanını göstərmək 
üçün istifadə olunur. Sənəd brauzer pəncərəsində əks 
olunduqdan sonra,  hiperistinada müraciət zamanı məhz bu 
obyektə keçid olacaqdır. Məsələn, 

<a href href =“http://www.iıq.com“ < /a> 
<a> teqinin ikinci parametri olan target üçün qiymət olaraq 
obyektin açılacağı freymin adı göstərilə bilər. Əgər göstərilən 
adlı freym yoxdursa, o zaman hiperistinada müraciət etdikdə 
istinad olunan obyekt yeni pəncərədə əks olunacaq, target üçün 
müəyyən edilmiş  ad isə bu pəncərəyə veriləcəkdir.  

Səhifədə müəyyən hissələrə avtomatik keçidi təmin 
etmək üçün o hissələr əvvəlcədən nişanlanmalıdır. Bunun üçün 
aşağıdakı yazılış formasından istifadə olunur.  

< a name = nişanın adı> mətn və ya obyekt < /a> 

                                                 
1 n1, n2 -ədədlərdir. 
2 Bax: Freymlər. 
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Name parametri  nişanla qeyd olunmuş obyektə istinad 
etmək üçün href parametrində verilməsi vacib olan adın 
göstərilməsi üçün istifadə olunur. Məsələn, əgər Web-  səhifədə 
<a name = “chapter4“> teqinin vasitəsi ilə nişan müəyyən 
edilmişdirsə, həmin nişanla qeyd olunmuş obyektə istinadın 
yaradılması üçün aşağıdakı yazılışdan istifadə edilməlidir: 

< a href = “#chapter 4”>< /a> 

#- simvolu nişanın adını faylın adından fərqləndirməyə imkan 
verir. 

Cədvəllər 
Html sənədlərinin yaradılması zamanı cədvəllərdən 

geniş istifadə olunur. Cədvəldən əsasən səhifələrdə mətn, ədəd 
tipli informasiyanın, dizayn elementlərini nizamlanmış formada 
yerləşdirmək üçün istifadə olunur. Html sənədlərində 
cədvəllərin yaradılması üçün <table> və </table> cüt 
teqlərindən istifadə olunur. Onun yazılış formatı belədir: 

<table alıgn= left|right|center| wıdth=n1 border=n2 
cellspacıng =n3 cellpaddıng =n4> 

     <tr valıgn = left|right|center|justifu valıgn =   
      top| middle| bottom> 
     <td rowspan=n5 colspan = n6 alıgn = left|right|center| 
justifu valıgn = top |middle| bottom> wıdth =n6 bgcolor 
= “xananın fonunun rənginin kodu”> xananın mətni 
</td>1 
 <tr > 
<table> 

Table alıgn parametri yalnız cədvəlin (cədvəlin xanalarındakı 
informasiyanı yox!) nizamlama rejimini müəyyən edir. 
Cellspacıng parametri cədvəlin xanaları arasındakı intervalı 

                                                 
1 n1,n2,n3,n4,n5,n6 konkret ədədlərdir. 
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piksellərlə göstərməyə imkan verir. Cellpaddıng parametri 
piksellə xanaların ölçüsünü  müəyyən edir. 

Cədvəlin hər bir sətri <tr> və </tr> teqləri ilə müəyyən 
olunur. Bu teq cədvəlin hər bir sətri üçün ayrılıqda 
formatlaşmanın əsas parametrlərini göstərməyə imkan verir. 
Alıgn parametri xanadakı informasiyanın şaquli istiqamətdə, 
valıgn parametri isə üfiqi istiqamətdə, xananın yuxarı, aşağı 
sərhədinə və  mərkəzə görə nizamlayır. 

Cədvəlin xanasının formatlaşma parametrləri cüt  <td> 
və </td> teqləri daxilində yazılır. Bgcolor parametri xananın 
fonunun rəngini göstərməyə imkan verir. Cədvəlin bir neçə 
sətrinin və ya sütununun birləşməsindən yaranan xana 
yaratmaq üçün rowspan və colspan parametrlərindən istifadə 
olunur. Məsələn, 

<table width="170" border="0" cellspacing="1" 
cellpadding="1"> 
<tr bordercolor="#ff0000"> 
<td width="26" nowrap bordercolor="#000000" 
gcolor="#0000ff"> </td> 
<td width="57" nowrap bgcolor="#ff0000>azad</td> 
 <td width="107" nowrap 
bgcolor="#0099ff">55</span></td> 
  </tr> 
  <tr bordercolor="#ff0000"> 
    <td nowrap bordercolor="#000000" 
bgcolor="#0000ff">2</td> 
    <td nowrap bgcolor="#ff0000">sima</td> 
    <td nowrap bordercolor="#ff0000" 
bgcolor="#0099ff">67</td> 
  </tr> 
  <tr bordercolor="#ff0000"> 
    <td nowrap bordercolor="#000000" 
bgcolor="#0000ff"></td> 
    <td nowrap bgcolor="#ff0000">sevinc</td> 
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<td nowrap bgcolor="#0099ff">78</td> 
</tr> 
</table>  

Yazılışı 3x3 ölçülü aşağıdakı  cədvəlin brauzer pəncərəsində 
əks olunmasını təmin edir.  

1 Azad 55 
2 Sima 67 
3 Sevinc 78 

 

 

Formalar 
Formalar dinamik Web-saytların əsas elementi sayılır. 

İstifadəçi forma elementlərindən istifadə edərək, müəyyən 
məlumatları  server əlavəsinə ötürə bilər, Web-saytın müəyyən 
səhifələrinə keçidi və digər əməlliyyatları yerinə yetirə bilər.  

Formanın   Web-səhifəyə daxil olunması üçün <form> 
teqindən istifadə olunur. Onun yazılış formatı belədir:  

<form actıon = ”server əlavəsinin url ünvanı” method 
= get|post enctype = forma verilənlərinin 
kodlaşdırılması”> forma elementləri <form> 

Actıon parametri <form> teqinin əsas parametri sayılır. Bu 
parametr server əlavəsinin ünvanını müəyyən edir. Method və 
enctype əlavə parametrləri isə verilənlərin ötürülməsi və 
kodlaşdırılmasını müəyyən edirlər.  

Qeyd etmək lazımdır ki, formalar özündə idarəetmə 
elementlərini saxlayırlar. Bu elementlərə aşağıdakılar aiddir: 

Text field  
Check box  
Radio buttons  
Тextarea 
Мenu 
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List  
              Botton. 

Text field. Element serverə ötürələcək mətn tipli 
məlumatların daxil edilməsini təmin edən Web-səhifədə  mətn 
sahəsinin əks olunmasını təmin edir. Formaya bu elementi daxil 
etmək üçün aşağıdakı yazılış formatından istifadə olunur: 

<input name="textfield" type="text" value="mətn" size="n1" 
maxlength="n2"> 

Name parametri elementin adını, type parametri daxil 
edilən mətnin tipini təyin edir və text və ya password qiymətləri 
alır. Parametrin password qiymətində mətn sahəsinə daxil 
edilən bütün simvolların əvəzinə ulduz (*) simvolu əks olunur. 
Bu sahədən istifadəçinin identifikasiyası üçün xüsusi parolu 
daxil etmək tələb olunduqda istifadə olunur. Value parametri 
səhifə yükləndikdə avtomatik olaraq mətn sahəsində əks olunan 
informasiyanı müəyyən edir. Size parametri daxiletmə 
sahəsinin enini, maxlength  parametri isə bu sahəyə daxil 
ediləcək sətrin mümkün maksimal uzunluğunu müəyyən edir. 
Məsələn, 
<input name="textfield" type="password" value="sima" 
size="12" maxlength="121"> 

Check box və radio buttons elementləri serverə ötürülə-
cək parametrin iki qiymətdən birini aldığını göstərmək üçün 
istifadə edilir.  

Formaya bu elementi daxil etmək üçün aşağıdakı yazılış 
formatından istifadə olunur: 

<input name="checkbox" type="checkbox" 
value="checkbox" checked> 

və ya  
<input name="radiobutton" type="radio" 
value="radiobutton" checked> 
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Name parametri elementin adını, value parametri səhifə 
yükləndikdə sahənin seçim rejiminin aktiv olmasını 
tənzimləyir. Belə ki, value parametri checked qiyməti aldıqda 
seçim rejimi aktiv olur.  

Тextarea elementi çoxsətrli  mətn sahəsinin formaya 
daxil edilməsini təmin edir və aşağıdakı yazılış formatına 
malikdir:  

<textarea name="textfield" cols="n1" 
rows="n2">”mətn” </textarea> 

Name parametri elementin adını, cols parametri sətrdə 
simvolların sayını, rows parametri isə sətrlərin sayını təyin edir. 
</textarea> teqindən əvvəl isə səhifə yükləndikdə avtomatik 
olaraq çox sətrli mətn sahəsində əks olunan informasiyanı 
müəyyn edir. 

Мenyu. Element «açılan siyahıların» yaradılmasını təmin 
edir. Formaya «açılan siyahıları» daxil etmək üçün  aşağıdakı 
yazılış formatından istifadə olunur: 

<select name="select"> 
 <option>element 1</option> 
       ... ... 
 <option> element n</option> 
 </select> 

Name parametri elementin adını təyin edir. Siyahının 
elementləri isə <option> və </option> teqləri arasında yazılır. 
Məsələn,  

 <select name="select"> 
 <option>Azad </option> 
 <option>Ilham </option> 
 <option> Rafiq</option> 

       </select> 

List. Element «çoxsətrli siyahıların» yaradılmasını təmin 
edir. «Çoxsətrli siyahıları» daxil etmək üçün isə aşağıdakı 
yazılış formatından istifadə olunur: 
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<select name="select" size="4" multiple> 
 <option> element 1</option> 
                  … 
  <option> element n</option> 
  </select> 

Multiple parametrləri siyahıda bir neçə müxtəlif variantı qeyd 
etməyə imkan verir. Bu parametr göstərilmədikdə istifadəçi 
siyahıda göstərilən variantlardan ancaq birini seçə bilər.  

Botton. Element formaya istifadəçinin təyin etdiyi 
informasiyaları serverə göndərmək üçün submit  düyməsinin və 
informasiyanın pozulmasını təmin edən reset düyməsinin daxil 
edilməsinə xidmət edir. Onun yazılış formatı belədir:  

<input type="submit" name="submit" value="Send"> 
<input type="reset" name="Reset" value="Erase"> 

Name parametri elementin adını, value parametri düymənin 
üzərində əks olunan yazını təyin edir. 

Freymlər 
Freymlər – brauzerin bir pəncərəsində bir neçə sənədin 

əks olunmasını təmin edir. Freymlərdən istifadə zamanı 
brauzerin işçi sahəsinin pəncərəsi müxtəlif html sənədlərinin 
əks olunduğu bir neçə kiçik sahələrə bölünür.  

Html dilində freymlərin müəyyən edilməsi üçün 
<frameset> və </frameset> teqindən istifadə olunur. Onun 
yazılış formatı belədir: 

<frameset rows =n1 cols =n2> </frame src = başlanğıc 
səhifənin url ünvanı” name = freymin adı ”margin wıdth 
=n3  marginheıght = n4 scrollıng = yes| no|avto| noresize> 
<frameset> 
<noframes><body> 

Src parametri   freymdə əks olunan səhifənin url ünvanını təyin 
edir. Freymdə səhifə sürüşdürücülərinin əks olunma rejimini 
göstərmək üçün scrollıng parametrindən istifadə olunur. Bu 
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parametrin qiyməti yes olduqda, o zaman freymdə 
sürüşdürücülər görünür, parametrin qiyməti no olduqda 
sürüşdürücülər əks olunmur, avto olduqda isə  sürüşdürücülər 
yalnız informasiya freymin görünən sahəsi hüdudlarına 
yerləşmədikdə əks olunurlar. Parametrin noresize qiymətində 
baxış zamanı freymin ölçülərinin dəyişdirilməsi qadağan 
olunur.  
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1.3. ULEAD GIF ANIMATOR 
 

Ulead GIF Animator proqramı daxil edilmiş video və 
rəsm kadrlarına müəyyən effektlər tətbiq etməklə, gif geniş-
lənməsinə malik  animasiyaların  yaradılmasını və redaktəsini 
təmin edir.   

Proqram ilk dəfə yükləndikdə proqramın interfeys 
pəncərəsinin mərkəzində Startup Setup Wizard dialoq pəncərəsi 
əks olunur (şək.1). Dialoq pəncərəsi animasiya faylını 
yaratmaq, on-line olaraq  proqramın öyrədici sistemi ilə tanış 
olmaq, şəkil və video fayllarının, hazır animasiya fayllarının 
açmaq  rejimlərini təklif edir. İstifadəçi Do not show this dialog 
box next time qeyd sahəsini aktivləşdirməklə sonrakı 
yükləmələr zamanı onun əks olunmamasına nail ola bilər. Belə 
olduqda proqram yükləndikdə avtomatik olaraq yeni animasiya 
yaratma rejimi müəyyən olunur və istifadəçi animasiyanın 
yaradılmasına başlaya bilər. 

 
Şək.1. 
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Proqramın interfeys pəncərəsi başlıq, menyu sətrlərindən 
işçi sahədən və istifadəçinin təlabatından  asılı olaraq Standart 
toolbar, Attribute toolbar, Tool Panel, Object Manager Panel, 
Frame Panel panellərindən və Status Bar- cari vəziyyət 
sətrindən ibarət olur. Bu panellərin ekranda əks olunması 
müvafiq olaraq View→ Standart toolbar, View→ Attribute 
toolbar, View→ Tool Panel, View→ Object Manager Panel, 
View→ Frame Panel əmrləri ilə tənzimlənir. İşçi sahə üç 
bölmədən ibarətdir: Edit, Optimize, Preview. Animasiyanın 
yaradılması və redaktəsi işçi sahənin Edit bölməsində, kadrlara 
əlavə edilmiş rəsmlərin optimallaşması Optimize bölməsində 
yerinə yetirilir. İşçi sahənin Preview bölməsində isə  
animasiyanın nümayişi yerinə yetirilir. Nümayiş zamanı ayrı-
ayrı kadrlar bir-birini əvəz edir. Qeyd edək ki, hazır 
animasiyanın nümayişinə həmçinin View→Play Animation və 
View→Browser Preview əmrlərni yerinə yetirməklə nail 
olmaq olar1.   

Yeni animasiya istifadəçi tərəfindən və  usta rejimi 
vasitəsilə yaradıla bilər.  Usta rejimi vasitəsilə animasiya faylı 
yaratmaq üçün  File → Animation Wizard  əmrini yerinə 
yetirmək lazımdır. Bu zaman açılan usta rejiminin ilk 
pəncərəsində şəklin ölçüsünü müəyyən etmək, növbəti 
pəncərədə Add İmage və ya Add Video  düymələrini sıxmaqla 
müvafiq olaraq  animasiyanın yaradılması üçün istifadə olunan 
şəkil və ya video faylları daxil etmək, sonrakı açılan pəncərədə 
animasiya kadrlarının görünmə sürətini müəyyən etmək və 
sonuncu pəncərədə Finish və ya Qotovo düyməsini sıxmaq 
lazımdır (şək.2-5)2.  

                                                 
1View→Stop Animation əmrini yerinə yetirməklə animasiyanın nümayişini 
dayandırmaq olar. 
2 Növbəti pəncərəyə keçid usta rejiminin cari pəncərəsində yerləşən Next >> 
və ya  Dalee >> düyməsini sıxdıqda baş verir. 
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Şək.2.                                     Şək.3. 

  
                          Şək.4.                                     Şək.5. 

  
Yeni animasiyanı yaratmaq üçün File → New əmrini 

yerinə yetirmək, açılan dialoq pəncərəsində şəklin ölçülərini 
müəyyən etmək və OK düyməsini sıxmaq lazımdır. 

 
Şək.6. 

Bu zaman işçi pəncərəsinin Edit bölməsində boş kadr sahəsi 
yaranır.  Sonrakı addımda,  File →Add İmage və ya Add 
Video əmrini yerinə yetirmək, açılan eyni adlı dialoq 
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pəncərəsində şəkil və ya video faylının ünvanını müəyyən 
etmək lazımdır. Daha sonra Frame→Add Frame əmrini 
yerinə yetirib animasiyaya yeni boş kadrlar əlavə etmək və 
təkrarən File →Add İmage və ya Add Video  əmrini yerinə 
yetirməklə hər bir kadra şəkil və ya videokadrlar əlavə etmək 
lazımdır. Kadra bir deyil, bir neçə rəsm və mətn effekti əlavə 
etmək olar.    

 Kadrlarda rəsmlərin əks olunması və kadrların bir-birini 
əvəz etməsi müəyyən effektlərlə müşaiyət oluna bilər. Bu 
effektləri tətbiq etmək üçün Video F/X menyusunun aşağıdakı 
əmrlərindən birini yerinə yetirmək lazımdır: 
• 3D→ Gate 3D  əmri «qapıların açılması» effektini;  
• Build→Diagonal- Build əmri «diaqonal üzrə rəsmin 
kəsilməsi» effektini; 
• Clock→Sweep -Clock əmri saat və ya saatın əksi 
istiqaməti üzrə rəsmin kəsilməsi effektini; 
• F/X→Diamond A-F/X əmri rəsmin əks olunması üçün 
«romb»  effektini; 
• F/X→Iris -F/X əmri kadrın dəyişdirilməsi üçün «açılan 
gül» effektini; 
• F/X→Mosaic- F/X əmri kadrların dəyişdirilməsi üçün 
«mozaika» effektini; 
• F/X→Power Off- F/X əmri kadrların dəyişdirilməsi 
üçün  «ekranının tədricən söndürülməsi effektini; 
• Film→Flap B-Film əmri kadrların dəyişdirilməsi üçün 
rəsmin hissələrinin tədricən «kəsilməsi» effektini; 
•  Film→Proqressive-Filməmri kadrlarındirilməsi üçün 
rəsmin hissələrinin tədricən əvəz edilməsi effektini; 
• Film→Turn Page-Film kadrların dəyişdirilməsi üçün 
«şəffav səhifənin» çevrilməsi effektini; 
• Peel→Page-Pell əmri kadrların dəyişdirilməsi üçün 
«fonlu səhifənin çevrilməsi» effektini; 
• Push→Run and Stop Push əmri kadrların 
dəyişdirilməsi üçün rəsmin ekrandan «sıxışdırılması» effektini; 
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•  Roll→Side-Roll əmri kadrların dəyişdirilməsi üçün 
«səhifənin burulması» effektini; 
• Slide→Bar Slide əmri kadrların dəyişdirilməsi üçün 
«rəsmin yarıya bölünərək sürüşdürmə» effektini; 
•  Stretch→Cross Zoom – Stretch əmri kadrların 
dəyişdirilməsi üçün rəsmin miqyasının böyüdülməsi effektini; 
•  Wipe→Star Wipe əmri kadrların dəyişdirilməsi üçün 
beş guşəli ulduz formasında təsvirin kəsilməsi effektini; 
• 2D Mapping→Croppring  əmri rəsmin əks olunması 
üçün «düzbucaqlı çərçivənin böyüdülməsi» effektini; 
• Camera Llens→ColorReplace rəsmdə qara rəngin 
tədricən göy rənglə əvəz olunma effektini; 
• Camera Lens→Gradient əmri kadrların dəyişdirilməsi 
üçün rəsmdə rəng çalarlarının tədricən dəyişdirilməsi effektini; 
• Camera Lens→Mirror əmri kadrların dəyişdirilməsi 
üçün rəsmin  «dalğavari əks olunma» effektini; 
• Camera lens→Zoom Motion əmri kadrların 
dəyişdirilməsi üçün rəsmin «şəfəq saçma» effektini; 
• Darkroom→Hue& Saturation, Nature Painting→ 
Charcoal, Naturae Painting→Colored Pen, Special →Add 
Noise  əmrləri kadrların dəyişdirilməsi üçün rəsmdə tədricən 
rəngin müxtəlif formalarda qarışdırılması effektlərini; 
• Special→Wind əmri kadrların dəyişdirilməsi üçün 
rəsm üçün «bayraq dalğalanması» effektini təmin edir.  
Qeyd edək ki, əmrləri yerinə yetirdikdə açılan müvafiq dialoq 
pəncərələrində seçilmiş effekt üçün nizamlama parametrlərini 
dəyişməklə effektin nümayişini tənzimləmək olar. İstifadəçi, 
Video F/X menyusunun About Video F/X əmrini yerinə 
yetirməklə yuxarıda sadalanan effektlər haqqında daha geniş 
məlumat ala bilər. 

Animasiya fayllarında müxtəlif mətn effektlərindən də 
istifadə olunur. Bunun üçün Frame →Add Text Banner  
əmrini yerinə yetirmək və açılan dialoq pəncərəsinin Text 
bölməsində  mətni daxil etmək, Effect bölməsində mətn üçün 
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effekt, Frame Contlor  sahəsində kadrların əvəz olunma 
sürətini, Neon bölməsində isə mətn üçün işıqlandırma effektləri 
üçün müvafiq parametrləri müəyyən etmək lazımdır (şək.7-10). 
Start Preview  düyməsini sıxmaqla animasiyaya baxmaq olar. 
OK düyməsini sıxdıqda animasiya yaranır və kadrlar Frame 
Panel- kadr  panelində  əks olunur. 

      
                        Şək.7.                                              Şək.8. 

      
                        Şək.9.                                             Şək.10. 

Yaradılmış animasiyanı yaddaşda saxlamaq üçün File→ Save 
əmrini yerinə yetirmək lazımdır. File→ Save As→Gif file, 
File→ Save As→UGA file, File→ Save As→UFO file, File→ 
Save As→PSD file, File→ Save As→Video file, File→ Save 
As→Macromedia Flash əmrlərini yerinə yetirməklə müvafiq 
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olaraq animasiyanı Gif, UGA, UFO , PSD, Video və 
Macromedia Flash faylı kimi  yaddaşda saxlamaq olar. File→ 
Save As→Image Frames əmri isə animasiyanın hər bir kadrını 
rəsm faylı kimi yaddaşda saxlanmasını təmin edir. File→ 
Export→As HTML File, File→ Export→As an Active 
Desktop Item, File→Export→As Animation Package(EXE) 
əmrlərini yerinə yetirməklə animasiya faylını müvafiq olaraq 
HTML faylına, İşçi stol elementinə və exe genişləməsinə malik 
özü yerinə yetirilən animasiya faylına çevirmək olar. File→ 
Export→As an Active Desktop Item əmrini yerinə yetirdikdə  
açılan Active Desktop Item  dialoq pəncərəsində elementin İşçi 
stolun harasında yerləşməsini müəyyən etmək lazımdır 
(şək.11). 

 
Şək.11. 

File→ Export→As Animation Package(EXE) əmrini yerinə 
yetirdikdə isə açılan dialoq pəncərəsində istifadəçi 
animasiyanın nümayişinin musiqilə müşayət olunması, 
animasiyanın nümayişi qurtardıqdan sonra konkret sənədə 
istinad olunması və s. parametrləri tənzimləyə bilər (şək.12). 
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Şək.12. 

Proqram animasiya faylı üzərində aşağıdakı redaktə 
əmliyyatlarını aparmağı təmin edir: 
• Kadrların yerini dəyişmək;  Bunun üçün aşağıdakı 
əmrlərdən birini yerinə yetirmək lazımdır:  

Frame→Change Frame Order→ Assign as First Name 
Frame→Change Frame Order→ Assign as Last  Name 
Frame→Change Frame Order→Move Frame Backward 

Frame→Change Frame Order→ Move Frame Forward . 
Belə ki, Frame→Change Frame Order→ Assign as First 

Name əmri qeyd olunmuş kadrı animasiyanın ilk, 
Frame→Change Frame Order→ Assign as Last  Name  
əmri qeyd olunmuş kadrı animasiyanın son kadrı olmasını, 
Frame→Change Frame Order→ Move Frame Backward 
əmri qeyd olunmuş kadrı bir kadr sağa, Frame → Change 
Frame Order→ Move Frame Forward əmri qeyd olunmuş 
kadrı bir kadr sola yerdəyişməsini təmini edir. 
• Yeni kadr əlavə etmək; Animasiyaya yeni kadr əlavə etmək 
üçün Frame→Add Frame əmrini yerinə yetirmək lazımdır. 
• Cari kadrın surətini əlavə etmək; Animasiyaya cari kadrın 
və ya qeyd olunmuş kadrların surətini əlavə etmək üçün Frame 
→ Duplicate Frame(s) əmrini yerinə yetirmək lazımdır. 
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•    Cari və ya qeyd olunmuş kadrları ləğv etmək; 
Animasiyadan cari və ya qeyd olunmuş kadrları ləğv etmək 
üçün Frame→ Delete Frame(s) əmrini yerinə yetirmək 
lazımdır. 
•   Obyektə kölgə effekti vermək; Qeyd olunmuş obyektə-
şəkilə və ya mətnə  kölgə effekti vermək üçün 
Object→Shadow əmrini yerinə yetirmək və açılan dialoq 
pəncərəsində (şək.14) Shadow qeydetmə sahəsini 
aktivləşdirmək, kölgə üçün rəng və müxtəlif kölgə 
parametrlərini müəyyən etmək lazımdır. 
• Kölgəni obyektdən ayırmaq; Kölgə effektinə malik şəkil və 
mətndən kölgəni ayırmaq üçün Object→Split Shadow əmrini 
yerinə yetirmək lazımdır. Ayrılmış kölgə müstəqil rəsm 
obyektinə çevrilir.  

 
Şək.14. 

• Mətni redaktə etmək; Kadra daxil edilmiş mətni redaktə 
etmək üçün ilk öncə onu qeyd etmək,  Object→Text→Edit 
Text  əmrini yerinə yetirmək və açılan dialoq pəncərəsində 
(şək.15) mətni yenisi ilə əvəz etmək, mətnin şriftini, rəngini, 
şrift üçün stilləri dəyişmək, mətnin istiqamətini, şriftlər 
arasında intervalı və s. parametrləri müəyyən etmək olar. 
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Şək.15. 

• İşıqlandırma effektini dəyişdirmək; Kadra daxil edilmiş 
işıqlandırma effektinə malik mətndə işıqlandırma effektini 
dəyişmək üçün ilk öncə onu qeyd etmək,  
Object→Text→Neon  əmrini yerinə yetirmək və açılan dialoq 
pəncərəsində (şək.16) işıqlandırma effekti üçün yeni 
parametrləri müəyyən etmək lazımdır. 

 
Şək.16. 

• Mətni  hərflər üzrə ayırmaq; Kadra daxil edilmiş və 
qeyd olunmuş mətnin hərflər üzrə ayrılışına nail olmaq üçün 
Object → Text → Splite Text əmrini yerinə yetirmək 
kifayətdir. Bu zaman hər bir hərf müstəqil obyektə çevrilir. 
• Mətni şəkilə çevirmək; Kadra daxil edilmiş və qeyd 
olunmuş mətni şəkilə çevirmək üçün Object → Convert to 
Image  əmrini yerinə yetirmək lazımdır.  
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• Rəsmin ölçüsünü dəyişdirmək; Kadra daxil edilmiş 
rəsmin ölçüsünü dəyişdirmək üçün Edit →Resize İmage 
əmrini yerinə yetirmək və açılan dialoq pəncərəsində şəkilin 
yeni ölçülərini müəyyən etmək lazımdır (şək.17). 
• Kadr sahəsini rəsmin ölçüsünə görə tənzimləmək; Kadr 
sahəsini rəsmin ölçüsünə görə tənzimləmək üçün Edit → Crop 
Canvas əmrini yerinə yetirmək kifayətdir.  
• Kadr sahəsinin ölçüsünü dəyişmək; Kadr sahəsinin 
ölçüsünü dəyişmək üçün Edit→Canvas Size əmrini yerinə 
yetirmək və açılan dialoq pəncərəsində (şək.18) kadr sahəsi 
üçün yeni ölçülər və obyektin kadrda yerləşmə istiqamtini 
müəyyən etmək lazımdır. 

      
                       Şək.17.                                         Şək.18. 
• Kadra daxil edilmiş rəsm üzərində dəyişikliklər aparmaq; 
Bu əməliyyatlar Tool Panel  panelinin alətləri vasitəsilə 
asanlıqla yerinə yetirilir. 
• Kadra daxil edilmiş qeyd olunmuş obyektlərin və ya rəsm 
hissəsinin yerinin dəyişdirilməsi; Bunun üçün obyekti və ya 
rəsm hissəsini qeyd etmək, ardıcıl olaraq Edit→Cut  və 
Edit→Paste əmrlərini yerinə yetirmək və onu tələb olunan 
yerə sürüşdürmək lazımdır. 
• Kadra daxil edilmiş qeyd olunmuş obyektlərin və ya rəsm 
hissəsinin surətinin daxil edilməsi; Bunun üçün obyekti və ya 
rəsm hissəsini qeyd etmək, ardıcıl olaraq Edit→Copy  və 
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Edit→Paste əmrlərini yerinə yetirmək və surəti tələb olunan 
yerə sürüşdürmək lazımdır. 
• Kadra daxil edilmiş qeyd olunmuş obyektləri bir obyekt 
kimi qruplaşdırmaq; Bunun üçün obyektləri qeyd etmək, ardıcıl 
olaraq Object→Combine as Single Object əmrini yerinə 
yetirmək  lazımdır. 

Animasiya üzərində redaktə  əməliyyatlarından imtina 
etmək tələb olunduqda File→Restore  əmrini yerinə yetirmək 
lazımdır. 

Rəsmi optimallaşdırmaqla animasiya və ya rəsm faylının 
ölçüsünü mümkün qədər kiçiltmək olur. Rəsmi 
optimallaşdırmaq üçün kadra rəsmi əlavə etdikdən sonra işçi 
sahənin Optimize  bölməsinə daxil olmaq lazımdır. Proqramda 
avtomatik nəzərdə tutulmuş üsul əsasında şəklin optimallaşması 
baş verir1. Optimallaşma əməliyyatı başa çatdıqda, müqayisə 
aparmaq üçün şəklin optimallaşmadan əvvəl və sonrakı 
təsvirləri əks olunur (şək.19).  

 
Şək.19. 

                                                 
1 Avtomatik təyin olunan optimallaşma üsulunu dəyişmək də olar. Bunun 
üçün File→References əmrini yerinə yetirmək və açılan eyni adlı dialoq 
pəncərəsinin Optimize bölməsində siyahıdan tələb olunan üsulu seçmək və 
Set Selection As Default düyməsini sıxmaq lazımdır. 
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Nəticə istifadəçini qane edərsə o,  Save düyməsini 
sıxmaqla rəsmi yaddaşda saxlaya bilər. Optimallaşmanın 
nəticəsi kifayət qədər müvəffəqiyyətli olmadıqda, istifadəçi 
Atribute Tollbar panelinin Preset açılan siyahısından digər 
üsulu seçə bilər (şək.20). 

 
Şək.20. 

İstifadəçi həmçinin Atribute Tollbar panelinin sonuncu 
düyməsini - Show/Hide the Color Palette düyməsini sıxmaqla 
əks olunan və rəsmin rənglərini özündə saxlayan Color Palette  
rəng palitrası vasitəsilə rəsmdən müəyyən rəngi ləğv edə bilər, 
digər rəng ilə əvəz edə bilər. Bunun üçün palitradan tələb 
olunan rəngi  seçmək və müvafiq olaraq  Delete Color  və Edit 
Current Cell  düymələrini sıxmaq lazımdır.  

Rəsmi həmçinin File→ Optimization Wizard əmrini 
yerinə yetirməklə optimallaşdırmaq olar. Əmri yerinə 
yetirdikdə açılan Optimization Wizard dialoq pəncərəsində 
optimallaşma üsulunu seçmək və Finish düyməsini sıxmaq 
lazımdır (şək.21).  

Proqram paket formasında - bir neçə rəsmin eyni 
zamanda optimallaşmasını da təmin edir. Bunun üçün 
File→Batch Process əmrini yerinə yetirmək lazımdır. Açılan 
eyni adlı dialoq pəncərəsində By folder variantını seçməklə 
şəkil qovluğunu müəyyən etmək və ya By files variantını 
seçmək və Select düyməsini sıxmaqla optimallaşmalı rəsmləri  
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müəyyən etmək, Optimization preset siahısından optimallaşma 
üsulunu seçmək və OK düyməsini sıxmaq lazımdır (şək.22).  

 

 
Şək.21. 

 
Şək.22. 

Paket formasında optimallaşdıqdan sonra optimalaşmış 
rəsmləri digər qovluqda saxlamaq üçün Create New Files: 
sahəsini aktivləşdirmək və qovluğun ünvanını müəyyən etmək 
lazımdır. Əlavə olaraq Delete original files sahəsini 
aktivləşdirdikdə rəsmlər optimallaşdıqdan və yeni qovluqda 
yaddaşda saxlandıqdan sonra  ləğv olunur. 
 



FƏSİL 1  Web tərtibat proqramları 

 

41

1.4. DREAMWEAVER MX  
 

Dreamweaver MX proqramı Web saytların yaradılması 
üçün nəzərdə tutulmuş ən yaxşı proqram hesab olunur. Proqram 
yükləndikdən sonra proqramın interfeys pəncərəsinin 
mərkəzində proqramla iş rejimi paneli əks olunur. Bu panelin 
Open a Recent Item bölməsinin müvafiq bəndləri vasitəsilə 
əvvəllər çağrılmış səhifələri,  mövcud Web səhifələri sənəd 
pəncərəsinə cağırmaq, Create New bölməsinin bəndləri 
vasitəsilə Web sayt, Web səhifə, Web server əlavələri  
yaratmaq, Create Item Samples bölməsinin bəndləri vasitəsilə 
isə kaskadlı stil cədvəlləri və Web-səhifə şablonları əsasında 
Web səhifələr yaratmaq olar.  

 
Şək.1. 

Proqramın interfeys pəncərəsi başlıq, menyu, və cari 
vəziyyət sətrlərinə və seçilmiş iş rejimindən asılı olaraq sənəd 
pəncərəsinə, xassə inspektoruna və müxtəlif panellərə malik 
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olur. Proqramda müxtəlif funksiyalar yerinə yetirən  Standard, 
Document, Insert, Properties, CSS Styles, Layers, Behaviors, 
Snippets, Reference, Databases, Brindings, Server Behaviors, 
Components, Files, Assets, Tag Inspector, Results, History, 
Frames, Code Inspector, Timelines panelləri nəzərdə 
tutulmuşdur 1 . Document, Insert və Standart panellərinin 
ekranda əks olunması müvafiq olaraq View ToolBars  
Document, View ToolBars Standart və View ToolBars 

 Insert əmrlərini yerinə yetirməklə, digər panellər isə 
Window menyusunun panelin adına uyğun əmrini yerinə 
yetirməklə tənzimlənir. View Hide Panels əmrini yerinə 
yetirməklə müəyyən edilmiş panellərin hamısının 
gizlədilməsini, View Show Panels əmrini yerinə yetirməklə 
isə gizlədilmiş panellərin pəncərədə əks olunmasına nail olmaq 
olar.  

Sənəd pəncərəsi üç bölmədən- Code, Desijn,  Split 
bölmələrindən ibarətdir.  Code və Desijn bölmələri müvafiq 
olaraq səhifənin və ya server əlavəsinin Code (HTML və ya 
XTML dilində) və Desijn rejimlərində görünüşünü, redaktəsini 
və yaradılmasını, Split bölməsi isə eyni zamanda   Code və 
Desijn rejimlərinin aktiv olmasını təmin edir. Adətən yeni 
yaradılan və ya redaktə məqsədi üçün çağrılan səhifə və ya 
server əlavəsinin sənəd pəncərəsinin Desijn bölməsində əks 
olunur. Qeyd edək ki, istifadəçi proqramın müvafiq parametrini 
dəyişməklə yeni yaradılan və ya redaktə məqsədi üçün çağrılan 
səhifə və ya server əlavəsinin həmişə sənəd pəncərəsinin Code  
bölməsində əks edilməsini tənzimləyə bilər. Bunun üçün o,  
Edit Preferences  əmrini yerinə yetirib, açılan Preferences 
pəncərəsinin Change Workspace… düyməsini sıxmalı və  
Workspace Setup dialoq pəncərəsində Coder variantını 
seçməlidir (şək.2).    

                                                 
1 Sonrakı paraqraflarda bu panellərdən  istifadə qaydaları şərh edilmişdir. 
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 Şək.2. 

Sənəd pəncərəsinin Desijn bölməsində xətkeşin əks olunmasını  
View Rulers  Show əmrini yerinə yetirməklə tənzimləmək 
olar. View Rulers  Pixels, View Rulers  Inches, 
View Rulers  Centimeters  əmrlərini yerinə yetirməklə isə 
xətkeş şkalası üçün müvafiq olaraq ölçü vahidi olaraq pixels, 
inches, cantimetr  təyin edirlər. İstifadəçinin zövqündən asılı 
olaraq sənəd pəncərəsinin Desijn bölməsində  şəbəkə də əks 
oluna bilər. Şəbəkənin əks olunması  View Grid  Show 
Grid əmri ilə, şəbəkənin parametrləri isə View Grid  Grid 
Settings  əmrini yerinə yetirdikdə açılan dialoq pəncərəsinin 
müvafiq parametrlərini dəyişməklə tənzimlənir (şək.3). 
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Şək.3. 

 
 
 

1.4.1.  Web saytlar ın yarad ılmas ı  
 
Web sayt  uzaq məsafədə, lokal şəbəkədə yerləşən Web 

serverlərdə və ya lokal kompüterdə yaradılır. Uzaq məsafədə 
yerləşən serverdə saytın yaradılması üçün İnternetin FTP 
xidmətindən istifadə olunur. Lakin bu xidmət pullu 
olduğundan,   Web sayt adətən lokal şəbəkədə yerləşən Web 
serverdə və ya lokal kompüterdə yaradılır. Sayt lokal 
kompüterdə yaradılıb  testdən keçirildikdən sonra İnternet 
şəbəkəsi və ya uzaq məsafədən qoşulma vasitəsilə uzaq 
məsafədə yerləşən Web serverə köçürülür.  

Web sayt yaratmaq üçün ilk öncə sayt təyin edilməlidir. 
Yeni sayt təyin etmək üçün kursoru proqram yükləndikdə 
açılan proqramla iş rejimi panelinn Create New bölməsində 
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yerləşən Dreamweaver Site sətrinin üzərinə qoyub siçanın sol 
düyməsini sıxmaq lazımdır1. Bu zaman Site Definition usta 
rejiminin ilk pəncərəsinin What would you like to name your 
site? sahəsində sayta ad vermək, Next düyməsini sıxıb növbəti 
pəncərədə saytın yaradılmasında server texnologiyalarının 
istifadə olunub-olunmamasını və əgər istifadə olunarsa konkret 
texnologiyanı müəyyən etmək və yenidən Next düyməsini 
sıxmaq lazımdır (şək.4-5). 

 
Şək.4. 

                                                 
1 Bu əməliyyat  həmçinin Site→Manage Site əmrini yerinə yetirmək və 
açılan Manage Site dialoq pəncərəsində New  düyməsini sıxmaqla da  
yerinə yetirilə bilər.  
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Şək.5. 

 Usta rejiminin növbəti pəncərəsində redaktə rejiminin 
sənədlərinin birbaşa serverdə və ya lokal kompüterdə yaradılıb 
redaktə olunması rejimini seçdikdə saytın yerləşəcəyi əsas 
qovluğun ünvanını müvafiq olaraq Where on Your computer 
do you want to store yur files və ya Where are your files on the 
network? sahəsinə  daxil etmək və ya qovluq nişanlı düyməni 
sıxmaqla açılan pəncərədə əks olunan fayl strukturundan  
müəyyən olunmalıdır. Əgər yeni qovluq yaradılması tələb 
olunursa Create New Folder düyməsini sıxmaq, qovluğa ad 
verib Save və ya Soxranitğ düyməsini sıxmaq lazımdır. Sonrakı 
pəncərədə serverlə əlaqə forması How do you connect to your 
remote server? açılan siyahıdan müəyyən olunmalıdır. Seçilmiş 
əlaqə formasına müvafiq olaraq  qoşulma parametrləri  
müəyyən olunmalı və Next düyməsi  sıxılmalıdır (şək.6-7). 
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Nəhayət informasiya xarakterli sonuncu pəncərə açılır və onun 
Done düyməsini sıxdıqda sənəd pəncərəsinin sağ tərəfində 
Sayt panelində saytın əsas qovluğu əks olunacaq. 

 
         Şək.6.      

 
Şək.7. 
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Sayt müəyyən olunduqdan sonra saytın tərkibnə daxil 
olan Web səhifələr, server əlavələri, kaskadlı stil cədvəlləri və 
s. yaradılmalıdır.  Adətən, sayt yaradıcılığında iki üsul tətbiq 
edilir: 

1)İlk öncə saytın strukturu-qovluqlar və Web sənədlərin 
yerləşmə ardıcıllığı müəyyən olunur və sonradan hər bir Web 
səhifənin və ya server əlavəsinin  tərtibatı ilə məşğul olurlar. 

2)Birbaşa saytın tərkibinə daxil olan Web sənədlərin 
yaradılmasına başlayırlar və bu yaradılma prosesi sona çatdıqda 
saytın strukturu formalaşır.  

Saytın strukturunu əvvəlcədən müəyyən etmək üçün 
sayta bu strukturu təşkil edən qovluqlar və Web-səhifələr əlavə 
etmək lazımdır.  Sayta qovluq əlavə etmək üçün File panelində 
kontekst menyunun New Folder əmrini yerinə yetirmək və 
qovluğa ad vermək lazımdır. Qeyd edək ki, qovluq əsas qovluq 
və ya yaradılmış yeni qovluq daxilində yaradıla bilər. Yeni 
Web səhifə yaratmaq üçün isə File panelində kontekst 
menyunun New File əmrini yerinə yetirmək və sənədə unikal 
ad vermək lazımdır. Həmçinin paneldə kontekst menyunun 
EDIT Delete əmrini yerinə yetirməklə qeyd olunmuş  
qovluqları və sənədləri  ləvğ etmək, EDIT Rename əmrini 
yerinə yetirməklə qeyd olunmuş qovluğun və sənədin adını 
dəyişdirmək olar. Qovluq və ya faylın yerini dəyişmək üçün 
onları qeyd etmək və tələb olunan yerə sürüşdürmək lazımdır. 
Sayta kompüterdə və digər informasiya daşıyıcılarında olan 
Web-səhifələri əlavə etmək üçün ilk öncə panelin Local Files 
siyahısından  informasiya  daşıyıcısını seçib (Desktop, Floppy 
disk 3.5(A), Local disk (C), CD-ROM(D) və s.), daşıyıcıda 
yerləşən  tələb olunan Web səhifələri  qeyd etmək, kontekst  
menyunun Copy əmrini yerinə yetirib, onların surətini 
mübadilə buferinə köçürmək, panelin Local Files siyahısından  
saytı seçmək və kontekst menyunun  Paste əmrini yerinə 
yetirmək lazımdır. 
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Saytın strukturunu müəyyən etdikdən sonra ilk öncə əsas  
səhifə müəyyən olunmalıdır. Bunun üçün səhifə qeyd 
olunduqdan sonra kontekst menyunun Set as Home Page əmri 
yerinə yetirilməlidir. Saytda səhifələrarası əlaqələri təyin etmək 
üçün  File panelinin rejim  siyahısından Mape View seçməklə, 
saytın xəritəsi rejimini müəyyən etmək lazımdır. Əsas səhifə 
xəritədə əks olunacaqdır.  Sonradan əsas səhifəni  qeyd etmək 
və kontekst menyunun  Link to Existing File əmrini yerinə 
yetirmək, Select HTML Link dialoq pəncərəsində istinad 
olunacaq sənədi seçmək lazımdır. Yeni sənədlərlə əlaqə 
yaratmaq üçün isə kontekst menyunun Link to New File əmrini  
yerinə yetirmək və açılan dialoq pəncərəsində müvafiq olaraq 
sənədin ünvanını, sərlövhəsini, və istinad mətnini daxil etmək 
lazımdır (şək.8). Eyni qayda ilə sənədlər arasında hiperəlaqələr 
müəyyən olunur.  

 
Şək.8. 
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İkinci üsulla sayt yaratdıqda hər yeni Web sənəd yaratmaq 
üçün File New əmrini yerinə yetirib, açılan eyniadlı  dialoq 
pəncərəsinin General bölməsinin  Category sahəsində sənəd 
növünü və sənəd növünə uyğun şablonu seçmək,  sənədin 
XMTL dilində yaradılması tələb olunarsa Make document 
XMTL compilant parametrini seçmək və Create düyməsini 
sıxmaq lazımdır (şək.9). Sənəd həmçinin istifadəçi tərəfindən 
yaradılan şablon əsasında da yaradıla bilər. Bunun üçün dialoq 
pəncərəsinin Templates bölməsinə daxil olub, müvafiq şablonu 
seçib Create düyməsini sıxmaq lazımdır.  

 
Şək.9. 

 

1.4.2. Sadə Web-səhifələrin tərtibatı  və yaddaşda 
saxlan ılmas ı 
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Web-səhifənin tərtibatı Design (Konstruktor) və ya Code 
(Kod) rejimində həyata keçirilə bilər1. Code rejimində səhifənin 
tərtibi HMTL və ya XMTL dilinin elementlərini klaviaturadan 
daxil etməklə həyata keçirilir.  Design rejimində isə səhifənin 
tərtibi  WYSIWYG ("What You See Is What You Get 2 ") 
prinsipinə əsaslanır. Design rejimində səhifənin hazırlanması 
daha asan olub, tez başa gəlir və buna görə də praktikada ondan 
daha çox istifadə edirlər. 

Hər bir səhifənin hazırlanmasında aşağıdakı 
komponentlərdən istifadə etmək olar: 

• Mətn; 
• Siyahı;  
• Cədvəllər;  
• Hiperistinadlar; 
• Qrafiki təsvirlər; 
• Multimedia faylları (audio, video, animasiya, Flash və 

s. fayllar); 
• Skript və apletlər;  
• Naviqasiya elementləri;  
• Forma və s. 

Mətn. Mətn hər bir səhifənin məcburi elementidir. Mətn 
klaviaturadan və ya Edit → Paste əmrini yerinə yetirməklə 
mübadilə buferindən daxil edilə bilər. Mətn həmçinin File → 
Import Word Document əmrini yerinə yetirməklə Word 
sənədindən də daxil edilə bilər. Əmri yerinə yetirdikdə açılan 
dialoq pəncərəsində Word sənədinin ünvanını müəyyən etmək 
və Open və ya Otkrıtğ düyməsini sıxmaq lazımdır. 

Səhifənin Internet brauzerində qüsursuz görünüşünə nail 
olmaq üçün mətni UNICOD şriftləri əsasında daxil etmək 

                                                 
1  Bu rejimlər sənəd pəncərəsinin eyni adlı bölməsinə daxil olduqda 
aktivləşirlər. 
2 Azərbaycan dilinə tərcümədə «Nə edirsən, onu da görürsən» deməkdir  
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lazımdır. Mətn üçün şrift müəyyən etmək üçün Text      Font  
< şriftin adı> əmrini yerinə yetirmək lazımdır (şək.10). 

 
Şək.10. 

Tələb olunan şrift əmrlər siyahısında olmadıqda istifadəçi Text 
→ Font → Edit Fond List əmrini  yerinə yetirməklə şrifti 
siyahıya daxil edə bilər. Bunun üçün əmri yerinə yetirdikdə 
açılan Edit Font List dialoq pəncərəsində (şək.11)  + 
düyməsini sıxmaq, Available Fonts: siyahısında tələb olunan 
şriftləri seçib << düyməsini sıxmaqla Chosen Fonts siyahısına 
əlavə etmək və OK düyməsini sıxmaq lazımdır.  

 
Şək.11. 
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Həmçinin şriftləri siyahıdan ləğv etmək olar. Şrifti siyahıdan 
ləğv etmək üçün Edit Font List dialoq pəncərəsinin Font List 
şrift siyahısından ləğv olunacaq şriftləri qeyd edərək - 
düyməsini sıxmaq və OK düyməsini sıxmaq lazımdır. 

Şriftin ölçüsü Text →  Size → <ölçü siyah ıs ı>, stili 
Text → Style  → <stil siyah ıs ı> əmrləri vasitəsilə müəyyən 
olunur (şək.12-13 ). Şriftin ölçüsü üçün 7 ölçü səviyyəsi 
nəzərdə tutulmuşdur. Mətn üçün standart şrift ölçüsü 3 hesab 
olunur. Şriftin rəngi isə Text → Color əmrini yerinə yetirdikdə 
açılan rəng palitrasından müəyyən edilir.   

             
               Şək.12.                                                       Şək.13. 

Mətn daxilində xüsusi simvollardan: ©, ®,™, £,¥,€,“,”,—
istifadə etmək üçün müvafiq olaraq Insert  HTML → Special 
Characters →  Copyright, Insert → HTML→    Special 
Characters  →  Registered, Insert  →  HTML→   Special 
Characters  → Trademark, Insert →  HTML→   Special 
Characters →  Pound, Insert  → HTML  →   Special 
Characters →  Yen, Insert →  HTML → Special 
Characters →  Euro, Insert →  HTML →  Special 
Characters →  Left Quote, Insert →  HTML →  Special 
Characters →  Right Quote,  Insert →  HTML →  Special 
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Characters →  Em-Dash əmrlərindən birini yerinə yetirmək 
lazımdır. Əmr siyahısında olmayan simvolun daxil olunması 
üçün isə Insert → HTML →  Special Characters →  Other 
əmrini yerinə yetirmək və tələb olunan simvolu açılan Insert 
Other Character dialoq pəncərəsində seçib OK düyməsini 
sıxmaq lazımdır (şək.14).  

 
Şək.14. 

Yeni abzasa keçmək üçün Enter düyməsini sıxmaq, abzas 
daxilində «qısa» sətrlərdən istifadə etmək üçün isə Insert →   
HTML →   Special Characters  →  Line Break əmrini yerinə 
yetirmək və ya Shift və Enter düymələrini birgə sıxmaq 
lazımdır.  Abzas üçün səhifənin kənarlarından buraxılan boş 
məsafələri artırmaq üçün Text  →   Indent əmrini, səhifənin 
kənarlarından buraxılan boş məsafələri azaltmaq üçün isə Text  
→   Outdent əmrini yerinə yetirmək lazımdır. Abzasın sola, 
mərkəzə, saga, hər iki tərəfə görə nizamlanması müvafiq olaraq 
Text  →  Align →  Left, Text  →  Align →  Center,  Text  →  
Align →  Right, Text  →  Align →  Justify əmrləri vasitsəilə 
tənzimlənir. Text → Pagraph Format  →   Headin1, Text  →  
Pagraph Format →  Heading2, Text  →  Pagraph Format → 
Heading3, Text  →  Pagraph Format →  Heading4, Text  →  
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Pagraph Format →  Heading5, Text  →  Pagraph Format  →  
Heading6 əmrləri isə abzas üçün müvafiq yazı stillərinin 
müəyyən edilməsini təmin edir. 

Internet brauzerləri ardıcıl daxil olunmuş probelləri qəbul 
etmədiyindən sözü və ya söz birləşməsini sağa sürüşdürmək 
üçün Insert → HTML → Special Characters→Non-
Breaking Space  əmrini yerinə yetirmək lazımdır.  

Qeyd edək ki, proqram bir sıra mətn redaktorlarında 
olduğu kimi, sənədə daxil edilmiş mətnin orfoqrafik və 
qrammatik yazılışının yoxlanılmasını təmin edir. Bunun üçün 
Text → Check Spelling əmrini yerinə yetirmək lazımdır. Əmri 
yerinə yetirdikdə, mətndə səhv aşkar olunarsa, Check Spelling 
dialoq pəncərəsi açılır və bu dialoq pəncərəsində variantlar 
bölməsində səhv hesab olunan sözün düzgün variantları əks 
olunur.  Bu variantlardan birini seçib Change düyməsini 
sıxmaqla səhv sözü həmin sözlə əvəz etmək olar. Bəzi hallarda 
(termin, şəxs adı, coğrafi adlar və s.) söz düzgün yazıldığına 
baxmayaraq, kompüter onu səhv kimi qəbul edə bilər. Bu halda 
Ignore düyməsini sıxmaq kifayətdir. Add to Personal 
düyməsini sıxmaqla isə kompüterin lüğət bazasını «səhv qəbul 
etdiyi» sözlə zənginləşdirmək olar (şək.15). 

 
Şək.15. 
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Qeyd edək, mətnin keyfiyyətli orfoqrafik yoxlanışına nail 
olmaq üçün ilk öncə Edit →  Proferences əmrini yerinə 
yetirmək və  açılan eyni adlı dialoq pəncərəsinin Spelling 
dictionary sahəsindən dillərin siyahısından mətnin yazıldığı 
dilə uyğun dili seçmək lazımdır (şək.16). 

 
Şək.16. 

Səhifəyə cari tarixi Insert→Data əmrini yerinə 
yetirməklə  daxil etmək olar. Əmri yerinə yetirdikdə açılan 
dialoq pəncərəsində müvafiq tarix formatını seçmək lazımdır. 
İstifadəçi Update Automatically variantını aktivləşdirsə Web-
səhifə hər dəfə yaddaşda saxlandıqda tarix yeniləşəcək. 

Siyah ı. Web səhifələrdə 3 növ siyahılardan istifadə 
olunur (şək. 17): 

1) Nömrəli;  
2) Nişanlı;  
3) Təyinetmə siyahıları. 
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Şək.17. 

Nömrəli və nişanlı siyahılarda hər bir abzas müvafiq olaraq 
nömrələnir və ya nişanlanır. Təyinetmə siyahısından əsasən 
terminlər lüğətinin yaradılmasında istifadə olunur: ilk sətrdə 
termin, sonrakı sətrdə isə onun şərhi əks olunur. Yeni siyahı 
yaratmaq üçün siyahının tipinə müvafiq Text  →   List  →   
Ordered, Text  →   List  →  Unordered, Text  →   List →   
Definition List əmrlərindən birini yerinə yetirmək, mətni daxil 
etmək lazımdır. Enter düyməsini sıxdıqda daxil edilmiş mətn 
siyahıya çevrilir. Siyahının sonunda Enter düyməsini iki dəfə 
sıxmaq lazımdır. Siyahını həmçinin daxil edilmiş abzasları qeyd 
edib, siyahının tipinə müvafiq yuxarıda qeyd olunan əmrlərdən 
birini yerinə yetirməklə də yaratmaq olar. 

Cədvəl. Cədvəllər Web səhifədə nizamlı  informasiya-
ların əks edilməsi,  səhifənin tərtibatı üçün istifadə olunur.  

Məsələn, şəkil 18-də təsvir olunmuş səhifənin tərtibatında 
cədvəldən istifadə olunmuşdur. 
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Şək.18. 

Səhifəyə yeni cədvəl daxil etmək üçün Insert→Table əmrini 
yerinə yetirmək və açılan dialoq pəncərəsində sətr və sütunların 
sayını, cədvəlin enini, cədvəlin sərhədinin qalınlığını, xanalarda 
informasiyanın xananın sərhədindən hansı məsafədə olmasını, 
xanalararası intervalı, cədvəlin sərlövhəsinin yerləşmə 
formasını, cədvəlin adını, sərlövhə üçün nizamlama parametrini 
və ehtiyac olarsa cədvəl üçün qısa şərhi daxil etmək və OK 
düyməsini sıxmaq lazımdır (şək.19).  Bundan sonra cədvəl 
şablonu səhifədə əks olunacaqdır. Cədvəlin xanalarına mətn, 
ədəd, rəsm və multimedia tipli informasiya daxil edilir. Mətn 
və ədəd tipli informasiya xanalara klaviaturadan və ya 
mübadilə buferindən daxil olunur. Rəsm və multimedia tipli 
informasiya müvafiq olaraq Insert →  Image, Insert →  
Media  →  Flash,  Insert →  Media  →  Shockwave, Insert 
→ Media  →  Image Viewer, Insert →  Media  →  Plugin 
əmrlərini yerinə yetirməklə daxil olunur. 
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Şək.19. 

İstifadəçi həmçinin, sənədə MS Excel və digər proqramlar 
vasitəsilə hazırlanmış cədvəlləri də daxil edə bilər. Belə ki,  
sənədə MS Excel cədvəlini əlavə etmək üçün File →  Import  
→  Excel Document əmrini yerinə yetirmək və açılan  dialoq 
pəncərəsində Excel faylının ünvanını müəyyən etmək lazımdır. 
Insert  →  Table Objects  →  Import Tabular Data əmrini 
yerinə yetirməklə isə digər proqramlar vasitəsilə hazırlanmış 
cədvəl sənədə  daxil olunur. Əmri yerinə yetirdikdə açılan   
Import Tabular Data adlı dialoq pəncərəsinin Data File 
sahəsinə faylın ünvanını daxil etmək, Border Cell padding, Cell 
spacing sahələrində müvafiq olaraq xanadakı informasiya ilə 
xananın sərhədi arasında və xanalar arasında intervalı,  Format 
top row: sahəsində şrift üçün stil formasını, Border sahəsində 
cədvəlin sərhədinin qalınlığını müəyyən etmək lazımdır 
(şək.20). Bundan əlavə cədvəlin ölçüsünün daxil olmuş 
informasiyaya uyğun avtomatik nizamlanması üçün dialoq 
pəncərəsinin Fit to data variantını, cədvəl üçün konkret ölçü 
müəyyən etmək üçün  isə Set variantını seçib, bu zaman əks 
olunan sahəyə ölçünün konkret qiymətlərini daxil etmək 
lazımdır.  
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Şək.20. 

Daxil edilmiş cədvəl üzərində aşağıdakı redaktə və 
formatlaşma əməliyyatlarını yerinə yetirmək olar: 
• Yeni sətr və sütun əlavə etmək; Cədvələ cari sətrdən sonra 
yeni sətr əlavə etmək üçün Insert →  Table Objects  →   
Insert Row Above və ya Modify →  Table  →   Insert Row 
əmrini, cari sətirdən əvvəl yeni sətr əlavə etmək üçün Insert →  
Table Objects  →   Insert Row Below əmrini, cari sütunun 
solundan yeni sütun  əlavə etmək üçün Insert →  Table 
Objects  →   Insert Column to The Left  və ya Modify →  
Table  →   Insert Column əmrini, cari sütununun sağından 
yeni sütun  əlavə etmək üçün isə Insert →  Table Objects  →   
Insert Column to The Right  əmrini yerinə yetirmək lazımdır.  
Cədvələ cari sətrdən əvvəl və ya sonra  bir neçə sətr, cari 
sütunun solundan və ya sağından bir neçə sütun əlavə etmək 
üçün  Modify →  Table  →   Insert Rows or Columns əmrini 
yerinə yetirmək lazımdır. Əmri yerinə yetirdikdə açılan Insert 
Rows or  Columns pəncərəsində Insert  sahəsində yeni sətr 
üçün Rows, sütun  üçün Columns  parametrlərini seçmək və 
bunlara uyğun Number of rows  və Number of columns  
sahələrində müvafiq olaraq sətr və sütunların sayını, Where 
sahəsində isə sətr və ya sütunun cari sətr və ya sütundan əvvəl 
və ya sonra daxil olması parametrini müəyyən etmək lazımdır 
(şək.21-22). 
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                          Şək. 21.                                   Şək.22. 

Cədvəlin sonuncu sətr və sütunundan sonra yeni sətr və sütun  
əlavə etmək üçün  Modify →  Table  →  Select Table əmrini 
yerinə yetirməklə cədvəli qeyd etmək və xassə inspektorunun 
Rows və Columns sahələrində (şək.23) müvafiq olaraq sətr və 
sütunların sayını artırmaq lazımdır.  

 
Şək.23. 

• Cədvəldən sətr və sütunu ləğv etmək;  Cədvəldən cari sətri 
və sütunu ləğv etmək üçün müvafiq olaraq  Modify →  Table  
→   Delete Row və Modify →  Table  →   Delete Column 
əmrlərini yerinə yetirmək lazımdır. Cədvəlin sonuncu sətr və 
sütunlarını ləğv etmək üçün isə Modify →  Table  →  Select 
Table əmrini yerinə yetirməklə cədvəli qeyd etmək və xassə 
inspektorunun Rows və Columns sahələrində (şək.23) müvafiq 
olaraq sətr və sütunların sayını azaltmaq lazımdır. 
• Xanalardakı qeyd olunmuş informasiyanın yerini 
dəyişdirmək və surətini digər xanalara əlavə etmək; 
Xanalardakı qeyd olunmuş informasiyanın yerini dəyişdirmək 
üçün ilk öncə Edit → Cut əmrini yerinə yetirməklə qeyd 
olunmuş informasiyanı kəsib mübadilə buferinə köçürmək, 
sonra kursoru tələb olunan xanaya qoyub Edit → Paste əmrini 
yerinə yetirmək lazımdır.  Xanalardakı qeyd olunmuş 
informasiyanın surətini digər xanalara əlavə etmək üçün isə  
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Edit → Copy  əmrini yerinə yetirib qeyd olunmuş 
informasiyanın surətini  mübadilə buferinə köçürmək, kursoru 
tələb olunan xanaya qoyub Edit → Paste əmrini yerinə 
yetirmək lazımdır.  
• Qeyd olunmuş xanaları birləşdirmək; Qeyd olunmuş 
xanaları birləşdirmək üçün Modify → Table → Merge Cell 
əmrini yerinə yetirmək lazımdır. 
• Cari xananı şaquli və üfüqi istiqamətdə  bir neçə xanaya 
bölmək; Cari xananı şaquli və üfüqi istiqamətdə bir neçə 
xanaya bölmək üçün Modify → Table → Split Cell əmrini 
yerinə yetirmək, açılan Split Cell dialoq pəncərəsində şaquli 
istiqamətdə bölmək üçün Split cell into: sahəsində Rows, üfüqi 
istiqamətdə bölmək üçün  isə Columns parametrini seçmək, 
xanaların sayını müəyyən etmək və OK düyməsini sıxmaq 
lazımdır (şək.24-25). 

  
                             Şək. 24.                             Şək. 25. 

• Cədvəldəki informasiyanı əlifba və ya artma-azalma 
ardıcıllığına görə nizamlamaq; Cədvəldəki informasiyanı əlifba 
və ya artma-azalma ardıcıllığına görə nizamlamaq üçün 
Commands → Sort Table əmrini yerinə yetirmək və açılan 
dialoq pəncərəsinin Sort by  sahəsində nizamlanacaq 
informasiyanın yerləşdiyi sütunu seçmək, Order sahəsində isə 
nizamlama parametrlərini müəyyən etmək lazımdır (şək.26) 
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Şək.26. 

• Cari cədvəlin formasını dəyişmək; Cari cədvəlin görünüş  
formasını dəyişmək üçün Commands →  Format Table 
əmrini yerinə yetirmək və açılan Format Table dialoq 
pəncərəsində müvafiq görünüş parametrlərini müəyyən etmək 
lazımdır (şək.27). 

 
Şək.27. 

• Cədvəl üçün müəyyən olunmuş parametrləri dəyiş-məklə 
cədvəli formatlaşdırmaq; Cədvəli formatlaşdır-maq üçün onu 
qeyd etmək və xassə inspektorunda cədvəl üçün yeni 
parametrlər: Table Id sahəsində cədvəlin adını, Rows və Cols  
sahələrində sətr və sütunların sayını, W və H sahələrində 
cədvəlin ölçülərini və müvafiq ölçü vahidini CellPad sahəsində 
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informasiya üçün xananın kənarlarından buraxılan məsafələri, 
CellSpace  sahəsində xanalararası intervalı, Align sahəsində 
nizamlama parametrini, Border sahəsində xanaların sərhədinin 
qalınlığını, Brdr Color sahəsində xanaların sərhədinin rəngini, 
Bg Color sahəsində cədvəlin xanaları üçün fon, Bg Image 
sahəsində cədvəlin xanaları üçün fon şəkli müəyyən etmək 
lazımdır (şək.28a). Eyni qayda ilə cari xananın  xassə 
inspektorunda  cari xana və onun sərhədi üçün yeni fon və ölçü  
müəyyən etmək olar (şək.28b). Bundan əlavə xassə 
inspektorunun Horz  və Vert sahələrində üfüqi və şaquli 
istiqamətdə nizamlama parametrini, No Wrap sahəsində 
xananın sərhədində mətn tipli informasiyanın hecaya bölünməsi 
parametrini, Header sahəsində xanadakı informasiyanın  tünd 
qara və mərkəzə döğru nizamlanmasını dəyişmək olar. 

 
Şək.28a. 

 
Şək.28b. 

Qeyd edək ki, cədvəlin müəyyən olunmuş ölçülərini 
ləğv etmək üçün  müvafiq olaraq Modify → Table →Clear 
Cell Heights və Modify → Table → Clear Cell Widths 
əmrini yerinə yetirmək lazımdır. Xananın ölçüləri üçün 
müəyyən olunmuş ölçü vahidini – pikseli faizə və əksinə 
dəyişmək üçün müvafiq olaraq Modify  → Table → Convert 
Width to Pixels  Modify → Table →  Convert Width to 
Persent, Modify → Table → Convert Heights to Pixels , 
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Modify  → Table  → Convert Heights to Persent əmrlərini 
yerinə yetirmək lazımdır.   

Hiperistinad.Hiperistinadlar cari Web səhifədən digər 
Web səhifəyə, fayllara, e-mail ünvanlara, böyük həcmli 
səhifələrdə səhifənin müxtəlif nişanlanmış hissələrinə istinad 
olunmasını təmin edir. 

İstinad mətn və ya qrafiki tipli olur. Mətn tipli istinad 
yaratmaq üçün Insert →  Hyperlink əmrini yerinə yetirmək və 
açılan dialoq pəncərəsinin Text sahəsinə istinadın mətnini, Link 
sahəsinə isə istinad olunan səhifənin və ya faylın ünvanını daxil 
etmək və ya Browse düyməsini sıxmaqla açılan Select File 
pəncərəsindən səhifəni və faylın ünvanını müəyyən etmək 
lazımdır (şək.29). Ehtiyac olarsa Title sahəsində hiperistinad 
üçün qısa şərh də daxil etmək olar. 

 
Şək.29. 

 E-mail ünvanına istinad yaratmaq üçün isə Insert →  
EMail Link əmrini yerinə yetirmək, açılan E-mail Link dialoq 
pəncərəsində Text sahəsinə mətni,    E-Mail sahəsinə isə 
elektron poçt ünvanı daxil edib, OK düyməsini sıxmaq lazımdır 
(şək.30). 

 
Şək.30. 
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Qrafiki təsvirlər. Rəsmlər və qrafiki obyektlər Web 
səhifədə dizayn, istinad və vizual informasiya elementi kimi 
istifadə olunur. Rəsmləri və qrafiki obyektləri səhifəyə daxil 
etmək üçün Insert →  Image əmrini yerinə yetirmək və açılan 
Select Image Source dialoq pəncərəsi vasitəsilə tələb olunan 
rəsmi seçmək və OK düyməsini sıxmaq lazımdır. Daxil edilmiş 
şəkli qeyd edib, xassə inspektorunun W  və H  sahələrində 
şəkilin ölçülərini müəyyən etmək, Edit sahəsinin Crop 
düyməsini sıxmaqla daxil edilmiş rəsmdən fraqment kəsmək, 
Brightness and Contrast düyməsini sıxmaqla isə şəkilin 
«parlaqlıq» effektini tənzimləmək olar (şək.31). 

Səhifənin hazırlanması prosesində tələb olunan şəkil 
müəyyən səbəblərdən hazır olmadıqda səhifə tərtibatını 
yarımçıq saxlamamaq üçün «şəkil əvəzedici» daxil edir və 
tərtibat işini davam edirlər. Şəkil əvəzedici daxil etmək üçün 
Insert → ImageObjects → Image Placeholder əmrini yerinə 
yetirmək və açılan dialoq pəncərəsinin Name sahəsinə ad, 
Width və Height sahəsinə ölçülərini, Color sahəsinə rəngi, 
Altenate Text sahəsinə isə şəkil üçün alternativ  mətni daxil 
edib OK düyməsini sıxmaq lazımdır (şək.32). 

 
Şək.31. 

Rəsmdən istinad elementi kimi istifadə etmək üçün rəsmi 
qeyd etmək və xassə inspektorunun Link sahəsinə istinad 
olunacaq faylın, sənədin ünvanını və ya e-mail ünvanını daxil 
etmək lazımdır (şək.31). İstinad olunan faylın ünvanını 
həmçinin Browse düyməsini sıxmaqla açılan Select File dialoq 
pəncərəsi vasitəsilə də təyin etmək olar.  
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Şək.32. 

Rəsmdən həmçinin istinad xəritəsinin yaradılması üçün də 
istifadə olunur. İstinad xəritəsi böyük ölçülü rəsmlərin konkret 
sahələrindən digər sənədlərə, fayllara istinadı təmin edir. 
İstinad xəritəsi yaratmaq üçün xassə inspektorunun Map 
sahəsinə xəritənin adını daxil etmək, oblastlar alətləri vasitəsilə 
şəkil üzərində düzbucaqlı, çevrə və ya düzbucaqlı sahələr 
ayırmaq və ayrılmış sahənin xassə inspektorunun Link 
sahəsində sahədən istinad olunacaq faylın, sənədin ünvanını və 
ya e-mail ünvanını daxil etmək lazımdır (şək.31). 

Multimedia fayllar ı. Web səhifələr hipermedia sənədlər 
olduğu üçün özündə rəsmlə yanaşı audio və video 
informasiyalar da daşıyır. Səhifəyə audio və ya video fayllar 
daxil etmək üçün ilk öncə Insert →  Media →  Plugin əmrini 
yerinə yetirib müvafiq multimedia proqramını (məsələn, 
Windows Media Player, WinAmp və s.) müəyyən etmək və 
xassə inspektorunun Plg URL sahəsində səslənəcək audio fayla 
və ya nümayiş olunacaq video fayla istinadı təyin etmək 
lazımdır. Flash animasiyalar daxil etmək üçün isə Insert →  
Media →  Flash əmrini yerinə yetirmək və animasiya faylının 
ünvanını müəyyən etmək lazımdır. 

Flash animasiya ilə yanaşı proqram sənədə Flash sətir və 
düymələr daxil olunmasını da təmin edir. Flash düymələr daxil 
etmək üçün Insert →  Media →  Flash Button əmrini yerinə 
yetirmək və açılan dialoq pəncərəsinin (şək.33) Style sahəsində 
düymə üçün stil formasını seçmək, düymənin üzərindəki yazını 
Button Text sahəsinə daxil etmək, Font açılan siyahısından yazı 
üçün şrift seçmək, Link sahəsinə istinad olunacaq sənədin, 
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faylın ünvanını və ya e-mail ünvanını daxil etmək lazımdır. 
Save As sahəsində düymənin yaddaşda saxlanması üçün faylın 
adı müəyyən olunmalıdır. 

Flash-sətir daxil etmək üçün Insert →  Media → Flash 
text əmrini yerinə yetirmək və açılan dialoq pəncərəsinin Text 
sahəsinə mətni daxil etmək, Link sahəsində istinad olunacaq 
ünvanı müəyyən etmək, Big color rəng palitrasından sətir üçün 
rəngli fon seçmək və Save As sahəsində isə flaş-sətrin 
yaddaşda saxlanması üçün faylın ünvanını təyin etmək lazımdır 
(şək.34). Ehtiyac olduqda Font şrift siyahısından mətn üçün 
şrifti, Color palitrasından şrift üçün ilkin rəngi, Rollover Color 
palitrasından isə kursoru mətnin üzərinə qoyduqda şriftlərin 
aldığı yeni rəngi seçmək lazımdır.    

   
                Şək. 33.                              Şək. 34. 

Apletlər səhifələrin funksional imkanlarını artıran və 
əsasən Java dilində hazırlanmış hazır proqram modullarıdır. 
Sənədə aplet daxil etmək üçün Insert → Media →  Applet 
əmrini yerinə yetirmək və açılan Select File dialoq 
pəncərəsində aplet faylının ünvanını müəyyən edib OK 
düyməsini sıxmaq lazımdır.  

Skriptlər Web səhifəyə əlavə edilmiş  Java, VBasic və C 
dillərinin birində yazılmış proqram kodlarıdır. Skriptlər 
səhifədə dinamik effektlərin yaradılması, müəyyən 
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əməliyyatların yerinə yetirilməsi üçün tətbiq edilir. Səhifəyə 
skript əlavə etmək üçün Insert → Html → Script Objects → 
Script əmrini yerinə yetirmək və açılan Script dialoq 
pəncərəsinin Language: sahəsində skriptin yazıldığı dili 
seçmək, Content: sahəsində isə skriptin mətnini daxil etmək və 
OK düyməsini sıxmaq lazımdır (şək.35) 

 
Şək.35. 

Naviqasiya elementləri. Naviqasiya elementləri saytın 
əsas komponentlərindən biri hesab olunur və cari səhifədən 
digər səhifələrə keçidi təmin edir. Dreamweaver MX 2004 
proqramı aşağıdakı naviqasiya elementlərinin yaradılmasını 
təmin edir: 

1. Rollver düyməsi. Rollver düyməsi rəsmin dəyişməsi 
effektinə əsaslanır. Sənədə bu elementi daxil etmək üçün  
İnsert → İmage Objects → Rollover İmage əmrini yerinə 
yetirmək və açılan İnsert Rollover İmage dialoq pəncərəsinin 
İmage Name sahəsində düyməyə ad, Orginal İmage sahəsində 
düymə üçün başlanğıc rəsmin ünvanını, Rollover İmage 
sahəsində aktiv vəziyyətdə düymə üçün rəsmin ünvanını, 
Alternate Text sahəsində rəsm üçün şərh, When Clicked, Go 
to URL sahəsində hiperistinad daxil edilməlidir (şək.36). 
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Şək.36. 

2. Naviqasiya paneli. Naviqasiya paneli digər sənədlərə 
istinadı təmin edən qrafiki rəsmlərdən ibarət paneldir. Belə ki, 
panelin elementlərinin konkret vəziyyətlərinə  konkret qrafiki 
rəsm uyğun olur. Panelin yaranması üçün İnsert  →   İmage 
Objects  →  Navigation Bar əmrini yerinə yetirmək, açılan 
dialoq pəncərəsinin + düyməsini sıxıb, Up İmage sahəsində 
panelin ilk elementinin normal vəziyyətinə uyğun rəsmin, Over 
İmage sahəsində kursoru elementin üzərinə gətirdikdə 
elementə uyğun  rəsmin, Down İmage sahəsində aktiv 
vəziyyətə uyğun rəsmin ünvanını, When Clicked, Go to URL 
sahəsində hiperstinadın ünvanını daxil etmək, İnsert 
siyahısından isə panelin üfiqi və ya şaquli istiqamətdə olmasını 
təyin etmək lazımdır (şək.37). 

 
Şək.37. 

Növbəti element təkrarən + düyməsini sıxmaqla və eyni 
qaydada müvafiq parametrləri təyin etməklə daxil edilir. Daxil 
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edilmiş element New Bar Element siyahısında əks olunacaq. 
Bu siyahıdan hər hansı elementi qeyd edib -  düyməsini 
sıxmaqla elementi paneldən ləğv etmək olar. 

3. Kontekst menyu. Kontekst menyu rəsmə və ya mətnə 
mənimsədilən hiperistinad vasitəsilə, naviqasiya funksiyasını 
yerinə yetirir. Menyu yaratmaq üçün ilk öncə mətni qeyd 
etmək, xassə inspektorunun Link sahəsində sıfırıncı 
hiperistinadı- javascript: daxil etmək və Behaviors panelinin 
Actions siyahısından Show Pop-Up Menu əmrini seçmək 
lazımdır. Bu zaman açılan Show Pop-Up Menu dialoq 
pəncərəsinin Contents bölməsinin + düyməsini sıxmaq və 
Text sahəsində menyunun elementini, Link sahəsində isə 
hiperstinadı daxil etmək lazımdır (şək.38). Növbəti elementi 
daxil etmək üçün təkrar + düyməsini sıxmaq və yenidən 
elementin adını və hiperistinadı daxil etmək lazımdır. Dialoq 
pəncərəsinin Apperance bölməsində şrift və menyunun 
elementi üçün rəngləri, Advanced bölməsində cədvəl üçün 
parametrləri, Positon bölməsində isə menyunun əmrlər 
siyahısının əks olunma formasını  müəyyən etmək lazımdır 
(şək.38-41).  Menyunun yaranması OK düyməsini sıxmaqla 
tamamlanır. 

  
          Şək.38.                                         Şək. 39. 
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         Şək.  40.                                     Şək.41. 

Formalar. Formalar cari səhifədəki məlumatın Web 
serverə ötürülməsini təmin edir. Sənədə forma daxil etmək 
üçün Insert → Form əmrini yerinə yetirmək lazımdır. Forma 
səhifədə Design rejimində qırmızı rəngli qırıq xətli düzbucaqlı 
çərçivə şəklində əks olunur. Onu qeyd edib, xassə 
inspektorunun Action sahəsində skriptin və ya Web əlavənin 
URL ünvanını, Method sahəsində isə informasiyanın ötürmə 
üsulunu seçmək lazımdır (şək.42).  

 
Şək.42.  

Forma müəyyən olunduqdan sonra formanı idarəetmə 
elementlərini daxil etmək lazımdır. Bu elementlər 
aşağıdakılardır: 

• Text Field. Bu element serverə ötürüləcək mətn tipli 
məlumatların daxil edilməsini təmin edir.  Formaya elementi 
daxil etmək üçün Insert →  Form →  Text Field əmrini yerinə 
yetirmək lazımdır. Bundan sonra xassə inspektorunun Type  
sahəsində  bir sətrli mətn sahəsi üçün elementin Single line , 
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sürüşdürücülü mətn sahəsi üçün Multi line 1, parol sahəsi üçün 
Password  parametrini seçmək, sahə üçün ad, başlanğıc qiymət2 
və sahənin neçə simvol üçün nəzərdə tutulduğunu müəyyən 
etmək lazımdır (şək.43).  

 
Şək.43. 

• Check box və Radio Buttons elementləri serverə 
ötürüləcək parametrin iki qiymətdən birini aldığını göstərmək 
üçün istifadə edilir. Bu elementləri daxil etmək üçün müvafiq 
olaraq Insert→Form → Check Box  və  Insert → Form → 
Radio Button əmrlərini yerinə yetirmək lazımdır. Hər iki halda 
xassə inspektorunda istifadəçi Checkbox name və Radio 
Buttom sahələrində müvafiq olaraq elementlər üçün unikal ad, 
Checked Value sahəsində element üçün təsvir identifikatorunu, 
Intial State sahəsində isə elementlərin başlanğıc vəziyyətini 
müəyyən etmək lazımdır3 (şək.44-45).  

 
Şək.44. 

 
Şək.45. 

                                                 
1  Qeyd edək ki, formaya sürüşdürücülü mətn sahəsi  həmçinin, Insert → 
Form Object→ TextArea əmrini yerinə yetirməklə də daxil edilir. 
2  Qiymət müəyyən edildikdə elementin adı başlanğıc qiymət kimi qəbul 
edilir. 
3 Checked elementin başlanğıc halda aktiv, Unchecked isə başlanğıc halda 
qeyri aktiv olmasını təyin edir. 
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• Radio Group. Element serverə ötürüləcək parametrin təklif 
olunan variantlardan birini aldığını göstərmək üçün istifadə 
olunur. Elementi daxil etmək üçün Insert →  Form →  Radio 
Group  əmrini yerinə yetirmək və açılan Radio Group dialoq 
pəncərəsinin Name sahəsində elementə unikal ad vermək, + 
düyməsini sıxmaqla qrupun elementləri üçün təsvir 
identifikatorlarını daxil etmək, düymələr qrupunun görünüşü 
üçün Line Breaks (<br>Tags) və Table variantından birini 
seçmək lazımdır (şək.46). Dialoq pəncərəsinin   -  düyməsini 
sıxmaqla  qrupun qeyd olunmuş elementini ləğv etmək olar. 

 
Şək.46. 

• List/Menu. Element «çoxsətrli siyah ılar ın» və «aç ılan 
siyah ılar ın» yaradılmasını təmin edir.  Elementi formaya daxil 
etmək üçün  Insert → Form → List/Menu əmrini yerinə 
yetirmək lazımdır. Çoxsətrli siyahı yaratmaq üçün elementin 
xassə inspektorunun Type sahəsində List parametrini seçmək, 
Heigh sahəsində siyahının hündürlüyünü (sətrlərin sayını) və 
List Values düyməsini sıxmaqla siyahının elementlərini daxil 
etmək lazımdır (şək.47). Əgər, siyahıdan bir neçə element 
seçmək lazım olarsa Selections Alow multiple parametrini 
aktivləşdirmək lazımdır.  
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Şək. 47. 

«Aç ılan siyah ı» yaratmaq üçün isə Type sahəsində Menu 
parametrini seçmək və ListValues düyməsini sıxmaqla 
siyahının elementlərini daxil etmək lazımdır. 
• Jump Menu. Element digər Web səhifələrə, fayllara və ya 
e-mail ünvanlarına istinadı təmin edən menyuların 
yaradılmasını təmin edir. Elementi formaya daxil etmək üçün  
Insert → Form → Jump Menu əmrini yerinə yetirmək 
lazımdır. Açılan Insert Jump Menu dialoq pəncərəsinin Menu 
name sahəsində elementə unikal ad müəyyən etmək, + 
düyməsini sıxmaqla Text sahəsində menyunun elementlərini, 
When Selected, go to URL sahəsində istinadın ünvanını, Open 
URLs in sahəsində səhifənin necə açılacağını (yeni pəncərədə 
və ya freymlərin birində) müəyyən etmək lazımdır (şək.48). 
Ehtiyac olarsa Insert go button after menu parametrini 
seçməklə menyudan sağda Go düyməsinin əks olunmasına nail 
olmaq olar. 

Fərdi kompüterlərin proqram təminatı 

 

76

 
Şək.48. 

• File Field. Element serverə göndəriləcək fayl adının təyin 
edilməsini təmin edir. İstifadəçi faylın adını klaviaturadan daxil 
edə bilər və ya elementin Browse düyməsini sıxmaqla Select 
Files pəncərəsi vasitəsilə təyin edə bilər. Element formaya 
Insert → Form → File Field əmrini yerinə yetirməklə daxil 
olunur. Elementin xassə inspektorunda elementə ad vermək, 
simvolların uzunluğunu və ya maksimal sayını müəyyən etmək 
lazımdır (şək.49). 

 
Şək.49. 

• Botton. Element formaya istifadəçinin təyin etdiyi 
informasiyaları serverə göndərmək üçün Submit  düyməsinin, 
informasiyanın pozulmasını təmin edən Reset düyməsinin daxil 
edilməsinə xidmət edir.  Element formaya Insert → Form → 
Botton  əmrini yerinə yetirməklə daxil olunur. Elementin xassə 
inspektorunun Action sahəsində Submit və ya Reset 
parametrini seçmək lazımdır (şək.50). İstifadəçi Label 
sahəsində düymə üçün fərqli adlar məsələn, Otpravitğ, Send  
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və s. mənimsədə bilər. Formaya digər məqsədlə, məsələn 
müəyən  skriptlərin yerinə yetirilməsi üçün idarəedici düymə 
daxil etmək tələb olunduqda Action sahəsində None 
parametrini seçmək lazımdır. 

 
Şək.50. 

• Image Field sahəsi formaya qrafiki rəsmli idarəedici 
düymələrin daxil olmasını təmin edir. Element formaya Insert 
→ Form → Image Field  əmrini yerinə yetirməklə daxil 
olunur. Xassə inspektorunda rəsmin ölçülərini və Image Filed 
sahəsi üçün Submit, Next və s. standart sözlər daxil etmək 
lazımdır (şək.51).    

 
Şək.51. 

Hazır Web səhifəni yaddaşda saxlamaq üçün File →  
Save əmrini, uzaq məsafədə yerləşən  serverdə yaddaşda 
saxlamaq üçün isə File →  Save to Remote Server əmrini 
yerinə yetirmək lazımdır. Cari HTML səhifəsini  XHTML 
sənədi şəklində yaddaşda saxlamaq üçün isə  Convert →  
XHTML əmrini yerinə yetirmək lazımdır.  

 
 
 

1.4.3. Freymli səhifələrin yarad ılmas ı 

Freymlər bir Web-səhifə daxilində digər  Web  səhifənin 
əks olunmasını təmin edir.  Freymlər əsasən mürəkkəb 
strukturlu səhifələrin yaradılması üçün istifadə olunur. Məsələn 
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şəkil 52-də göstərilmiş səhifə 4 freymdən təşkil edilmişdir. 
Yuxarı üfüqi freymdə səhifənin sərlövhəsi əks olunur. Sol və 
şaquli freymlər isə hiperistinadlar siyahısından ibarət olub,  
naviqasiya funksiyasını yerinə yetirir. Hər bir istinada uyğun 
Web-səhifə mərkəzi freymdə əks olunur. 

 
Şək.52. 

 Freymli boş səhifə yaratmaq üçün bir neçə üsul 
mövcuddur: 
1.File  New əmrini yerini yetirib açılan dialoq pəncərəsinin 
General  bölməsinin  Category siyahısında  Framsets  sənəd 
tipini və Framsets tipinə uyğun freym strukturunu seçmək və  
Create düyməsini sıxmaqla yeni boş freymli səhifə yaratmaq 
(şək.53) ; 
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Şək.53. 

2. Insert→Html→Frames→Left, Insert→Html→Frames  
→Right, Insert→Html→Frames→Top, Insert→Html→  
Frames→Bottom, Insert→Html→Frames→Bottom Nested 
Right, Insert→Html→Frames→Bottom Nested Left, Insert  
→Html→Frames→Right Nested Top, Insert→Html→  
Frames→Right Nested Bottom, Insert→Html→Frames→   
Left Nested Top, Insert→Html→Frames→Left Nested 
Bottom,  Insert→Html→Frames→Top and Bottom, Insert  
→Html→Frames→Top Nested Left, Insert→Html→   
Frames→Top Nested Right əmrlərindən birini yerinə 
yetirməklə cari boş səhifəyə freymləri əlavə etmək; 
3.Insert panelinin Layout bölməsinin freym siyahısından 
müvafiq freym strukturunu seçməklə cari boş səhifəyə 
freymləri əlavə etmək (şək.54). 
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Şək.54. 

Sonrakı addımda səhifənin  freymlərinin avtomatik 
müəyyən olunan parametrləri təlabata uyğun tənzimlənməlidir.  
Bunun üçün  ilk öncə Window→Frames əmrini yerinə 
yetirməklə interfeys pəncərəsinin sag şaquli hissəsində Frames 
panelini əks etdirib, panel vasitəsilə konkret freymi qeyd etmək 
və qeyd edilmiş freymin xassə inspektorunda parametrləri 
təlabata uyğun dəyişdirmək lazımdır (şək.55). Belə ki, 
inspektorun Frame name sahəsində freymin adını, Src 
sahəsində freymdə əks olunacaq səhifənin ünvanını, Margin 
Width, Margin Height sahələrində müvafiq olaraq freymin 
informasiya sahəsinin enini və hündürlüyünü müəyyən etmək 
olar. Freymin sərhədlərinin əks olunması Borders sahəsilə, 
sərhədin rəngi Border Color sahəsilə, səhifə sürüşdürücülərinin 
əks olunması isə Scroll sahəsilə tənzimlənir. No resize 
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parametri freymin ölçülərinin istifadəçi tərəfindən dəyişdirilə 
bilən olmasını tənzimləyir1.   

 
Şək.55. 

Səhifədə freymlərin sərhədinin qalınlığını müəyyən etmək üçün 
isə kursoru hər hansı bir freymin sərhədinin üzərinə qoyub 
siçanın sol düyməsini sıxmaqla sərhədi qeyd etmək xassə 
inspektorunun Border Width sahəsində sərhədin qalınlığını 
müəyyən etmək lazımdır.    

Hər bir freymdə müstəqil Web-səhifə əks olunduğundan  
Save Frame  və ya Save Frame As əmrlərindən birini yerinə 
yetirməklə cari freymi yaddaşda saxlamaq olar.  

Cari freymi bölməklə səhifəyə yeni freym əlavə etmək 
olar. Bunun üçün müvafiq olaraq Modify→Framset→Split 
Frame Left, Modify→Framset→Split Frame Right, 
Modify→Framset→ Frame  Up, Modify→Framset→ Frame 
Down əmrlərindən birini yerinə yetirmək lazımdır. Cari 
                                                 
1 Bu parametr aktiv olduqda freymin ölçüləri dəyişməz olur. 
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freymdən digər sənədlərə istinad etmək üçün 
Insert→Hyperlink əmrini yerinə yetirdikdə açılan dialoq 
pəncərəsində sənədin ünvanını müəyyən etdikdən sonra  Target 
sahəsində istinad olunmuş səhifənin hansı freymdə əks 
olunacağını müəyyən etmək lazımdır  (şək.56). 

 
Şək.56. 

 
 

1.4.4. CSS- Kaskadl ı Stil Cədvəlləri 
 

Kaskadlı stil cədvəli-CSS sənədin xarici görünüşünü 
təyin edən xassələr toplusudur. Onun vasitəsilə sənədin 
formatlaşması sürətlənir. Proqram 2 növ: sənəddaxili və xarici 
CSS-lərin yaradılması və redaktəsini təmin edir. Sənəddaxili 
kaskadlı stil cədvəli cari səhifənin formatlaşması üçün tətbiq 
edilir. Xarici kaskadlı stil cədvəli saytda ayrıca “.css” 
genişlənməsinə malik fayl kimi yaddaşda saxlanılır və saytın 
istənilən səhifəsinə tətbiq oluna bilər. 
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Yeni CSS yaratmaq üçün Text → CSS Styles →  New 
əmrini yerinə yetirmək və ya Window →  CSS Styles əmrini 
yerinə yetirməklə CSS Styles panelinin əks olunmasına nail 
olmaq və panelin sağ aşağı küncündəki ikinci düyməni - New 
CSS Style düyməsini sıxmaq lazımdır. Hər iki halda New CSS 
Style dialoq pəncərəsi açılır. İstifadəçi ilk növbədə stilin tipini 
müəyyən etməlidir. Qeyd edək ki, proqram İstifadəçi, HTML 
Teqini yenidən təyinetmə, CSS Selector tipli kaskadlı stil 
cədvəli yaradılmasını təmin edir. İstifadəçi CSS yaratmaq 
üçün Selector Type:-tiplər siyahısından Class (can apply to 
any tag) parametrini seçmək və Name sahəsində stilə ad 
vermək,   HTML stilini yenidən təyinetmə kaskadlı stil 
cədvəlini yaratmaq tələb olunduqda Selector Type:-tiplər 
siyahısından Tag (redefines  the look of a specific tag) tipini 
seçmək və Tag siyahısında HTML teqini müəyyən etmək, CSS 
selektor kaskadlı stil cədvəlini yaratmaq üçün isə Selector 
Type:-tiplər siyahısından Use CSS Selector  tipini, Selector 
siyahısından aşağıdakı parametrlərdən birini seçmək 
lazımdır1(şək.57-59): 

a:active2, a:hover3,   a:link4,  a:visited5. 

  
                  Şək.57.                                     Şək.58. 

                                                 
1CSS selektor kaskadlı stil cədvəlləri sənəddə hiperistinadın görünüşünü 
tənzimləyir. 
2 a:active  parametri  istinadın aktiv görünüşünü təyin edir. 
3  a:hover parametri kursoru istinadın üzərinə qoyduqda istinadın 
görünüşünü təyin edir. 
4 a:link parametri istinadın normal vəziyyətdə görünüşünü təyin edir. 
5 a:visited prametri istinaddan əvvəllər istifadə edilərsə onun görünüşünü 
təyin edir. 
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Şək.59. 

Bundan sonra stilin növünü təyin etmək lazımdır. Belə ki, 
cədvəldaxili stil yaratmaq üçün New CSS Style dialoq 
pəncərəsində This Document Only variantını, xarici stil cədvəli 
yaratmaq üçün New Style Sheet File variantını seçmək və OK 
düyməsini sıxmaq lazımdır. New Style Sheet File variantını 
seçdikdə açılan Save Style File As dialoq pəncərəsində fayla ad 
vermək və Save düyməsini sıxmaq lazımdır. Bu zaman  açılan 
CSS Style Definition dialoq pəncərəsində kaskadlı stil 
cədvəlinin parametrlərini müəyyən etmək lazımdır (şək.60).  

 
Şək.60. 

Parametrlər kateqoriyalar üzrə qruplaşmışdır. Belə ki, 
Type kateqoriyasında mətnin formatlaşma atributları, 
Background kateqoriyasında fon rənglərini və rəsmlər üçün 
Block kateqoriyasında söz və hərflərarası interval, abzas üçün, 
Box kateqoriyasında obyektlərarası interval üçün, Border-
obyektlərin sərhədləri üçün, List kateqoriyasında markerli 
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siyahı üçün, Positioning kateqoriyasında obyektin səhifədə 
yerləşməsi üçün, Extensions kateqoriyasında səhifənin 
bölünməsi, effektlər və s. üçün parametrlər müəyyən olunur. 
Pəncərənin OK düyməsini sıxmaqla CSS yaradılması 
tamamlanır. Yaradılmış kaskadlı stil cədvəli CSS Styles 
panelində əks olunur. 

Sənəddaxili stili cari səhifəyə tətbiq etmək üçün, onu 
xassə inspektorunun Style siyahısından seçmək lazımdır 
(şək.61).  

 
Şək.61. 

Xarici stil cədvəlini tətbiq etmək üçün CSS Styles panelinin 
aşağı küncündə yerləşən ilk düyməni-Attach Style Sheet 
düyməsini sıxmaq, açılan dialoq pəncərəsinin File/URL 
sahəsində xarici kaskadlı stil cədvəli faylını müəyyən etmək və 
Link parametrini seçmək lazımdır (şək.62). Bundan sonra 
cədvəldə nəzərdə tutulmuş stili xassə inspektorunun Style 
siyahısından seçmək lazımdır (şək. 61). 

Yaradılmış CSS cədvəlini redaktə etmək üçün panelin 
Edit Style Sheet düyməsini sıxmaq və açılan Edit Style Sheet 
dialoq pəncərəsində tələb olunan stili qeyd etmək və Edit 
düyməsini sıxmaq, açılan CSS Style Definition dialoq 
pəncərəsində yeni parametrlər müəyyən etmək lazımdır 
(şək.60). 
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Şək.62. 

 
 
 

1.4.5. Şablonlar və Obyektlər Kitabxanas ı 
 
Şablonlar saytın eyni və ya oxşar tərtibatlı Web 

səhifələrinin hazırlanması zamanı tətbiq edilir. Şablon özü 
HTML və ya XTML faylı olub, aşağıdakı sahələrdən ibarət 
olur: 
• Dəyişilməz sahə; 
• Redaktə olunan sahə; 
• Təkrar olunan sahə; 
• Təkrar olunan cədvəl sahəsi; 
• Məcburi olmayan sahə. 

Şablon yaratmaq üçün ilk öncə File New əmrini yerinə 
yetirib, yeni Web-səhifə yaratmaq, səhifə hazır olduqda File → 
Save As Template əmrini yerinə yetirmək, açılan dialoq 
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pəncərəsində saytın və şablonun adını müəyyən etmək və Save 
düyməsini sıxmaq lazımdır (şək.63). 

 
Şək.63. 

Qeyd edək ki, səhifə şablon kimi yaddaşda saxlandıqda   
şablon bütünlüklə dəyişilməz sahədən ibarət olur.  Şablonda 
redaktə olunan sahə təyin etmək üçün  müəyyən hissəni qeyd 
etmək, Insert→Template Objects→Editable Region əmrini 
yerinə yetirmək və açılan New Editable Region dialoq 
pəncərəsində sahəyə unikal ad vermək və OK düyməsini 
sıxmaq lazımdır. Bundan sonra redaktə olunan sahə göy-yaşıl 
rəngli, sol küncdə Editable Region :<sahənin adı>  başlığına 
malik düzbucaqlı çərçivə ilə haşiyələnir (şək.64). 

Təkrar olunan sahə səhifədə müəyyən sahənin surətinin 
təkrar daxil olunmasını təmin edir. Təkrar olunan sahəni 
müəyyən etmək üçün şablonun  müəyyən hissəsini qeyd etmək, 
Insert→Template Objects→Repating Region əmrini yerinə 
yetirmək, açılan New Repating Region dialoq pəncərəsində 
sahəyə unikal ad vermək və OK düyməsini sıxmaq lazımdır. 
Bundan sonra sahə Repating:<sahənin ad ı> başlığa malik 
çərçivə ilə haşiyələnir (şək.64).  
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Şək.64. 

Təkrar olunan cədvəl sahəsi cədvəlin yaradılmasını 
avtomatlaşdırmaq üçün tətbiq edilir.  Təkrar olunan çərçivə 
yaratmaq üçün Insert→Template Objects Repating Table 
əmrini yerinə yetirmək və açılan Insert Repating Table dialoq 
pəncərəsində cədvəlin sətr və sütunlarının sayı, xanalararası 
interval, cədvəlin enini və sərhəd üçün müvafiq parametrləri 
müəyyən etmək, cədvələ unikal ad vermək, xananın təkrar 
olunan sətrlərinin sayını təyin etmək və OK düyməsini sıxmaq 
lazımdır (şək.65). Cədvəl yaratdıqdan sonra standart vasitələrlə 
cədvəlin tərtibatı ilə də məşğul olmaq olar. 

 
Şək.65. 

Məcburi olmayan sahə şablon əsasında yaradılan 
səhifələrdə istifadəçinin istəyindən asılı olaraq əks olunur. 
Məcburi olmayan sahə təyin etmək üçün səhifənin müəyyən 
hissəsini qeyd etmək, Insert→Template Objects →Optional 
Region və ya Insert→Template Objects→Editable Optional 
Region əmrini yerinə yetirmək və açılan New Optional Region 
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dialoq pəncərəsində sahəyə unikal ad vermək və OK düyməsini 
sıxmaq lazımdır(şək.66).  

 
Şək.66. 

Şablon əsasında yeni səhifə yaratmaq üçün File New 
əmrini yerinə yetirmək və açılan dialoq pəncərəsinin Template 
bölməsində müvafiq şablonu seçmək və Create düyməsini 
sıxmaq lazımdır (şək.67). 

 
Şək.67. 

Şablonu həmçinin cari səhifəyə də tətbiq etmək olar. Bunun 
üçün Windows →  Assets əmrini yerinə yetirməklə əks olunan 
Assets panelinin Template düyməsini sıxmaq, sonra şablon 
siyahısından tələb olunan şablonu seçmək və Apply düyməsini 
sıxmaq lazımdır (şək.68). 
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Şək.68. 

Şablon əsasında yaradılmış Web səhifənin redaktə olunan 
sahəsində redaktə işi-informasiya daxil edilməsi, ləğv olunması 
və s. əməliyyatlar aparılır. Təkrar olunan sahələrdə + 
düyməsini sıxmaqla təkrarlanan hissənin surətini əlavə etmək 
olar. Təkrar olunan sahə redaktə oluna bilən olduqda daxil 
edilmiş hissədə  -  düyməsini sıxmaqla ləğv etmək olar. 
Səhifədə məcburi olmayan sahələrin əks olunmasını 
tənzimləmək üçün Modify →Template Properties əmrini 
yerinə yetirmək və açılan dialoq pəncərəsində müvafiq məcburi 
olmayan sahəni qeyd etmək,  Show <sahənin adı>  
parametrini aktiv və ya qeyri-aktiv etmək və OK düyməsini 
sıxmaq lazımdır (şək.69). 

 
Şək.69. 
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Hazırlanmış şablonu redaktə etmək üçün Modify→Templates 
→Update Current Page əmrini yerinə yetirmək və açılan 
dialoq pəncərəsində şablonu seçmək  və OK düyməsini sıxmaq 
lazımdır. Bundan sonra avtomatik olaraq səhifənin hazırlandığı 
şablon əks olunur və istifadəçi onun üzərində redaktə işi apara 
bilər. Səhifəni şablondan azad etmək üçün isə  Modify →  
Templates→Detach from Template əmrini yerinə yetirmək 
kifayətdir. 

Obyektlər kitabxanası səhifədə təkrar olunan obyektlərin 
saxlanılmasını təmin edir. Kitabxanaya obyekt daxil etmək 
üçün Assets panelinin Library bölməsinə daxil olmaq və 
səhifənin obyektini qeyd edib siçanın sol düyməsini sıxmaqla 
panelin aşağı hissəsinə əlavə etmək lazımdır. Obyekti redaktə 
etmək üçün onu qeyd etmək, Redaktə düyməsini sıxmaq və 
açılan redaktorda redaktə işi aparmaq lazımdır. Obyekti 
səhifəyə daxil etmək üçün isə obyektə uyğun elementi qeyd 
etmək, siçanın sol düyməsini sıxmaqla səhifənin müəyyən 
hissəsinə sürüşdürmək və bundan sonra sıxılmış düyməni 
buraxmaq lazımdır.                    

 
 
 
 

1.4.6. Server əlavələrinin yarad ılmas ı 

Konkret olaraq ASP texnologiyası vasitəsilə server 
əlavəsi yaratmaq üsulu ilə tanış olaq.   

Server əlavəsi yaratmaq üçün File→New əmrini yerinə 
yetirmək, açılan dialoq pəncərəsinin General bölməsində 
Cateqory siyahısından Dynamic Page elementini və ona 
müvafiq Dynamic page siyahısından ASP VBScript 
texnologiyasını seçmək və Create düyməsini sıxmaq lazımdır 
(şək.70). Bu zaman asp genişlənməsinə malik boş dinamik 
səhifə yaranır. 
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Şək.70. 

  Sonrakı addımda  Verilənlər bazası ilə əlaqə yaratmaq 
lazımdır. Bunun üçün Window → Databases əmrini yerinə 
yetirmək və bu zaman əks olunan Databases panelində + 
düyməsini sıxdıqda Data Source Name (DSN) əmrini yerinə 
yetirmək və açılan-dialoq pəncərəsinin Connection Name 
sahəsinə əlaqənin adını, Date source name (DSN): sahəsinə 
bazaya qoşulma adını, istifadəçinin tanınmasını təmin edən 
indenfikatorları User Name və Password sahələrinə daxil 
etmək1, Us ıng DSN on Testinq server parametrini seçmək, 
Test düyməsini sıxmaqla əlaqəni testdən keçirmək və testin 
nəticəsi müsbət olduqda OK düyməsini sıxmaq lazımdır 
(şək.71). 

                                                 
1  Bazadan istifadə etmə «müxtəlif hüquqlu» rejimlə  təmin olunarsa bu 
parametrləri daxil etmək lazımdır. 
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Şək.71. 

Əlaqə yarandıqdan sonra bazanın konkret informasiya 
ehtiyatına qoşulmanı təmin edən  yazı toplusuna uyğun  server 
reaksiyasını müəyyən etmək lazımdır. Bunun üçün İnsert 
panelinin Applications kateqoriyasının və ya Server Behaviors 
panelinin Server Behaviors panelinin +    düməsini sıxmaqla 
açılan reaksiya siyahısından Recordset reaksiyası daxil etmək 
lazımdır (şək72).  

 
Şək.72. 

Sonra açılan dialoq pəncərəsinin Name və Connection 
sahələrinə müvafiq olaraq yazı toplusunun və əlaqənin adı, 
SQL sahəsinə isə toplunu təyin edən sorğu daxil edilməlidir. 
Daha  sonra  Test düyməsini sıxmaqla sorğunun düzgünlüyü 
yoxlanılmalı və bundan sonra OK düyməsi sıxılmalıdır 
(şək.73). 
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Şək.73. 

Yazı toplusu müəyyən olunduqdan sonra informasiyanın 
idarə olunmasını təmin edən digər server reaksiyalarını 
müəyyən etmək lazımdır. Məsələn, uzaq məsafədən  bazaya 
informasiya daxil olunmasını təmin etmək üçün İnsert 
panelinin Applications kateqoriyasının Insert Record:Record 
İnsertion Form Wizard reaksiyasını əlavə etmək lazımdır. Bu 
zaman açılan dialoq pəncərəsində müvafiq olaraq əlaqənin 
adını, cədvəli və cədvəlin sahələrini, tələb olunarsa sahənin 
avtomatik olaraq aldığı qiyməti müəyyən etmək və OK 
düyməsini sıxmaq lazımdır (şək.74).  

 
Şək.74. 
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Təyin olunmuş informasiya toplusunun cədvəl şəklində əks 
olunması üçün isə İnsert panelinin Applications 
kateqoriyasının Dynamic Data:Dynamic Table elementini 
sıxmaqla Dynamic Table reaksiyasını əlavə etmək və açılan 
dialoq pəncərəsində müvafiq olaraq yazı toplusunun adını, əks 
olunacaq yazıların sayını, ehtiyac olarsa, cədvəlin sərhədinin 
qalınlığını, xanalararası intervalı və xanalarda informasiya və 
sərhəd arasında boşluğun ölçüsünü təyin etmək lazımdır 
(şək.75). 

 
Şək.75. 

İstifadəçi həmçinin cədvəlin xassə inspektoru vasitəsilə cədvəli 
formatlaşdıra bilər. Cədvəldəki konkret informasiyaya keçidi 
təmin etmək üçün İnsert panelinin Applications 
kateqoriyasının Recordset Naviqation Bar reaksiyasını daxil 
etmək lazımdır. 

Qeyd edək ki, İnsert  panelinin Applications 
kateqoriyasının müvafiq elementləri vasitəsilə həmçinin 
istifadəçinin audentifikasiyası, dinamik forma və s. 
reaksiyalarını daxil etmək olar. 

 
 
 

 1.4.7. Saytın testdən keçirilməsi və uzaq məsafədə yerləşən 
Web serverə göndərilməsi 
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 Saytı uzaq məsafədə yerləşən Web serverə 
göndərməzdən əvvəl onu testdən keçirmək lazımdır. İlk öncə 
saytın səhifələrinin müxtəlif brauzerlərdə qüsursuz görünüşünə 
əmin olmaq lazımdır. Bu məqsədlə, əvəlcə File→Preview in 
Browser → Edit Browser List əmrini yerinə yetirmək və 
açılan Preferences dialoq pəncərəsinin Preview in Browser + 
düyməsini sıxmaqla brauzerlər siyahısını tərtib etmək lazımdır 
(şək.76). 

 
Şək.76. 

Bundan sonra səhifənin konkret brauzerdə görünüşünə baxmaq 
üçün File→Preview in Browser → <brauzerin ad ı> əmrini 
yerinə yetirmək lazımdır. 

Praktikada saytda ən çox səhv hiperistinadların düzgün 
müəyyən olunmaması, redaktə zamanı saytın hər hansı bir 
səhifəsi ləğv olunduqda və ya səhifənin ünvanı dəyişdikdə 
istinad olunacaq səhifənin tapılmaması səbəbindən baş verir. 
Buna görə də saytda hiperistinadların işləməsini testdən 
keçirmək zəruridir. Bu məqsədlə Site →Check Links Stiwide 
əmrini yerinə yetirmək lazımdır. Testin nəticəsi Results 
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panelində əks olunacaqdır.  Test nəticəsində hər hansı bir 
hiperistinadın düzgün təyin olunmadığı aşkar olduqda, saytda 
onu digərilə əvəz etmək lazım gəlir. Nəzərə alsaq ki, bu istinad 
saytın müxtəlif səhifələrində iştrak edə bilər, düzgün təyin 
olunmayan istinadın hamısını  digər istinad ilə əvəz etmək üçün 
Site →Change Links Stiwide əmrini yerinə yetirmək, açılan 
Change Links Stiwide dialoq pəncərəsinin Change all links to 
sahəsində dəyişiləcək istinadın ünvanı, Into links to sahəsində 
isə istinadın yeni ünvanını müəyyən edib OK düyməsini 
sıxmaq lazımdır (şək. 77).  

 
Şək.77. 

Hazır saytı uzaq məsafədə yerləşən serverə göndərmək üçün  
Site→Put əmrini yerinə yetirmək lazımdır. Bu zaman uzaq 
məsafədə yerləşən saytla əlaqə yaranır və lokal saytın fayl 
strukturu uzaq məsafədə yerləşən sayta köçürülür. Saytın 
konkret qovluğunu və ya sənədini göndərmək tələb olunduqda 
isə qovluğu və ya sənədi qeyd edib Site → Put əmrini təkrar 
yerinə yetirmək lazımdır.  
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2.1. MAPLE  9.01 RİYAZİ PRORQAM PAKETİ 
 
Maple 9.01 Waterloo Maple, Inc. (Kanada) firması 

tərəfindən hazırlanmış, riyazi məsələlərin analitik və ədədi 
həllini təmin edən riyazi proqram paketidir. Proqramın 
alqoritmik bazası riyaziyyatın bütün sahələrini əhatə edir. Bu 
səbəbdən dünyanın 300-dən artıq qabaqcıl universitetlərində (o 
cümlədən Moskva Dövlət Universiteti) paket tədris olunur, 
elmi-tədqiqatlar aparılmasında geniş istifadə olunur. Bu gün  
paketin lisenziyalı istifadəçilərinin sayı artıq millionu 
keçmişdir. Bir faktı da qeyd etmək lazımdır ki, bu gün geniş 
istifadə olunan Matlab,   Mathcad, Scientific WorkPlace və 
digər riyazi proqram paketləri analitik hesablamaları məhz 
Maple paketinin alqoritm kitabxanası əsasında yerinə yetirir.  

Maple paketi böyük inkişaf və aprobasiya yolu 
keçmişdir. Bu gün paket müxtəlif əməliyyat sistemləri 
platformasında bütün növ kompüterlərdə, o cümlədən 
maynfremlərdə,  Sun işçi stansiyalarında, IBM və Macintosh 
tipli fərdi kompüterlərdə,  Casio - Cassiopeia firmasının 
miniatür kompüterlərində müvəffəqiyyətlə istifadə olunur.  

Maple 9.01 etibarlı və intellektual paketdir. Paket 
proqramlaşdırma dilinə, çoxsaylı riyazi məsələlərin analitik və 
ədədi həll alqoritmik bazasına, diaqnostika sisteminə, çoxsaylı 
funksiyalar kitabxanasına malikdir. Paket həmçinin sənədlərin 
hazırlanmasını və redaktəsini təmin edən  çoxpəncərəli 
redaktorla təchiz olunmuş, digər proqram paketlərinin və  
alqoritmik dillərdə hazırlanmış alqoritmlərdən istifadə 
imkanına malikdir.   

 
 

2.1.1. İnterfeys elementləri və əsas anlayışlar 
 
 Maple 9.01  paketi sadə və  əlavələr üçün standart 
interfeys elementlərinə: əsas və kontekst menyu sisteminə, 
ToolBar, ContextBar, Symbol, Expression, Matrix, Vector 
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panellərinə, sənəd pəncərəsinə, StatusBar-cari vəziyyət sətrinə 
malikdir  (şək.1). 

 Şək.1. 

Sənədin yaradılması, redaktə olunması, formatlaşması, 
paketin parametrlərinin nizamlanması əsas menyu sistemi 
vasitəsilə həyata keçirilir. Əsas menyu sistemi menyu sətrində 
toplanmış File, Edit, View, Insert, Format, Tools, Window, 
Help menyularından ibarətdir. Hər bir menyu isə əmrlər 
siyahısından ibarətdir. Menyudan istifadə etmək üçün kursoru 
onun üzərinə qoyub siçanın sol düyməsini sıxmaq, açılan 
əmrlər siyahısı ilə tanış olmaq və ya müvafiq əmri seçib siçanın 
sol düyməsini yenidən sıxmaqla əmri yerinə yetirmək lazımdır. 
Kontekst menyu konkret obyektlə bağlı olub, kursoru obyektin 
üzərinə qoyub siçanın sağ düyməsini sıxmaqla aktivləşir. 
Məsələn, kursoru cədvəl obyektinin üzərinə qoyub siçanın sağ 
düyməsini sıxdıqda cədvəl üzərində redaktə əməliyyatları 
aparmağı təmin edən kontekst menyu açılır (şək.1)  
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ToolBar paneli File, Edit, View, Insert, Help  
menyularının bir sıra əmrlərinin yerinə yetirilməsini təmin edən 
alətləri özündə saxlayır.  ContextBar paneli isə cari və ya qeyd 
olunmuş obyektin formatlaşmasını təmin edən alətləri özündə 
saxlayır. Bu alətlər Format menyusunun müvafiq əmrlərinin 
funksiyalarını yerinə yetirir. Qeyd edək ki, istifadəçi kursoru 
hər iki panelin üzərinə gətirdikdə alətin funksiyası haqqında 
məlumat sarı düzbucaqlı cərçivədə əks olunur (şək.2)    

 
Şək.2. 

Symbol, Expression, Matrix, Vector panelləri müvafiq 
olaraq yunan əlifbasının hərflərinin və ie ,,, π∞  simvollarının, 
riyazi ifadə (məsələn, inteqral, diferensial, limit və s.), matris 
və vektor şablonlarının daxil edilməsini təmin edir. 

Sənədin yaradılması (məsələnin riyazi qoyuluşu, həlli),  
sənədin redaktə olunması, formatlaşması sənəd pəncərəsində 
həyata keçirilir. Proqram eyni zamanda bir neçə sənəd 
pəncərəsilə işləməyi təmin edir. StatusBar-cari vəziyyət 
sətrində cari yerinə yetirilən əməliyyat haqqında informasiya 
əks olunur. Qeyd edək ki,  ToolBar, ContextBar,  Symbol, 
Expression, Matrix, Vector panellərinin və cari vəziyyət 
sətrinin interfeys pəncərəsində əks olunması müvafiq olaraq 
View   ToolBar, View  ContextBar, View  Palette  
Symbol, View  Palette  Expression, View  Palette  
Matrix, View  Palette  Vector, View  StatusBar 
əmrlərilə tənzimlənir. View  Palette Show əmri Symbol, 
Expression, Matrix, Vector panellərinin hamısının əks 
olunmasını, View  Palette  Hide All əmri hamısının 
görünməz olmasını,  View  Palette  Cascade əmri isə 
onların pəncərədə ardıcıl düzülüşlə əks olunmasını tənzimləyir. 
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Maple 9.01  riyazi proqram paketi olduğundan,  
məsələnin həlli riyazi ifadələrə əsaslanır. Riyazi ifadələr 
müstəqil olaraq, əmr  və şərh daxilində istifadə olunur. Riyazi 
ifadələrin tərtibində dəyişənlərdən, sabitlərdən, hesabi və 
məntiqi operatorlardan istifadə olunur.  Dəyişənin adı hərflə 
başlayan istənilən sayda simvoldan ibarət ola bilər. Dəyişənə  
ifadə, sabit, vektor və ya matris «:=»  işarəsi vasitəsilə 
mənimsədilir. Maple 9.01 –də tam, həqiqi, rasional və 
kompleks ədədi sabitlərdən, sətr tipli və aşağıdakı standart 
sabitlərdən istifadə olunur: 

• Pi- 141.3=π ; 
• Gamma – Eyler sabiti 490.57721566=γ ; 
• false – məntiqi «yalan»;  
• true-məntiqi «doğru»; 
• infinty –sonsuzluq; 
• Catalan-0,915965594-ə bərabər Katalan sabiti.   

Sətr tipli sabitlər apastrof daxilində yazılır. Məsələn, 
> d:='Azad'; b:='Qurbanov'; 
                          d := Azad 
                          b := Qurbanov 

Qeyd edək ki, bu sabitlərə hər hansı digər qiymət və ya 
ifadə mənimsədilsə sistem onu avtomatik səhv qəbul edəcək. 
Dəyişənin və sabitin adı olaraq xüsusi sözlərdən istifadə etmək 
olmaz. 

Kompleks ədədin xəyali hissəsi I ilə işarə olunur və 
ədəd ümumi şəkildə a+bI kimi daxil edilir. 

İfadənin tərtibi zamanı aşağıdakı hesabi və məntiqi 
operatorlardan istifadə olunur: 

 

 

Hesabi 
operatorun 

Əməliyyatın 
adı 

Məntiqi 
operator

Əməliyyatın adı 
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+  Toplama > Böyükdür  

- Çıxma < Kiçikdir 

* Vurma >= Böyük bərabərdir  

/ bölmə,  <= Kiçik bərabərdir  

** və ya ^ Qüvvətə 
yüksəltmə 

= Bərabərdir 

@ kompozisiya  <> Fərqlidir 

@@ Təkrar 
kompozisiya   

Or Məntiqi «və ya» 

mod bölmə zamanı 
qalıq  

And Məntiqi «və»  

Məsələn: 
>y:=17 mod 2; 
                               y := 1 
>f:=1/(a-5):(f@@3)(k); 

5
5

5)(
1
1

1:

−

⎟
⎟
⎟
⎟
⎟

⎠

⎞

⎜
⎜
⎜
⎜
⎜

⎝

⎛

−⎟⎟
⎠

⎞
⎜⎜
⎝

⎛
−

=

ka
a

a

y    

Bundan əlavə %, %% və %%% operatorlarından da 
istifadə olunur. % operatoru cari sətrdən əvvəlki ifadənin 
nəticəsini, %% və %%% operatorları isə müvafiq olaraq 
axırdan ikinci və üçüncü ifadənin nəticəsini daxil edir. 

Məsələn, 
> 2+3; 
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>%+a; 
5+a. 
Maple çoxluqlar, siyahılar və massivlər üzərində 

əməliyyatlar aparmaq iqtidarına malikdir. Çoxluğun elementləri 
{ } arasında, siyahının elementləri isə [ ] arasında bir-birindən 
vergüllə ayrılmaqla yazılır. 

Məsələn; 

d}c,b,{a,: x
d};c,b,{a,: x

=
=>

                         

[1,2,4]: x
[1,2,4];: x

=
=>

 

  Matris və  vektoru  iki üsulla təyin etmək olar: 
1. Matrix və  Vector panellərinin  matrisin və  vektorun 
ölçüsünə müvafiq alətlərii vasiətsilə  sənədə daxil edilən  
şablonda %? işarəsinin yerinə  matris və vektorun 
elementlərini daxil etməklə1.  Məsələn, 
> <<12 | 23| 23>, <33 | 333 | 33>, <33 | 33 | 33>>: 
> <12 | 23| 23>: 

2. Vektorun təyin olunması üçün vector(s), matrislərin 
təyin olunması üçün  isə array (s, s1), matrix(n,m,s) və ya 
matrix(s,s1) funksiyalarından istifadə etməklə; burada m, n 
matrisin sətr və sütun elementlərinin sayı , s  və s1 – vektorun 
və matrisin elementlərindən ibarət siyahılardır. Məsələn: 

[2,3,4,5]: B                          
3,4,5]);vector([2,:B

=
=>

 

1,1,1,1])[2,3,4,5][[3,4,5,6],,3,4,5],matrix([[2:A =>  

                                                 
1 Matrix вя  Vector панелляри мцвафиг олараг  View  Palette Matrix 
вя View Palette Vector ямрлярини йериня йетиримякля интерфейс 
пянъярясиндя якс олунур.  
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⎥
⎥
⎥
⎥

⎦

⎤

⎢
⎢
⎢
⎢

⎣

⎡

=

1111
5432
6543
5432

:A  

Vektoru siyahıya və əksinə siyahını vektora çevirmək 
mümkündür. Bunun üçün müvafiq olaraq convert(vector, list) 
və convert(list, vector) əmrlərini yerinə yetirmək lazımdır. 

Təyin olunmuş  vektorun və ya matrisin konkret 
elementinə, elementin indeksi vasitəsilə müraciət olunur. 
Məsələn, 

5  :d                          
B[2];3:d :3,4,5])vector([2,:B

=
+==>  

Maple çox geniş standart riyazi funksiyalar bazasına 
malikdir. Onlardan bir qismi aşağıdakı cədvəldə verilmişdir. 

Riyazi yazılış  Maple paketində 
yazılış  

xe  exp(x) 
xln  Ln(x) 
xlg  Log10(x) 

xalog  log[a](x) 
x  sqrt(x) 

x  abs(x) 
xsin  Sin(x) 
xcos  cos(x) 

xtg  tan(x) 
xctg  cot(x) 
xsec  sec(x) 
xeccos  csc(x) 
xarcsin  Arcsin(x) 
xarccos  Arccos(x) 
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Riyazi yazılış  Maple paketində 
yazılış  

xarctg  Arctan(x) 
xarcctg  Arccot(x) 

xsh  Sinh(x) 
xch  Cosh(x) 
xth  tanh(x) 
xcth  Coth(x) 

)(xδ - Dirak funksiyası Dirac(x) 
)(xθ - Xevissayda 
funksiyası 

 

Heaviside(x) 

Bundan əlavə istifadəçi öz funksiyasını da təyin  edə 
bilər. İstifadəçi funksiyası aşağıdakı yazılışa malikdir: 
<name>: =(<x,y…>)→expr. Burada name-funksiyanın adı, 
x,y,… arqumentləri, expr funksiyanın analitik ifadəsidir. 

 Məsələn,  

y−→=

〉=>
4xy)(x,:f                      

sqrt(y);-x^4y)-(x,:f
  

0253.763932                             
);5,4(f>

 

 
 
 

2.1.2. Sənədin yaradılması , yaddaşda saxlanılması, çapı  və 
uzaq məsafəyə göndərilməsi 

 
Yeni sənəd avtomatik olaraq Maple 9.01   proqramı   

yükləndikdə açılan boş sənəd pəncərəsində yaradılır. Sistem 
sənədi şərti olaraq Untitled (1) adlandırır. Proqramla seans 
müddətində yeni sənəd  File→New əmrini yerinə yetirdikdə, 
«Ctrl+N» düyməsini sıxdıqda və ya standart alətlər panelinin 
ilk alətini sıxdıqda açılan boş sənəd pəncərəsində yaradılır. 
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Sənəd pəncərəsində məsələnin riyazi qoyuluşu, məsələnin 
həllinə dair şərhlər, məsələnin həlli üçün əmrlər daxil edilir, 
məsələnin həlli analitik, ədədi və  ya qrafiki şəkildə əks olunur.  

Əmr və hesablanması tələb olunan riyazi ifadələr Maple 
İnput sahəsində [> işarəsindən sonra əmr sətrində daxil edilir. 
Qeyd edək ki, daxil edilmiş əmr və ifadələrdən sonra  «;» və ya 
«:» işarələri qoyulur. «:» işarəsi əmri və ya ifadənin nəticəsinin 
ekranda əks olunmamasını təmin edir.  Enter düyməsini 
sıxdıqda əmrin və hesablamanın nəticəsi növbəti sətrdə əks 
olunur.  Məsələnin həllinə dair şərhlər mətn fraqmenti kimi 
daxil edilir. Bunun üçün Insert→Text  əmrini yerinə yetirmək 
və ya ToolBar panelinin  düyməsini sıxmaq   lazımdır. Bu 
zaman  Text sahəsi aktivləşir və istifadəçi şərhi [ işarəsindən 
sonra klaviaturadan daxil edə bilər və ya mübadilə buferindən 
daxil edə bilər. Şərhdə həmçinin riyazi ifadələr də  istifadə 
oluna bilər1. Yerinə yetirilməyən  riyazi ifadələr  daxil etmək 
üçün İnsert→Standard Math əmrini  yerinə yetirmək və 
Standard Math sahəsində riyazi ifadəni klaviaturadan və ya 
Expression palitrasının müvafiq alətləri vasitəsilə daxil etmək 
lazımdır.   

Yenidən əmr sətrini aktivləşdirmək üçün 
İnsert→Maple İnput əmrini yerinə yetirmək, və ya ToolBar 
panelinin      düyməsini sıxmaq lazımdır. 

Sənəddə həmçinin, cədvəldən, hiperistinadlardan, 
müxtəlif şəkillərdən də istifadə etmək olar. Sənədə elektron 
cədvəl daxil etmək üçün İnsert→Spreadsheet əmrini yerinə 
yetirmək lazımdır. Sənədə cədvəl daxil olunduqda menyu 
sətrinə avtomatik olaraq Spreadsheet menyusu əlavə olunur.  
Cədvəldə informasiya, hesablama  düsturları MS Exsel 
proqramında olduğu kimi xanalara daxil olunur. İstifadəçi 
düstur əsasında Spreadsheet→Evalute əmrini yerinə 
yetirməklə qeyd edilmiş xanalarda, Selection 

                                                 
1 Адятян мясялянин рийази гойулушу дахил едилдикдя мятнля йанашы рийази 
ифадяляр дя дахил едилир. 
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Spreadsheet→Evalute Spreadsheet əmrini yerinə yetirməklə 
isə cədvəldə hesablama əməliyyatı apara bilər. Cədvələ yeni 
sətir və sütun əlavə etmək üçün müvafiq olaraq 
Spreadsheet→Row→Insert, Spreadsheet→Column→Insert 
əmrini, cari və qeyd olunmuş sətr və sütunları ləğv etmək üçün 
isə müvafiq olaraq Spreadsheet→Row→Delete, 
Spreadsheet→Column→Delete əmrini yerinə yetirmək 
lazımdır. Cari və ya qeyd olunmuş sətr və sütunların ölçüləri 
müvafiq olaraq Spreadsheet→Row→Height, 
Spreadsheet→Column →Width  əmrləri vasitəsilə 
tənzimlənir. 

Cari sənəddən digər sənədlərə, obyektlərə, Web 
səhifələrə, E-mail  ünvanına istinad yaratmaq üçün Insert 
→Hyperlink əmrini yerinə yetirmək,  Hyperlink Properties  
dialoq pəncərəsində istinad mətnini, istinadın tipini müəyyən 
etmək və OK düyməsini sıxmaq lazımdır. 

İstifadəçi hazır şəkilləri sənədə daxil etmək üçün 
İnsert→Image əmrini yerinə yetirməli və açılan İnset Image 
dialoq pəncərəsində şəklin ünvanını müəyyən etməlidir. Şəkli 
istifadəçi özü də çəkə bilər. Bunun üçün İnsert→Sketch 
əmrini yerinə yetirmək və əks olunan Sketch sahəsində Paint 
proqramında olduğu kimi rəsm çəkmək olar. 

Yaradılmış sənəd çoxsəhifəli ola bilər. Qeyd edək ki, yeni 
səhifəyə keçid avtomatik olaraq informasiyanın həcmi 
çoxaldıqda baş verir. Məcburi olaraq yeni səhifəyə keçid isə 
İnsert→Page Break əmri vasitəsilə təmin olunur. 

Yaradılmış yeni sənədin və sənəd üzərində edilmiş 
dəyişikliklərin yaddaşda saxlanılması üçün File→Save əmri 
yerinə yetirilməlidir. Yeni sənədi yaddaşda saxladıqda açılmış 
Save As pəncərəsində sənədin adı və tipi, sənədin saxlanılmalı 
olduğu disk və ya qovluq müəyyən olunduqdan sonra Save 
düyməsi sıxılmalıdır (şək.1). Əgər mövcud sənədi başqa adla, 
başqa yerdə (digər qovluqda, diskdə) və başqa parametrlərlə 
yaddaşda saxlamaq tələb olunarsa, Save As əmri yerinə 
yetirilməlidir. Əmri yerinə yetirdikdə Save As pəncərəsi açılır 
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və istifadəçi sənədin yeni ünvanını müəyyən edib, Save 
düyməsini sıxmalıdır. 

 
Şək.1. 

Sənədi həmçinin Html, Rtf sənədləri kimi yaddaşda 
saxlamaq olar. Bunun üçün File→Export As əmrini yerinə 
yetirmək , sənədə ad vermək, müvafiq sənəd tipini seçmək və 
Save düyməsini sıxmaq lazımdır. 
 Hazır sənədi çap etməzdən əvvəl səhifənin 
parametrlərini müəyyən etmək lazımdır. Bunun üçün File→ 
Page setup əmrini yerinə yetirmək və bu zaman açılan dialoq 
pəncərəsinin müvafiq elementləri vasitəsilə səhifənin sağ, sol, 
yuxarı və aşağı kənarlarından boş məsafələrin buraxılmasını, 
səhifənin ölçüsünü, çapın istiqamətini (kitab və ya albom 
formasında) müəyyən etmək lazımdır (şək.2). 
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Şək.2. 

 Daha sonra File → Print Preview əmrini yerinə yetirməklə 
sənədin səhifələrinin görünüşünə baxmaq məsləhətdir. Əgər 
sənədin görünüşü qənaətbəxş deyilsə, alətlər panelinin Close 
düyməsini sıxıb sənədi yenidən redaktə etmək gərəkdir. Əks 
halda alətlər panelinin printer düyməsini sıxmaqla onu çap 
etmək olar. Print düyməsini sıxdıqda açılan pəncərədə 
istifadəçi çap parametrlərini müəyyən edib OK düyməsini 
sıxmalıdır (şək.3). Çap parametrləri sənədin cari səhifəsini, 
konkret səhifələri, qeyd olunmuş mətn fraqmentini və sənədi 
bütövlükdə bir və ya bir neçə nüsxədə çap etməyi təmin edir. 
Qeyd edək ki, sənədi həmçinin File→Print əmrini yerinə 
yetirməklə də çap etmək olar. Bu halda da dialoq pəncərəsi 
açılır və istifadəçi çap parametrlərini müəyyən edib OK 
düyməsini sıxmalıdır. 
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Şək.3. 

Hazır sənədi həmçinin File→Send  əmrini yerinə yetirməklə 
elektron poçt vasitəsilə uzaq məsafədə yerləşən istifadəçiyə 
göndərmək olar. 

İstifadəçi sənəd üzərində işi bitirdikdən sonra Close 
əmrini yerinə yetirib sənəd pəncərəsini bağlamalıdır. Əks halda 
proqramla işi bitirdikdə1 proqram bağlanmamış sənəd 
pəncərələrinin bağlanmasını  tələb edir. Əgər sənəd üzərində 
edilmiş son dəyişikliklər yaddaşda saxlanılmamışdırsa, bu 
haqda xəbərdarlıq pəncərəsi açılır. Pəncərənin Yes, No, Cancel  
düymələri müvafiq olaraq bu dəyişikliklərin yaddaşda 
saxlanılmasını, saxlanılmamasını və sənəd pəncərəsinin 
bağlanılmasından imtina edilməsini təmin edir. 

 
 

2.1.3. Riyazi analiz məsələlərinin həlli 
 
Maple çoxsaylı riyazi analiz məsələlərini analitik həll 

etməyə qadirdir. Bir sıra məsələlərin həlli zamanı öz yazılışına 

                                                 
1 Бунун цчцн Филе→Ехит ямрини йериня йетирмяк лазымдыр. 
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görə oxşar, iki əmrdən istifadə olunur. Belə ki, böyük hərflə 
başlayan əmr məsələsinin «təbii riyazi» yazılışını, kiçik hərflə 
başlayan əmr isə məsələnin analitik hesablanmasını təmin edir.  

Sıranın hədlərinin cəminin və hasilinin hesablanması 
Sıranın hədlərinin cəmini ifadə etmək üçün Sum(f, 

k=m…n) əmrindən, hədlərinin cəmini hesablamaq üçün  
sum(f, k=m…n) əmrindən istifadə olunur; burada f-sıranın 
hədlərini ifadə edən funksiya, k- cəmləmə  indeksi, m və n 
müvafiq olaraq indeksin aldığı ilk və son qiymətdir.  

Məsələn,  
> Sum(exp(n/2),n=0..10); 

∑
=

⎟
⎠
⎞

⎜
⎝
⎛10

0

2
1

n

n
e  

> sum(exp(n/2.),n=0..10); 
5375.649671 

> Sum(exp(n/2),n=0..10)=sum(exp(n/2.),n=0..10); 

5375.649671
10

0

2
1

=∑
=

⎟
⎠
⎞

⎜
⎝
⎛

n

n
e  

Sıranın hədlərinin hasilini ifadə etmək üçün Product 
(f,k=m..n),  hasili hesablamaq üçün isə  product (f,k=m..n) 
əmrlərindən istifadə etmək lazımdır. Məsələn, 

>Product(exp(n/2),n=0..10); 

∏
=

⎟
⎠
⎞

⎜
⎝
⎛10

0

2
1

n

n
e  

> product(exp(n/2.),n=0..10); 
12100.877199251⋅  

> Product(exp(n/2),n=0..10)=product(exp(n/2.),n=0..10); 
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12
10

0

2
1

100.877199251⋅=∏
=

⎟
⎠
⎞

⎜
⎝
⎛

n

n
e  

Qeyd edək ki, riyaziyyatdan fərqli olaraq hədlərin yerini 
dəyişdikdə cəmin və hasilin qiyməti dəyişir. Aşağıdakı yazılış 

∏∏
=

⎟
⎠
⎞

⎜
⎝
⎛

=

⎟
⎠
⎞

⎜
⎝
⎛

≠
10

0

2
10

10

2
1

n

n

n

n
ee olduğunu təsdiq edir. 

>Product (exp(n/2),n=10..0)= product(exp(n/2.),n=10..0); 

9-
0

10

2
1

10 3.169189792⋅=∏
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⎜
⎝
⎛

n

n
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Eyni qaydada çoxqat cəmi və hasili də hesablamaq olar. 
Məsələn, 

>Product(Product(exp(k*n/2),n=0..10),k=1..5)= 
product(product(exp(k*n/2.),n=0..10),k=1..5); 

                               180
5

1

10

0

2
1

103.140111500⋅=∏ ∏
= =
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⎠
⎞

⎜
⎝
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Limitin hesablanması 
Limit anlayışı riyazi analizin fundamental anlayışlarından 

biridir. Limitin riyazi ifadəsi üçün Limit(f,x=a,par), 
hesablanması üçün limit(f,x=a,par) əmrlərindən istifadə 
olunur; burada f,  x=a nöqtəsində limiti axtarılan funksiya,  par  
yazılışda buraxıla bilən  parametr olub, left, right, real, complex 
qiymətləri alır. Bu qiymətlər müvafiq olaraq funksiyanın sol, 
sağ limitinin, limitin həqiqi və kompleks ədədlər oblastında 
hesablanmasını təyin edir. Məsələn,  
> Limit(sin(2*x)/x,x=0); 

x
x

x

)2sin(lim
0→

 

> limit(sin(2*x)/x,x=0); 
2 
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> Limit(x*(Pi/2+arctan(x)),x=-infinity) = 
limit(x*(Pi/2+arctan(x)), x=-infinity); 

1)arctan(
2

lim −=⎟
⎠
⎞

⎜
⎝
⎛ +

π
∞→

xx
x

 

> Limit(arctan(1/(1-x)),x=1,left)= 
limit(arctan(1/(1-x)), x=1, left); 

2
1

1
1arctanlim

1
π=⎟

⎠
⎞

⎜
⎝
⎛

−−→ xx
 

> Limit(arctan(1/(1-x)),x=1,right)= 
limit(arctan(1/(1-x)),x=1, right); 

2
1

1
1arctanlim

1
π−=⎟

⎠
⎞

⎜
⎝
⎛

−+→ xx
 

Funksiyanın törəməsinin hesablanması və 
inteqrallanması 

Funksiyanın törəməsinin riyazi ifadəsi  üçün Diff 
(f,x,x2,…,xn), törəmənin hesablanması üçün isə diff (f, 
x1,x2,…xn) əmrindən istifadə oluna bilər. Burada f törəməsi 
axtarılan funksiya və ya funksiyalar  siyahısı ola bilər Məsələn, 
>Diff(sin(x^2),x); 

                                )sin( 2x
x∂

∂  

>diff(sin(x^2),x); 
                                xx )cos(2 2  
>Diff(sin(x^2),x)=diff(sin(x^2),x); 

xxx
x

)cos(2)sin( 22 =
∂
∂  

Yüksək tərtibli törəmələri hesablamaq üçün isə aşağıdakı 
əmrdən istifadə etmək lazımdır: 
Diff (f,x$m,x2$m,…,xn$m)= diff (f,x$m,x2$m,…,xn$m); 
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 Burada m törəmənin tərtibini bildirir. Məsələn, 
> Diff(cos(2*x)^2,x$4)=diff(cos(2*x)^2,x$4); 

222
4

4

)2cos(128)2sin(128)2cos( xxx
x

+−=
∂
∂

 

Törəmənin hesablanması üçün həmçinin D(f) və ya D[i](f) 
operator yazılışından da istifadə olunur, burada i ifadə və ya 
müsbət ədəddir. Məsələn, 
> D(sin)(Pi); 

-1 
> f:=x-> ln(x^2)+exp(3*x): 
> D(f); 

)3(312 xe
x

x +→  

 İnteqralın hesablanması 
Qeyri–müəyyən inteqralın riyazi ifadəsi üçün  İnt(f,x), 

hesablanması üçün  int(f,x) əmrindən, müəyyən inteqralın 
riyazi ifadəsi üçün İnt(f,x=a..b), hesablanması üçün isə int (f,x 
=a..b) və ya int (f, x=a..b, c) əmrlərindən istifadə olunur. 
Burada c parametri əlavə inteqrallama şərtini təyin edir, a və b 
isə inteqralın aşağı və yuxarı sahələrini bildirir. Məsələn, 
> Int((1+cos(x))^2, x=0..Pi)=int((1+cos(x))^2, x=0..Pi); 

π=+∫
π

2
3))cos(1(

0

2dxx  

Müəyyən inteqralın ədədi üsulla qiymətinin tapılması üçün 
evalf(int(f, x=a..b)) əmrindən istifadə etmək olar. 
> Int((1+cos(x))^2, x=0..Pi)=evalf(int((1+cos(x))^2, x=0..Pi));  

               14.71238898))cos(1(
0

2 =+∫
π

dxx                        

Bir sıra hallarda Maple 9.01 inteqralı hesablaya bilmir və 
bu zaman inteqralın təkrar yazılışı sənəddə əks olunur. Belə 
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olduqda toyler və convert əmrləri vasitəsilə inteqralaltı ifadəni 
teylor sırasına ayırıb inteqrallama əməliyyatını aparmaq olar 
Məsələn, 

876532

720
1

1680
1

90
1

40
1

6
1

2
1

);),8.0),)),in((int(exp(s(

xxxxxxx

polynomxxxtaylorconvert

+−−−++

=>
 

Eyni qayda ilə çox qat inteqral da hesablanılır. Məsələn,  

xdyd
xy

yxyxIntInt

∫ ∫

==>
6.2

2

4.4

4

1

);6.2..2),4.4..4),*/(1((
 

70250059852.
(%);value>

 

Funksiyanın sıraya ayrılması 
Funksiyanı qüvvət sırasına ayırmaq üçün series(f,eqn,n) 

əmrindən, Teylor sırasına ayırmaq üçün isə taylor(f,eqn,n) 
əmrindən istifadə olunur: burada eqn- dəyişən və ya f  
funksiyasının hansı nöqtə ətrafında sıraya ayrıldığını bildirən 
bərabərlikdir, n isə həddlərin sayını təyin edir. n aşkar şəkildə 
verilmədikdə paket avtomatik olaraq n=6 qəbul edir. Məsələn, 

)(
120
1

6
1

);0),(sinh(

653 xOxxx

xxseries

+++

=>
 

Çoxdəyişənli funksiyanı Teylor sırasına ayırmaq üçün  
mtaylor(f,eqn,n) əmri nəzərdə tutulmuşdur. Burada eqn-
dəyişənlərin və ya bərabərliklərin siyahısı, n hədlərinin sayıdır. 
Məsələn,  

yxxyyxyxyy

yxyxmtaylor

3323

6
1

6
1

2
1

6
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);5],,[),sin(*)(exp(

−++−−

−>
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Bərabərsizlik və tənliklərin həlli 

Bərabərsizlik və tənliklərin, bərabərsizlik və tənliklər 
sisteminin analitik həlli üçün müvafiq olaraq, solve (eqn, var) 
və ya solve ({eqn_1, eqn_2, …,eqn_n},{ var_1, var_2, … , 
var_n }) əmrlərindən istifadə olunur. Burada eqn, eqn_1, 
eqn_2, …,eqn_n tənlik və ya bərabərsizlik, var, var_1, var_2, 
… , var_n isə axtarılan məchullardır. 
Məsələn, 
> solve({a*x-y=1,5*x+a*y=1},{x,y}); 

{ 22 5
5,

5
1

a
ay

a
ax

+
−

=
+
+

=  } 

 
> solve(1-1/2*ln(x)>2,{x}); 

},0{ )2(−<< exx  

> solve({x+y>=2,x-2*y<=1,x-y>=0,x-2*y>=1},{x,y}); 

}
3
1,21{ yyx ≤+=  

Qeyd edək ki,  triqonometrik tənliklər periodik  kökə malik 
olduğundan, tənliyin bütün köklərini tapmaq üçün ilk öncə 
_EnvAllSolutions:=true yazılışından istifadə etmək, sonra  
solve funksiyasını tətbiq etmək lazımdır.  Məsələn, 
>solve(sin(x)=1,x); 

                        π
2
1  

>_EnvAllSolutions:=true:solve(sin(x)=1,x); 

                                    _Z42
2
1

π+π  

Qeyri-xətti tənliyin və tənliklər sisteminin ədədi üsulla həlli 
üçün fsolve (eqn, var, options) əmrindən istifadə oluna bilər. 
Burada options parametri aşağıdakı qiymətləri ala bilər: 
• complex –parametri tənliyin və ya tənliklər sisteminin kökünü 

kompleks formada təyin edir;   
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• maxsols=n–parametri tənliyin və ya tənliklər sisteminin 
yalnız n sayda kökünü təyin edir; 

• interval-parametri tənliyin və ya tənliklər sisteminin kökünü 
a. .b ,  x=a. .b, və ya {x=a. .b, y=c. .d, ...} şəkildə verilmiş 
intervalda təyin edir. 

Məsələn, 
> x:=fsolve(cos(x)=x,x); 

x:=.7390851332 
>p := 3*x^4 - 16*x^3 - 3*x^2 + 13*x + 16:   
  fsolve(p,x,complex); 
  -0.6623589786 -0.5622795121 I, -0.6623589786 +0.5622795121 I, 
  1/324717957, 
   5.333333333 
>fsolve(x^5+4*x+8,x,complex,maxsols=2); 
                   -1.246794105, -0.6806361157-1.332546768 I 
>f := sin(x+y) - exp(x)*y = 0:g := x^2 - y - 2: 
  fsolve({f,g},{x,y},{x=-1..1,y=-2..0}); 

{x=-.6687012050, y=-1.552838698} 

Funksiyanın tədqiqi 
 Riyaziyyatda funksiyanın tədqiqi çox istifadə olunan 
əməliyyatlardan biridir. Bu əməliyyatlar Maple 9.01 riyazi 
proqram paketində aşağıdakı əmrlər vasitəsilə yerinə yetirilir: 
• Extrema (eq, constrs, x,’s’). Əmr analitik verilmiş 

funksiyanın ekstermumunu tapır, burada eq-funksiya, 
constrs-məhdudiyyət şərti, s-ekstermum nöqtəsinin 
mənimsədildiyi dəyişən, x- funksiyanın arqumentidir. 
Məsələn, 

> extrema( a*x^2+b*x+c,{},x,’s’ ); 
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Minimize (eq, opt), Maximize(eq, opt). Əmrlər müvafiq 
olaraq funksiyanın minimum və maksimum qiymətini tapır. 
Opt -parametri olaraq funksiyanın   minimum və ya maksimum 
qiymətinin axtarıldığı oblast müəyyən olunur. Həmçinin, əlavə 
olaraq  location parametrindən istifadə etmək olar. Bu parametr 
minimum və ya maksimum nöqtələrində funksiyanın 
qiymətlərinin  tapılmasını da təmin edir. Məsələn, 

> minimize(x^2-3*x+y^2+3*y+3, x=2..4, y=-4..-2, location); 
-1,{[{y=-2, x=2},-1]} 

>  maximize(sin(x),x=0..Pi/6); 

2
1  

• iscont (f, x=a…b,options). Əmr verilmiş intervalda və ya 
parçada  f(x) funksiyasının kəsilməzliyini yoxlayır. Options  
olaraq closed yazıldıqda  kəsilməzlik şərti verilmiş parçada, 
options  olaraq open  yazıldıqda isə verilmiş intervalda 
yoxlanılır. Nəticə false və ya true olur. Məsələn,   

   > iscont( 1/x, x=0..1 ); 

true 

   > iscont( 1/x, x=0..1, 'closed' ); 

false 
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• discont (f, x). Əmr f(x) funksiyasının kəsilmə nöqtəsini təyin 
edir. Məsələn, 

    >discont(1/(sin(x)-1/2),x); 

                        
⎭
⎬
⎫

⎩
⎨
⎧ π+π+π 3_2_

3
2

6
1 ZBI  

• singular (f,x). Əmr f(x) funksiyasının sinqulyar nöqtələrini 
təyin edir. Məsələn, 

   > singular(ln(x)/(x^2-1)); 
 {x=0},{x=1},{x=-1} 
• asympt (f, x, n). Əmr funksiyanın asimptotik ayrılışını təyin 

edir. Burada n- ayrılışın tərtibini bildirir və aşkar 
verilmədikdə paket n=6 qəbul edir. Məsələn, 

> asympt(x/(1-x-x^2),x); 

⎟
⎠
⎞

⎜
⎝
⎛+−+−+− 65432 x

1O
x
5

x
3

x
2

x
1

x
1  

Çoxhədlilər üzərində əməliyyatlar 

Riyaziyyatda bir sıra məsələlər coxhədlillər üzərində 
əməliyyatların yerinə yetirilməsinə gətirilir. Bu səbəbdən də, 
Maple 9.01  paketində də bir sıra əmrlər çoxhədlilər üzərində 
əməliyyatların yerinə yetirilməsinə xidmət edir. Bu əmrlərdən 
bir qismi ilə tanış olaq:  

• coeffs(p). Əmr p-çoxhədlisinin  əmsallarını təyin edir. 
Məsələn,  

            > p:= 2*x^2 + 3*x^3 – 5+y: coeffs(p); 
           -5,2,3,1       

• coeffs(p,x). Əmr çoxdəyişənli p-çoxhədlisinin x 
dəyişəninə görə  əmsallarını təyin edir. Məsələn,  

            > p:= 2*x^2 + 3*x^3 – 5+y: coeffs(p,x); 
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           -5+y,2,3       

• coeff(p,x^n). Əmr p-çoxhədlisinin nx∧  dəyişənli 
həddinin əmsalını təyin edir. Məsələn,  

            > p:= 2*x^2 + 3*y^3 - 5: coeff(p,x^2); 
                  2 

• lcoeff(p); tcoeff(p). Əmrlər müvafiq olaraq p- 
çoxhədlisinin ən kiçik və ən böyük tərtibli həddinin 
əmsalını təyin edir. Məsələn, 

            >p:= 2*x^2 + 3*x^3 - 5+y:lcoeff(p); tcoeff(p); 
                                         1 
                         -5 
• degree (f, x), idegree (f, x). Əmrlər müvafiq olaraq f(x) 

çoxhədlisinin ən böyük və ən kiçik tərtibini təyin edir. 
             >p:= 2*x^2 + 3*x^3 - 5+y:degree(p,x); ldegree(p,x); 

3 
0 

• evala (AFactor (p)), evala (AFactors (p)). Əmrlər 
müvafiq olaraq birdəyişənli və çoxdəyişənli p-çoxhədlisini 
vuruqlara ayırır. Məsələn, 

      > p:= 2*x^2 +4*x-6 :evala (AFactor(p)); 
2(x+3)(x-1) 

• roots (p, x). Əmr çoxhədlinin kökünü tapır. Məsələn, 
       >p:= 2*x^2 +4*x-6 :roots (p, x); 

                                 [[1,1],[-3,1]] 
• psqrt(p). Əmr p-çoxhədlisinin kvadrat kökünü  tapır. 
Məsələn, 
>psqrt(x^2+2*x*y+y^2);  
               x+y 
• proot (p,n). Əmr p-çoxhədlisinin n tərtibdən kökünü 
tapır. Məsələn, 
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>proot(x^3+3*x^2+3*x+1, 3); 
            x+1 
• realroot (p). Əmr p-çoxhədlisinin həqiqi kökünün 
yerləşdiyi intervalı təyin edir. Məsələn, 

>realroot(x^8+5*x^7-4*x^6-20*x^5+4*x^4+20*x^3, 1/1000);   

[ ] [ ]⎥⎦
⎤

⎢⎣

⎡ −⎥⎦
⎤

⎢⎣
⎡−

⎥⎦
⎤

⎢⎣
⎡ 5,5,

1024
1449,

1024
1449,

128
181,0,0  

• discrim (p, x). Əmr çoxhədlinin diskriminantını təyin 
edir. Məsələn, 

      > p:= a*x^2 + b*x + c: discrim(p,x); 
24 bac+−  

Funksiyanın interpolyasiyası 

Bir sıra funksiyaların, o cümlədən xüsusi funksiyaların 
hesablanması böyük vaxt tələb etdiyindən onların cədvəl 
qiymətlərindən istifadə olunur. Arqumentin hesablama 
intervalına daxil olan hər hansi bir aralıq qiymətində cədvəl 
şəklində verilmiş funksiyanın qiymətinin hesablanmasına 
interpolyasiya deyilir. Cədvəl qiymətləri əsasında məlum 
üsullarla funksiyanın interpolyasiya çoxhədlisi və splayn 
funksiyası qurulur. Funksiyanın çoxhədli ilə interpolyasiyası 
üçün Maple 9.01  paketində interp(X,Y,var), splayn funksiya 
ilə interpolyasiyası üçün spline (X,Y,var,d) əmrləri nəzərdə 
tutulmuşdur1. Burada X və Y eyniölçülü ədədi vektor və ya 
siyahı, var-çoxhədlinin və ya splayn funksiyanın arqumenti, d- 
isə splayn tipini müəyyən edən parametrdir və linear-(xətti), 
guadrati(iki tərtibli), cubic(üç tərtibli), guarrtic(dörd tərtibli) 
qiymətləri ala bilir. Məsələn, 
> Interp([2,5,6], [9,8,3], x) mod 11; 
                                                 
1 Чохщядлинин тяртиби йцксяк олдугда апроксимасийа дягиглийи азалыр. Буна 
эюря сплайн-интерполйасийасындан истифадя етмяк мяслящятдир. 
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968 2 ++ xx  

>spline([0,1,2,3],[0,1,4,3],x,linear); 

⎪
⎩

⎪
⎨

⎧

−
<+−
<

otherwisx6
2xx32
1xx

 

 
 

2.1.4. İfadələr üzərində analitik çevrilmələr 
 

Maple 9.01-də  ifadələr üzərində bir sıra analitik 
əməliyyat və çevrilmələr aparmaq olar. Bu əməliyyatlar 
aşağıdakı əmrlər vasitəsilə təmin olunur; 

• lhs(eqn) əmri eqn ifadəsinin sol hissəsini müəyyən 
edir. Məsələn, 

c-x47
y);*2-45x*45c-x*lhs(2 =+>

 

• rhs(eqn) əmri eqn ifadəsinin sağ hissəsini müəyyən 
edir. Məsələn, 

2y-45
y);*2-45x*45c-x*rhs(2 =+>

 

• normal(eqn) əmri eqn ifadəsini sadələşdirərək 
nəticəni kəsr formasında əks etdirir. Məsələn, 

a5
9xa+ca-5c+47x-

x/5);*45c-a)-x/(5*normal(2 

−

+>
 

• numer(eqn) əmri eqn kəsrinin surətini müəyyən edir. 
Məsələn, 

 
9xa+ca-5c+47x

x/5);*45c-x/5*numer(2 +>
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• denom(eqn) əmri eqn kəsrinin məxrəcini müəyyən 
edir. Məsələn, 

a+−
+>

5
x/5);*45c-a)-x/(5*denom(2 

 

• convert(eqn, form, op) əmri eqn ifadəsinin və ya 
ədədin digər yazılış formasını müəyyən edir. Form 
parametri eqn ifadəsinin digər yazılış formasını 
müəyyən edir və ədədlər üçün say sistemlərinə uyğun 
binary, decimal, Hex, octa1 qiymətlərini, ifadələr 
üçün isə exp, fraction, ln, factorial, float, polynom və 
s.  qiymətlər ala bilir. Məsələn, 

      
111101

binary);3,convert(12 >
 

      
x

x

e
e

2
1

2
1

exp);(sinh(x), convert 

−

>
 

• combine(f, n) əmri f ifadəsinin çevrilməsini təmin 
edir. n – aşağıdakı cədvəldə verilmiş qiymətlərdən 
birini alır:  

@@  Abs  Arctan  conjugate  exp  

In  Piecewise  polylog  power  product  

Ps  radical  range  signum  trig  

Məsələn, 

 )x6(e
exp);x)^3,*(exp(2 combine >

 

 
)x2sin(

2
1

cos(x));*(sin(x) combine >
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• radnormal(eqn) əmri müxtəlif tərtibdən kökləri 
sadələşdirir. Məsələn, 

  ( )( )

21

257:a

a);radnormal((1/3);sqrt(2))^*5(7 : a 
3/1

+

+=

+=>

 

• simplify(eqn) əmri eqn ifadəsinin sadələşdirilməsini 
təmin edir. Məsələn, 

  ( )cabe
exp(c))));*ln(b(exp(asimplify  

+

+>
 

• expand(eqn) əmri eqn ifadəsinin genişləndirilməsini 
təmin edir. Məsələn, 

sin(y) cos(x) + cos(y) sin(x)  
y));(xexpand(sin +>

, 

be
ln(b)));(aexpand(exp 

a

+>
 

• ifactor(eqn, metod) əmri tam və rasional ədədlərin 
sadə ədədlərin hasili kimi təyin edir. Məsələn, 

( ) ( )( )532

);60ifactor( 
2

>
 

( )
( )11
2

);
11
 4 ifactor(  

2

>
 

• factor(eqn,k) əmri eqn ifadəsini vuruqlara ayırır. 
Burada k məcburi parametr olmayıb, verildikdə 
ifadənin vuruqlarında iştirak etməlidir. Məsələn, 
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( )( )22

22

y^4));-y^3)/(x^4-3factor((x^ >  

yxxy
yxyx

++
++  

• collect(eqn, x) əmri eqn ifadəsini x- dəyişəninə görə 
qruplaşdırır. Məsələn, 

>p:= (x-1)^2-5+(x-1)^2; collect(p,x); 

                             
хх

xp
423

5)1(2:
2

2

−+−

−−=  

• frac(eqn) əmri ədədin və ya ifadənin ədədi  
nəticəsinin kəsr hissəsini təyin edir. Məsələn, 

3
2

frac(8/3); >
 

• trunc(eqn) əmri ədədin və ya ifadənin ədədi nəticəsinin 
tam hissəsini təyin edir. Məsələn, 

2
(8/3); trunc >

 

• round(eqn) əmri ədədin və ya ifadənin ədədi nəticəsini 
yuvarlaqlaşdırır. Məsələn, 

3
(8/3); trunc >

 

• Re(z), Im(z) əmri kompleks z ədədinin və ya kompleks  
nəticənin həqiqi və xəyali hissəsini təyin edir. Məsələn, 

)4cos()3cosh(
I));*4Re(cosh(3 +>

 

)1sin(
;Im(exp(I)) >

 

• conjugate(z) əmri kompleks z ədədinin qoşmasını təyin 
edir. Məsələn, 
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5I3
I);*53conjugate( 

−
+>

 

• polar(z) əmri kompleks z ədədinin modul və 
arqumentini təyin edir. Bunun üçün ilk öncə readlib 
(polar) əmrini yerinə yetirmək lazımdır.  

• subs(x=a,e) əmri e ifadəsində x- dəyişənini a - ifadəsilə 
əvəz olunmasını təmin edir. Məsələn, 

y1
y

); sin(x))-t(1sin(x)/sqr y,sin(x) subs( 

−

=>
 

• sort(L) əmri siyahıda və ifadədə nizamlama aparır. 
Məsələn, 

[1,23]
1]);sort([3,2, >

 

1xx
x^2);xsort(1 

2 ++

++>
 

 
2.1.5. Xətti  cəbr məsələlərinin həlli 

 
Maple 9.01 paketi vasitəsilə xətti cəbrin məsələlərini 

həll etmək üçün ilk öncə with(linalg) əmrini yerinə yetirməklə 
linalg paketini yükləmək lazımdır. Linalg paketinin çoxsaylı 
əmr və funksiyaları vektor və matrislər üzərində əməliyyatların 
yerinə yetirilməsini, xətti tənliklər sisteminin analitik və ədədi 
həll edilməsini və s. təmin edir.  

İki vektorun məsələn, a və b vektorlarının toplanması üçün 
paketin aşağıdakı əmrlərindən birini istifadə etmək olar:  

1) evalm(a+b); 
2) matadd(a,b). 
Məsələn, 
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34]) 10,- vector([0,:=  c                           
b);evalm(a:c

:,-12,31])vector([-1:b:2,3])vector([1,:a
+=

==>
 

34]) 10,- vector([0,:=  c                           
b);,matadd(a:c

:,-12,31])vector([-1:b:2,3])vector([1,:a
=

==>
 

İki a və b vektorlarının  xətti kombinasiyasını ( ba β+α , harada, 
βα, skalyar ədədlərdir) hesablamaq üçün isə matadd 

(a,b,alpha,beta) əmrini yerinə yetirmək lazımdır.  
İki a və b vektorlarının skalyar hasili  dotprod(a,b) əmrini  

yerinə yetirməklə hesablanır. Məsələn, 

68:=  c                          
b);,dotprod(a:c

:,-12,31])vector([-1:b:2,3])vector([1,:a
=>

==>
 

İki vektor arasında bucağı təyin etmək üçün angle(a,b)  
əmrini, a və b vektorlarının vektorial hasilini- ]b,a[  hesablamaq 
üçün isə crossprod (a,b) əmrini yerinə yetirmək lazımdır. 

 Məsələn, 

π=φ

===>

2
1:

b);angle(a,:phi:])([1,2,-2,1:b:)([2,1,3,2]:a
 

10] 10,- [-15,:=  c
b);a,crossprod(:c :([2,3,6]):b:([2,-2,1]):a ===>

 

)x,...,x( n1=a vektorunun norması və ya uzunluğu 
2
n

2
1 x...x ++=a düsturuna əsasən, norm(a,2) əmri 

vasitəsilə hesablanır. Məsələn, 

303:

norm(b,2):c :)([1,13,10]:b  

=

==>

c
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Əgər n vektordan ibarət sistem verilibsə - },...,,{ n21 aaa , 
basis ([a1,a2,…,an]) əmrini yerinə yetirməklə bu sistemin 
bazisini hesablamaq, GramSchmidt([a1,a2,…,an]) əmrini 
yerinə yetirməklə isə Qramm-Şmidt alqoritmi əsasında xətti-
asılı olmayan },...,,{ n21 aaa vektorlarını ortoqonallaşdırmaq 
olar. Məsələn, 

a5] a3, a2, [a1,:=  g                      
a5]);a4,a3,a2,basis([a1,:g
:1,12,-10])vector([2,:a5
 :1,7,-4])vector([0,:a4 

:2,8,7])vector([3,:a3
 :1,-5,3])vector([1,:a2
 :2,2,-1])vector([1,:a1

=>
=>
=>

=>
=>
=>

 

[ ] ⎥⎦

⎤
⎢⎣

⎡
⎥⎦
⎤

⎢⎣
⎡ −−−

⎥⎦
⎤

⎢⎣
⎡ −

>

724
355,

724
71,

724
923,

724
1633,

65
549,

65
327,

65
93,

65
81,1,2,2,-1

t(g);GramSchmid

 
§ 2.1.1-də verilmiş matrisi təyinetmə üsullarından əlavə, 

Linalg paketinin müvafiq funksiyaları  vasitəsilə xüsusi tip 
matrislər də  tərtib etmək olar. Məsələn,  diaqonal kvadrat 
matrisi təyin etmək üçün  diag(a11,a22,…,ann) funksiyası 
nəzərdə tutulmuşdur. Məsələn, 

 

⎥
⎥
⎥

⎦

⎤

⎢
⎢
⎢

⎣

⎡
=

300
020
001

:J               

);diag(1,2,3:=J>

 

Matrisi həmçinin, f(i, j) funksiyası vasitəsilə də tərtib 
etmək olar. Bunun üçün matrix(n, m, f) əmrini yerinə yetirmək 
lazımdır. Məsələn, 

> f:=(i, j)->x^i*y^j;   
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ji yx)j,i(:f →=  
> A:=matrix(2,3,f); 

⎥
⎦

⎤
⎢
⎣

⎡
= 32222

32

yxyxyx
xyxyxy

:A  

İxtiyari A matrisinin sətrlərinin sayı rowdim(A), 
sütunlarının sayı isə coldim(A) funksiyaları vasitəsilə təyin 
olunur. Məsələn, 

2
3

rowdim(A);coldim(A),
:,8])[1,2,5,6,7,matrix(2,3 :A =>

 

İki və ikidən artıq eyniölçülü matrisin cəmi evalm(A+B) 
və ya  matadd (A,B) əmrini, hasili isə evalm(A&*B) və ya 
multiply (A,B)  əmrini yerinə yetirməklə hesablanır. Məsələn, 

⎥
⎦

⎤
⎢
⎣

⎡
=

+=
==>

37
14-

:

B);evalm(A:C
:[7,4]]) 5,1],matrix([[-:B:[0,-1]]),0],matrix([[1:A

C

 

⎥
⎦

⎤
⎢
⎣

⎡
=

=
==>

37
14-

:C

; B)(A, matadd:C
:[7,4]]) 5,1],matrix([[-:B:[0,-1]]),0],matrix([[1:A
 

⎥
⎦

⎤
⎢
⎣

⎡
=

=

>
>

2316
96

:D    

C); B, ,multiply(A:D >
:) [4,5]][[1,2], matrix(:=  C >
:) [1,0]][[0,1], matrix(:=  B
:) [3,4]][[1,2], matrix(:= A  
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⎥
⎦

⎤
⎢
⎣

⎡
=

=
>
>

34
12

:D    

*B);&evalm(A:D 
:) [1,0]][[0,1], matrix(:=  B
:)[3,4]][[1,2],matrix(:= A 

 

Evalm  əmrindən həmçinin matrislə skalyar ədədin cəminin və 
matrisin skalyar ədədə hasilinin hesablanması üçün də istifadə 
oluna bilər. Məsələn, 

⎥
⎦

⎤
⎢
⎣

⎡

>

149
65

A);*3+evalm(2:)[3,4]][[1,2],matrix(:= A 
 

Matrisin determenantını və minorunu hesablamaq üçün 
paketdə det(A) və minor(A,i,j) əmrləri nəzərdə tutulmuşdur. A 
matrisinin ranqı rank(A), matrisin izi isə  trace(A) əmri 
vasitəsilə hesablanır. Məsələn, 

21a12a22a*11a:c
det(A);:=c:)a22]][a21,a12],[[a11,matrix(:= A 

−−=
>

 

⎥
⎦

⎤
⎢
⎣

⎡
=

==>

54
21

:c

2);minor(A,2,:S:,7,4,8,5])[1,5,2,6,3,matrix(3,3:A 

 

⎢
⎣

⎡
=

>
2:c

rank(A);:=c:) [21,22]][[11,12], matrix(:= A 
 

iea
trace(A);:i])h,g,f,e,d,c,b,[a,,matrix(3,3:A 

++
=>

  

A matrisinin tərs matrisi  evalm(1/A) və ya  inverse(A) 
funksiyaları vasitəsilə hesablana bilər. Matrisin transponirə 
olunmuş matrisinin tapılması isə transpose(A) funksiyası ilə 
yerinə yetirilə bilər. Məsələn, 
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;evalm(1/A);inverse(A)
:[3,0,4]])[0,1,-6],,0,5],matrix([[4:A =>
 

⎥
⎥
⎥

⎦

⎤

⎢
⎢
⎢

⎣

⎡

− 465
010
304

 

⎥
⎥
⎥

⎦

⎤

⎢
⎢
⎢

⎣

⎡

−
−

−

403
24118

504
 

⎥
⎥
⎥

⎦

⎤

⎢
⎢
⎢

⎣

⎡

−

=>

465
010
304

A);transpose(
:[3,0,4]])[0,1,-6],,0,5],matrix([[4:A
  

 
A matrisi üçün A>0, 0≥A , A<0, 0≤A  şərtlərinin 
yoxlanılması Linarg paketinin müvafiq olaraq aşağıdakı əmrləri 
vasitəsilə yerinə yetirilir: 

• definite(A,'positive_def'); 
• definite (A, 'positive_ semidef'); 
• definite(A,'negative_def'); 
• definite(A, 'negative_semidef') 

 Orthog(A) funksiyası isə matrisin ortqonallığını öyrənmək 
üçün istifadə olunur. Matris yoxlanılan şərti ödədikdə nəticə 
true, əks halda isə false qiyməti alır. Məsələn, 

false     
);ef'positive_d',definite(A:[3,0,4]])[0,1,-6],,0,5],matrix([[4:A =>

 

Fərdi kompüterlərin proqram təminatı 

 

133 

ruet     
orthog(A)-1/2]]);sqrt(3)/2,*[1,sqrt(3)/2]*/2,1matrix([[1:A =>

Matrisi n tərtibdən qüvvətə yüksəltmək üçün evalm(A^n), 
matris eksponentini hesablamaq üçün isə exponential(A)  
funksiyasından istifadə olunur. Məsələn, 

;evalm(A^2) :[3,0,4]])[0,1,6],4,0,15],matrix([[-:=A >  

⎥
⎥
⎥

⎦

⎤

⎢
⎢
⎢

⎣

⎡

6100
30118
0061

 

; (A) lexponentia  :x]])[0,0,x,0],[0,0,0],matrix([x,:=A >  

⎥
⎥
⎥

⎦

⎤

⎢
⎢
⎢

⎣

⎡

x

x

x

e00
0e0
00e

 

Xətti cəbr kursundan məlumdur ki, Ax=λx, bərabərliyi 
ödənərsə,  x  vektoru A matrisinin məxsusi vektoru, λ ədədi isə 
məxsusi ədədi adlanır. Maple-də matrisin məxsusi ədədinin 
tapılması üçün  eigenvalues(A), məxsusi vektorunun tapılması 
üçün isə eigenvectors(A) funksiyalarından istifadə olunur. 
Məsələn, 

3 2, 6,
]{[1,-2,1]}[6,1, ,{[1,1,1]}][3,1, ],{[-1,0,1]}[2,1,                  

s(A);eigenvalue
(A); rseigenvecto:[1,-1,3]])[-1,5,-1],,-1,1],matrix([[3:A =>

A matrisinin xarakteristik çoxhədlisi- )det()( AEPA −λ=λ  
charpoly(A,lambda), A matrisinin minimal çoxhədlisi isə  
minpoly(A,lambda) funksiyaları vasitəsilə hesablanır. 
Xarakteristik matris charmat( A,lambda) funksiyası vasitəsilə 
hesablanır.  Məsələn, 



Fəsil 2 Riyazi proqram paketləri 

 

134

323210:)(
lambda);minpoly(A,:d(lambda)
lambda);,charpoly(A:=P(lambda)

:[0,0,4]])[I,3,0],,-I,0],matrix([[3:=A >

23 −λ+λ−λ=λ

=

P

 

268:)(d λλλ +−=  

A matrisini normal Jordan formasına gətirilməsi 
jordan(A), üçbucaq matrisə gətirilməsi isə gausselim(A), 
ffgausselim(A), gaussjord(A) funksiyaları vasitəsilə həyata 
keçirilir. Gausselim(A) funksiyası Qauss üsuluna, 
ffgausselim(A) funksiyası bölmədən Qauss üsuluna, 
gaussjord(A) funksiyası isə Qauss-Jordan üsuluna əsaslanır. 
Məsələn, 

⎥
⎥
⎥

⎦

⎤

⎢
⎢
⎢

⎣

⎡

400
040
002

jordan(A);
:[0,0,4]])[I,3,0],,-I,0],matrix([[3:=A >
 

⎥
⎥
⎥
⎥

⎦

⎤

⎢
⎢
⎢
⎢

⎣

⎡

−
−

=

5
300
850
431

:

A);gausselim(
:[0,0,4]])[I,3,0],,-I,0],matrix([[3:=A >

g
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⎥
⎥
⎥

⎦

⎤

⎢
⎢
⎢

⎣

⎡

−−
−+−
−−

=

=

776
874
431

:)A(F

lambda);charmat(A,:F(A)
:[0,0,4]])[I,3,0],,-I,0],matrix([[3:=A >

λ
λ

λ
  

Xətti tənliklər sisteminin həlli üçün Maple 9.01  proqram 
paketində bir neçə funksiya  nəzərdə tutulmuşdur. Əgər sistem 
matris şəklində - bx =A  verilmişsə, onun həlli üçün linalg 
paketinin linsolve(A,b)funksiyasını tətbiq etmək lazımdır. 
Məsələn,  

3]- [7, : x
b); ,linsolve(A: x

:[1,-2]) vector( : b 
:)[1,3]][[1,2],matrix(:A  

=
=
=

=>

 

Matris şəklində bircins xətti tənliklər sisteminin- 0A =x  
həlli üçün A matrisinin nüvəsini təyin edən kernel(A) 
funksiyasından da istifadə etmək olar. Məsələn,  

2])} 1, {([-1,:=  x
kernel(A):x:[1,3,-1]])[0,2,-1],,1,0],matrix([[1:A ==>

 

Həmçinin bx =A  sistemini leastsqrs(A,b,'optimize'), 
funksiyası vasitəsilə  də həll etmək olar. Bu funksiya sistemin  
ən kiçik kvadratlar üsulu ilə təqribi həllinin tapılmasını təmin 
edir.  Məsələn, 

⎥⎦
⎤

⎢⎣
⎡ −−

=

>

21
10,

14
3,

42
67:x

);optimize''b,A,leastsqrs(:=  x
:2,4])vector([1,:=  b  

:[2,0,-1]])[1,1,-2],-1,1],array([[1,:= A   

 

Xətti tənliklər sistemi aşkar şəkildə təyin edildikdə digər 
funksiyadan, standart solve({eq1,eq2,..,eqn},{x1,x2,…,xn}) 
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funksiyasından istifadə olunur. Burada eq1,eq2,..,eqn sistemə 
daxil olan tənliklər, x1,x2,…,xn isə axtarılan məchullardır. 

Məsələn, 
⎪
⎩

⎪
⎨

⎧

=−−−
=++−
=++−

1t15z11y3x2
2t3z2y6x4
1t7z5y3x2

 sisteminin həll alqoritmi 

aşağıdakı şəkildə olacaqdır: 

⎭
⎬
⎫

⎩
⎨
⎧ =−=+−=

= 
==++

=++=>

yytztyx ,
8
11,

2
1

16
1

2
3

z});y,{x,solve(eq,:s
:1}t*15-z*11-y*3-x*2  2,t*3z*2y*6-x*4 

 1,t*7z*5y*3-x*{2:eq 

 
 
 

2.1.6. Qrafiklərin və animasiyaların qurulması 
 

Birdəyişənli f(x) funksiyasının qrafikinin qurulması üçün 
plot (f(x), x, interval, options) əmrini yerinə yetirmək 
lazımdır. Burada, options qrafikin təsvirini tənzimləyən 
parametrlər siyahısı, x axtarılan funksiyanın arqumenti, 
interval–funksiyanın arqumentinin dəyişmə intervalını bildirən 
parametrdir. İnterval ümumi şəkildə maxmin ..xxx =  kimi təyin 
olunur. Options parametri aşağıdakı qiymətləri ala bilər: 
1) title parametri qrafikin sərlövhəsini təyin edir. Məsələn, title 
=”Təzyiqin zamandan asılılıq qrafiki”. Əgər qrafikin 
sərlövhəsi latın əlifbası ilə verilmişsə, onda ” işarəsinin 
qoyulmasına ehtiyac olmur.   
2) coords parametri müvafiq koordinat sisteminin müəyyən 
olunmasını təmin edir. Bu parametr vasitəsilə birdəyişənli 
funksiyanın qrafikinin 15 tip müxtəlif koordinat sistemində 
qurmaq olar. Coords parametri təyin olunmadıqda avtomatik 
olaraq proqramda Dekart koordinat sistemi müəyyən olunur 
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(coords=Cartesian). Məsələn, qrafikin polyar koordinat 
sistemində qurulması üçün coords=polar parametrini müəyyən 
etmək lazımdır. 
3) axes parametri koordinat müstəvisinin görünüşünü müəyyən 
edir. Aşağıdakı yazılış formaları istifadə oluna bilər: 
axes=frame, axes=boxed axes=none, axes=normal. Məsələn, 
> plot (sin(x),x,axes=frame); plot (sin(x),x,axes=boxed); plot 
(sin(x),x,axes=normal); 

  

 
4) style parametri qrafikin xətti və ya nöqtəvi olmasını təmin 
edir. Qrafikin xətti olması üçün style=line, nöqtəvi olması üçün 
isə style=point yazılışından istifadə olunur. Avtomatik olaraq, 
style=line qəbul edilir. 
5) numpoints=n parametri qrafiki qurulan funksiyanın 
arqumenti üçün bölgü nöqtələrinin sayını təyin edir. Avtomatik 
olaraq, n=49 qəbul edilir. 
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6) color  parametri qrafik üçün rəng müəyyən edir. Rəng ingilis 
sözləri ilə ifadə olunur. Məsələn, qrafikin əyrisi üçün sarı rəng 
müəyyən etmək tələb olunarsa, color =yellow yazılışından 
istifadə etmək lazımdır. Məsələn, 
>plot([sin(2*t),cos(3*t),t=0..2*Pi], axes=boxed, color=blue ); 

 
 
7) xtickmarks və ytickmarks parametrləri koordinat oxları 
üzərində bölgü nişanlarının minimal sayını müəyyən edir. 
8) thickness parametri əyrinin qalınlığını təyin edir. Bu 
parametr təyin edilmədikdə proqram avtomatik olaraq 
thickness=0  qəbul edir. Məsələn, 
>plot(1+cos(x),x=0..2*Pi, title="Cardioida", coords=polar, 
color=coral, thickness=2); 
9) linestyle parametri qrafiki əyrinin tipini təyin edir. Belə ki, 
linestyle=1 olduqda əyri kəsilməz, linestyle=2 olduqda nöqtəvi,  
linestyle=3 olduqda qırıq-qırıq olur. 
10) symbol parametri nöqtəvi əyrinin nöqtələrini işarə etmək 
üçün istifadə olunan simvolları təyin edir. symbol=box, 
symbol=cross, symbol=circle, symbol=point, symbol=diamond 
yazılış formalarından istifadə etmək olar. 
11) labels parametri koordinat oxlarının adlarını müəyyən edir. 
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12) scaling parametri qrafikin miqyasını təyin edir. Belə ki, 
scaling=constrained yazılışı koordinat oxlarına görə eyni 
miqyas müəyyən edir, scaling=unconstrained yazılışı isə qrafik 
üçün miqyası pəncərənin ölçülərinə görə  tənzimləyir. Məsələn, 
> plot([ln(3*x-1), 3*x/2-ln(2)], x=0..6, scaling=constrained, 
color=[violet,red], linestyle=[1,2], thickness=[3,2]); 
13) font parametri qrafikin sərlöhvəsi, koordinat oxlarının adı 
üçün şriftin tipini müəyyən edir. Parametr font=[f,style,size] 
formatına malikdir: Burada f- şriftin adını1, style- stilini2, size 
şriftin ölçüsünü bildirir. Məsələn, 
 >plot(sin(x)/x, x=-4*Pi..4*Pi, labels=[x,y], labelfont= 
[times,italic,12],  thickness=2); 
14) discont=true parametri sonsuz kəsilmə nöqtəsinə malik 
qrafiklərin qurulmasını təmin edir. 

),( yxfz =  iki dəyişənli funksiyasının qrafikinin qurulması 
üçün plot3d(f(x,y), x=x1…x2, y=y1…y2, options) əmrini 
yerinə yetirmək olar.  Options parametri  plot  əmrinin 
Options parametri ilə demək olar ki, üst-üstə düşür. Əlavə 
parametrlərdən biri kimi light=[angl1, angl2, r, g, b] 
parametrini qeyd etmək olar. Bu parametr sferik (angl1, angl2) 
koordinatı ilə təyin edilmiş nöqtəvi mənbədən səthin 
işıqlanmasını təmin edir. İşıqlanma qırmızı (r), yaşıl (g) və göy 
rənglərin (b) nisbətilə təyin olunur.  

Parametrik şəkildə verilmiş funksiyanın səth əyrisinin 
qurulması üçün plot3d([x(u,v), y(u,v), z(u,v)], u=u1..u2, 
v=v1..v2) əmri yerinə yetirilməlidir. Məsələn, 
> plot3d({x*sin(2*y)+y*cos(3*x), sqrt(x^2+y^2)-7}, x=-Pi..Pi, 
y=-Pi..Pi, grid=[30,30], axes=framed, color=x+y); 

                                                 
1 Мясялян, TIMES, COURIER, HELVETICA, SYMBOL вя с. 
2 Мясялян, BOLD, ITALIC, UNDERLINE вя с. 
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>plot3d(1/(x^2+y^2)+0.2/((x+1.2)^2+(y-1.5)^2)+ 0.3/((x-

0.9)^2+(y+1.1)^2), x=-2..2, y=-2..2.5, view=[-2..2, -2..2.5, 

0..6], grid=[60,60], shading=NONE, light=[100,30,1,1,1], 

axes=NONE, orientation=[65,20], style=patchcontour); 

 
Qrafiklərin qurulması üçün Plots və Plottols paketlərinin 

əmrlərindən də geniş istifadə olunur. Plots paketi əlliyə yaxın 
əmrlər vasitəsilə Maple 9.01 proqramının iki və üçölçülü 
qrafiklərinin qurulma imkanlarını xeyli genişləndirir. Bu 
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əmrlərin hamısının şərhi bir mövzu çərçivəsində qeyri mümkün 
olduğundan, ən çox istifadə olunan əmrlərin bir qismi ilə tanış 
olaq: 
• Ploarplot(f,x=a..b, options) əmri polyar koordinat 

sistemində funksiyanın qrafikinin qurulmasını təmin edir; 
burada f-funksiya, x=a..b funksiyanın arqumentinin 
dəyişmə intervalını bildirir.  

> with(plots):polarplot([cos(t),sin(t),t=0..4*Pi],color=gold); 
 

• Implicitplot(F(x,y)=0, x=x1..x2, y=y1..y2) əmri qeyri-
aşkar şəkildə ( 0),( =yxF ) verilmiş birdəyişənli funksiyanın 
qrafikinin qurulmasını təmin edir. məsələn, 

> implicitplot({x^2-y^2=1, y=exp(x)}, x=-Pi..Pi, y=-Pi..Pi); 
 

• Implicitplot3d(F(x,y,z)=c, x=x1..x2, y=y1..y2, z=z1..z2) 
əmri qeyri-aşkar şəkildə ( 0)z,y,x(F = ) verilmiş 
ikidəyişənli funksiyanın qrafikinin qurulmasını təmin edir. 
məsələn, 

> implicitplot3d({x^2-y^2+z^2=1, y=exp(-x*z)}, x=-Pi..Pi, y=-
Pi..Pi, z=-1..1); 
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• Contourplot(f,x=a..b,y=c..d,options) əmri kontur 
qrafiklərin qurulmasını təmin edir. Məsələn,  

> contourplot(sin(x*y),x=-3..3,y=-3..3,contours=3); 
• Fieldplot (f, a..b, c..l) əmri birdəyişənli funksiyanın vektor 

sahəsinin qurulmasını təmin edir. 
>fieldplot( [x/(x^2+y^2+4)^(1/2),-y/(x^2+y^2+4)^(1/2)],x=-
2..2,y=-2..2); 
• Fieldplot3d(f, a..b, c..l) əmri 3 ölçülü koordinat sistemində 

vektor sahəsinin qurulmasını təmin edir. 
> fieldplot3d([2*x,2*y,1],x=-1..1,y=-1..1,z=-..1,grid=[5,5,5]); 
• Conformal(F,r1,r2,options) əmri kompleks müstəvidə 

konoformal inikasın qrafikini qurur. Burada, F-kompleks 
dəyişənli funksiya, r1 və  r2 funksiyanın təyin olduğu 
oblastdır.  

> conformal(1/z, z=-1-I..1+I, -6-6*I..6+6*I, color=black); 

 
  
• inequals({f1(x,y)>c1,…,fn(x,y)>cn},x=x1…x2, y=y1..y2, 

options) əmri bərabərsizliklər sistemi ilə verilmiş ikiölçülü 
oblastın təsvirinin qurulmasını təmin edir. Options olaraq 
aşağıdakı təsvir parametrlərindən istifadə etmək olar:  
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 optionsfeasible=(color=”<rəng>”)1; 
 optionsexcluded=(color=”<rəng>”)2;  
 optionsopen(color=<rəng>, thickness=<n>)3 ; 
 optionsclosed(color=<rəng>,thickness=<n>)4 . 

 Məsələn, 
>with(plots): 
> inequal({x+y>0,x-y<=1,y=2},x=-3..3,y=-3..3, 

optionsfeasible=(color=red), 
optionsopen=(color=blue,thickness=2), 
optionsclosed=(color=green, thickness=3), 
optionsexcluded=(color=yellow) ); 

• spacecurve([x(t),y(t),z(t)],t=t1..t2) əmri ),t(xx =  
),t(yy =  )t(zz =  parametrik şəkildə verilmiş fəza 

əyrilərinin qurulmasını təmin edir. Məsələn, 
> with(plots): 
> spacecurve([sin(t),cos(t),exp(t)], t=1..5, color=blue, 
thickness=2, axes=boxed); 

• display([p,t], options) əmri bir koordinat sistemində bir 
neçə qrafiki obyektin əks olunmasını təmin edir. Məsələn, 
aşağıdakı misalda ellips daxilində astroidin çəkilməsini 
təmin edir: 

> with(plots): eq:=x^2/16+y^2/4=1: 
>el:=implicitplot(eq, x=-4..4, y=-2..2, scaling= constrained, 
color=green, thickness=3): 
> as:=plot([4*cos(t)^3,2*sin(t)^3, t=0..2*Pi],  
color=blue, scaling=CONSTRAINED, thickness=2): 
> eq1:=convert(eq,string):  

                                                 
1 Параметр  областын дахили нюгтяляри цчцн рянэи тяйин едир. 
2 Параметр  областын хариъи нюгтяляри цчцн рянэи тяйин едир. 
3 Параметр ачыг сярщяд цчцн рянэ вя сярщяддин галынлыьыны тяйин едир.  
4 Параметр гапалы сярщяд цчцн рянэ вя сярщяддин галынлыьыны тяйи едир. 
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> t1:=textplot([1.5,2.5,eq1], font=[times, 
 italic, 10], align=right): 
> t2:=textplot([0.2,2.5,"Ellips:"], font=[times,  
 bold,10], align=RIGHT): 
> t3:=textplot([1.8,0.4,Astroida], font=[times,  
Bold,10], align=left): 
> display([as,el,t1,t2,t3]);  

Animasiyalar qrafiklərə dinamizm verərək, qrafik 
vasitəsilə təsvir olunan fiziki prosesin vizuallığını təmin edir. 
Bu səbəbdən, animasiyalardan elektron məruzələrin, öyrədici 
sistemlərin hazırlanması zamanı geniş istifadə olunur. Maple 
9.01  paketində ikiölçülü və üçölçülü animasiyaların 
yaradılması üçün animate(f,r) əmri yerinə yetirilməlidir. Sənəd 
pəncərəsində qrafik əks olunduqdan sonra istifadəçi ContextBar 
panelində Play düyməsini sıxmaqla animasiyanın nümayişinə 
nail ola bilər.  

 
 

 
2.1.7. Diferensial tənliklərin həlli 

 
Maple 9.01 paketi diferensial tənlik və tənliklər sistemini 

analitik və ədədi üsulla həll etməyi təmin edir. Adi diferensial 
tənliyin həlli üçün dsolve (ODE, f(x), options), adi differensial 
tənliklər sisteminin həlli üçün dsolve({ODE1, ODE2, …, 
ODEn}, {funcs}, options) funksiyalardan istifadə olunur. 
Burada, ODE, ODE1, ODE2,…,ODEn - diferensial tənliklər, 
f(x)–axtarılan funksiya, {funcs}-axtarılan funksiyalar 
çoxluğudur. Options parametri məsələnin həll formasını 
tənzimləyir. Məsələn, options  parametri olaraq exact 
yazıldıqda diferensial tənlik və ya tənliklər sisteminin həlli 
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analitik formada, formal_series yazıldıqda qüvvət sırası kimi  
əks olunur1. Məsələn, 

 _C1+5x-cos(x)-= x y(x)                               
y(x));sin(x),5x*2-x)f(y(x),dsolve(dif

2
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:y(x)}x)diff(z(x),y(x),z(x)*2-x),{diff(y(x):sysode

)x()x2()x2()x( −− −=+=
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nn

1n
x11- = _C1 y(x)                       

),ies'formal_ser'y(x),,dsolve(ode
 :y(x)-x)diff(y(x),-x)x),y(x),diff(diff(*x)-(1 : ode

 

Misaldan göründüyü kimi, tənliyin və tənliklər sisteminin həlli 
tənliyin və sistemin tərtibi sayda inteqral sabitdən asılı şəkildə 
təyin edilir. İnteqral sabitlər – C1, C2, … ilə işarə olunur. 
Dsolve funksiyası tənliyin və tənliklər sisteminin həllini 
avtomatik olaraq ən əlverişli üsulla tətbiq etməklə tapır. 
İstifadəçi həmçinin üsulun adını əlavə parametr kimi  kvadrat 
mötərizə (“[ ]” ) daxilində aşkar şəkildə müəyyən edə bilər. Bu 
məqsədlə aşağıdakı üsul adından biri seçilə bilər: 
• Quadrature, Linear, Bernoulli, Separable, Inverse_linear, 

Homogenous, Chini, Lin-sum, Abel, pot_sym. 
Qeyd edək ki, dsolve (<ODE>, f(x), options) və ({ODE1, 

ODE2,…,ODEn}, {funcs}, options) funksiyaları vasitəsilə 
həmçinin adi diferensial tənliyin və tənliklər sisteminin 
fundamental həllər sistemini də təyin etmək olar. Bunun üçün 
funksiyanın yazılışında options parametri olaraq output=basis 
yazmaq lazımdır. Məsələn,  

                                                 
1Яэяр options  параметри функсийанын йазылышында ашкар шякилдя 
верилмяйибся  програм тяряфиндян автоматик олараг options  параметри 
олараг Exact гиймяти мцяййян олунур.  
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1] x],*cos(x) x,*sin(x) cos(x), [[sin(x),
basis)outputy(x),dsolve(de,

:01-y(x)x$2)diff(y(x),*2x$4)diff(y(x),:de
=

=++=>
 

Adi diferensial tənlik və tənliklər sistemi  üçün Koşi və ya 
sərhəd məsələsini həll etmək üçün müvafiq olaraq dsolve 
({ODE, cond}, f, options) və dsolve ({sysODE, cond}, 
{funcs}, options) funksiyalarından istifadə olunur. Məsələn,  

⎭
⎬
⎫

⎩
⎨
⎧ −=+=

===
===>

−− )x()x2()x2()x( e
3
2e

3
2)x(y,e

3
1e

3
2z(x)

funcs);ode,dsolve(sys:z(x)}{y(x),:funcs:1}z(0)0,y(0)
y(x),x)diff(z(x),y(x),z(x)*2-x),{diff(y(x):sysode

Praktikada bir sinif Koşi məsələsinin həlli inteqral çevirmələri 
tətbiq etməklə tapılır. Bu məqsədlə options parametri olaraq 
method=<çevirmənin adı> yazılır1. Məsələn,  

( ) ( )t3t2 ee)t(y
laplace)methody(t), 1},D(y)(0) 0,y(0) 1,dsolve({de

:0  y(t)*6  t)diff(y(t),*5  t$2)diff(y(t), : de1 

−− −=

===
=++=>

 

Qeyri-xətti tənliklər üçün Koşi məsələsini analitik həll 
etmək mümkün olmadığından onları yalnız ədədi və asipmtotik 
üsulla həll etmək mümkün olur. Bu məqsədlə options parametri 
olaraq numeric müəyyən edilir. Bu zaman tənlik və ya sistem 
4-5 tərtibli Runqe-Kutta-Felberq üsulu ilə həll olunur. İstifadəçi 
ədədi üsulu özü də təyin edə bilər. Bu məqsədlə əlavə parametr 
olaraq aşağıdakılardan birini istifadə etmək olar: 

Taylorseries-Teylor sırasına ayırma üsulu; 
classical –klassik Runqe-Kutta üsulu; 
gear-təkaddımlı Qrin üsulu; 
mgear-çoxaddımlı Qrin üsulu;     
rkf45 –dörd və beş tərtibli Runqe-Kutta üsulu; 

                                                 
1 Интеграл чевирмяси олараг Лаплас, З, Фурйе вя с. чевирмяляриндян истифадя 
етмяк олар. 
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dverk78-yeddi və səkkiz tərtibli kəsilməz  Runqe-Kutta 
üsulu;         

  isode – sərt tənliklər üçün Livenmorski üsulu. 
Məsələn,  

:numeric)funcs,ode,dsolve(sys:S
:z(x)}{y(x),:funcs:1}z(0)0,y(0)

y(x),x)diff(z(x),y(x),z(x)*2-x),{diff(y(x):sysode

=
===

===>
 

);2(S>  

                             
355261940]18.2895941=  z(x)

 097877647,36.3085177=  y(x) 2.,=  [x
 

:) dverk78methodnumeric,funcs,ode,dsolve(sys:S
:z(x)}{y(x),:funcs:1}z(0)0,y(0)

y(x),x)diff(z(x),y(x),z(x)*2-x),{diff(y(x):sysode

==
===

===>
 

);2(S>  

355261940]18.2895941=  z(x)
 097877647,36.3085177=  y(x) 2.,=  [x

 

Məsələnin həllini qüvvət sırası kimi axtarmaq üçün options 
parametri olaraq series yazılmalıdır. Sıranın tərtibi əvvəlcə 
order dəyişəninə mənimsədilməlidir. Əks halda sıranın tərtibi 
avtomatik olaraq altıya bərabər olur. Məsələn, 

  Series);funcs,ode,dsolve(sys
:z(x)}{y(x),:funcs:1}z(0)0,y(0)

y(x),x)diff(z(x),y(x),z(x)*2-x),{diff(y(x):sysode
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===>
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)x(Ox
6
1x

2
1x1)x(y

series);y(x),cond},,dsolve({de
:10)(D@@2)(y)( 1,D(y)(0) 1,y(0):cond

:sin(x)*x^2)-(2*3x)diff(y(x),-x$3)diff(y(x),:de:4:Order

432 ++++=

====

===>

Diferensial tənliklərin ədədi üsulla həll edilməsi üçün həmçinin 
DETools paketinin əmrlərindən istifadə olunur. Onların bir 
qismi ilə tanış olaq: 

• Autonomus (eg, func, var).  Əmr tənliyin avtonom 
olduğunu yoxlayır. Burada eg-tənlik, func-axtarılan 
funksiya, var - dəyişəndir. Məsələn: 

 true
 t);z,5,-cos(z(t))-t)(D@@4)(z)(*z(t)^2)-in(z(t)automous(s

 :(DEtools) with>

false                             
 s);{x},(DE,autonomous 

 :arctan(s)(x(s)))cos(arctan*x(s)-s)diff(x(s),:DE
:(DEtools) with

==
>

 

• Denormal (eg, func, var). Əmr diferensial tənliyi normal 
formaya gətirir. Burada eg-tənlik, func-axtarılan funksiya, 
var - dəyişəndir. Məsələn, 

( )
x

)xsin()x(y
x

x50)x(y
x

1x)x(xy

));x(y,x,DE(Denormal
sin(x)*xx)(D@@2)(y)(*x^3*50
D(y)(x)*1)-(x*x^2y(x)*x^3:DE

 :(DEtools) with
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• ReduceOrder (eg, func, partsol, solutoform). Əmr 
tənliyin tərtibini bir vahid azaldır. Burada eg-tənlik, func-
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axtarılan funksiya, partsol tənliyin xüsusi həlli, solutoform 
tənliyin həll formasıdır. Məsələn, 

11y(x))x(y
x

6-)x(y
x

sol)y(x),r(de,reduceOrde:exp(x)sol
:y(x)*6

-x)diff(y(x),*11x$2)diff(y(x),*6-x$3)diff(y(x),:de
:ls)with(DEtoo 

2

2

+⎟⎟
⎠

⎞
⎜⎜
⎝

⎛
∂
∂

⎟⎟
⎠

⎞
⎜⎜
⎝

⎛
∂
∂

=

+=

>

 

• DEPlot (eg, func, trange, inits, options). Əmr tənliyin 
ədədi həll edilməsini və həllin qrafikinin qurulmasını təmin 
edir. Burada eg – tənlik və ya tənliklər sistemi, func- 
axtarılan funksiyalar, trange dəyişənin təyin oblastı, inits-
başlanğıc  və ya sərhəd şərtləri, options - qrafikin 
görünüşünü tənzimləyən parametrdir. Avtonom tənlik üçün 
qrafik vektor sahəsi kimi, qeyri-avtonom sistemlər üçün 
əyrilər şəklində qurulur.  Options parametri aşağıdakı 
qiymətləri ala bilər: 
• Arrow=<type> parametri vektor sahəsinin oxlarının 
tipini təyin edir. Type olaraq ‘smal’, medium’, ‘large’, 
‘line’, ‘none’ müəyyən etmək olar. 
• Color= <arrowcoluor>  parametri  oxların rəngini təyin 
edir. 
• parametri şəbəkənin xətlərinin sayını təyin edir. 
• niteration=  parametri iterasiyanın sayını təyin edir. 
• =linecolor <rəng>  parametri  xətlərin rəngini təyin edir. 
• =method <‘üsul’> parametri hesablamanın aparıldığı 
ədədi üsulu təyin edir.  
• TRUEobsrange=<  və ya >FALSE  parametri əgər 
qrafik görünüş oblastından kənara çıxarsa hesablamanın 
dayandırılmasını tənzimləyir. 
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• hStepsize=  parametri hesablama addımını müəyyən 
edir. Avtomatik olaraq 20/)ab((abs − - qəbul edilir. 
Məsələn, 

> with(DEtools): 

DEplot(cos(x)*diff(y(x),x$3)- diff(y(x),x$2)+ 
Pi*diff(y(x),x)=y(x)-x, y(x), x=-2.5..1.4, 

[[y(0)=1, D(y)(0)=2, (D@@2)(y)(0)=1]],y=-4..5, 
stepsize=.05); 

 
• Deplot3d (eg, func, trarge, init, options)1. Əmr tənliyin 

həllini fəza əyriləri kimi qurulmasını təmin edir. Məsələn, 
> DEplot3d({diff(x(t),t)=-sin(t),diff(y(t),t)=cos(t)},{y(t),x(t)}, 
t=-2*Pi..0, [[y(0)=0,x(0)=1]],scene=[t,x(t),y(t)], stepsize=0.1, 
linecolor=cos(t)); 
• Dfieldplot( deqns,  vars,  trange,  xrange,  yrange,  

options)2. Əmr istiqamətlər sahəsinin qurulmasını təmin 
edir. Məsələn, 

 > dfieldplot([diff(x(t),t)=x(t)*(1-y(t)), diff(y(t),t)=.3*y(t)*(x(t)-
1)],[x(t),y(t)],t=-2..2, x=-1..2, y=-1..2, arrows=LARGE, title 
= `Lotka-Volterra model`, color=[.3*y(t)*(x(t)-1), x(t)*(1-
y(t)), .1]); 

• Phaseportrait (deqns,  vars,  trange,  inits,  options)1.  
Əmr məsələnin faza portretlərinin qurulmasını təmin edir. 
Məsələn,  

                                                 
1 Еg–тянликляр системи, func-ахтарылан функсийалар, trarge-дяйишянин 
тяйин областы, inits-башланьыъ  вя йа сярщяд шяртляри, options - графикин 
эюрцнцшцнц тянзимляйян параметрдир. 
2 Deqns -тянликляр системи, vars-ахтарылан функсийалар, trang- дяйишянин 
дяйишмя областы, xrange, yrange ахтарылан функсийаларын дяйишмя областы, 
options - графикин эюрцнцшцнц тянзимляйян параметрдир. 
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> phaseportrait(D(y)(x)=-y(x)-x^2,y(x),x=-1..2.5, [[y(0)=0], 
[y(0)=1],[y(0)=-1]], title=`Asymptotic solution`, 
colour=magenta, linecolor=[gold,yellow,wheat]); 

 
2.1.8. Sənəd üzərində redaktə  əməliyyatları 

 
Maple 9.01  proqram paketində sənəd özərində aşağıdakı  

redaktə əməliyyatlarını  aparmaq olar:  
• Yerinə yetirilmiş  son əmrin nəticəsini ləğv etmək.         

Bunun üçün  Edit→Undo əmrini yerinə yetirmək və ya 
«Ctrl+Z» qızğın düyməsini sıxmaq lazımdır. Məsələn, əgər 
istifadəçi səhvən sənəddə müəyyən fraqmenti ləğv etmişsə bu 
əmr vasitəsilə onu  bərpa edə bilər. 

• Yerinə yetirilmiş  son əmri təkrar yerinə yetirmək.         
Bunun üçün  Edit→Repeat əmrini yerinə yetirmək və ya 
«Ctrl+Y» qızğın düyməsini sıxmaq lazımdır. 

• Qeyd olunmuş sənədi və sənəd fraqmentini kəsib, 
mübadilə buferində saxlamaq. Bunun üçün ilk öncə sənəd və ya 
sənəd fraqmenti qeyd edilməlidir. Sənədi tamamilə   qeyd 
etmək üçün  Edit→Select All əmrini yerinə yetirmək və ya 
«Ctrl+A» düyməsini sıxmaq lazımdır. Sənəddə müəyyən 
fraqmentləri qeyd etmək üçün isə «SHİFT» düyməsini 
sıxmaqla kursoru hissələrin üzərinə qoyub siçanın sol 
düyməsini sıxıb buraxmaq lazımdır. Qeyd edilmiş sahələr qırıq 
xətli çərçivəyə alınmış olur. Bundan sonra Edit→ Cut əmrini 
yerinə yetirmək və ya «Ctrl+X» düyməsini sıxmaq lazımdır. 
Mübadilə buferində saxlanılmış informasiyanı sonradan 
sənədin digər hissəsinə və ya digər redaktorlara daxil etmək 
olar.  

• Qeyd olunmuş sənədi və sənəd fraqmentinin surətini 
mübadilə buferində saxlamaq. Bunun üçün Edit→Copy əmrini 
                                                                                                        
1 Deqns –тянликляр системи, vars - ахтарылан функсийалар, trange- 
дяйишянин тяйин областы, inits-башланьыъ  вя йа сярщяд шяртляри, options 
- графикин эюрцнцшцнц тянзимляйян параметрдир 
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yerinə yetirmək və ya «Ctrl+C» qızğın düyməsini sıxmaq 
lazımdır.  

• Mübadilə buferində saxlanılan informasiyanı sənədə 
daxil etmək; Bunun üçün Edit→Paste əmrini yerinə yetirmək 
və ya «Ctrl+V» qızğın düyməsini sıxmaq lazımdır.  

• Sənəddə cari əmr sahəsini və ya mətn sahəsini ləğv 
etmək. Bunun üçün  Edit→Delete Element əmrini yerinə 
yetirmək və ya klaviaturanın Delete düyməsini və ya 
«CTRL+D» qızğın düyməsini  sıxmaq lazımdır.  

• Sənəddə hər hansı simvolu, sözü və ya söz birləşməsini 
axtarmaq. Bunun üçün Edit→ Find əmrini yerinə yetirdikdə 
açılmış pəncərənin  Find sətrində axtarılan simvol və ya söz 
daxil edilməli və Find next düyməsi sıxılmalıdır (şək. 1). 
İstifadəçi sənəddə registrlərin nəzərə alınması, tam sözün 
axtarılması rejimlərini müəyyən edə bilər. Bunun üçün o, 
müvafiq olaraq Match case1-, Matc whol word only2  rejim 
variantlarını seçməlidir. 

 
Şək.1. 

Əgər  sənəddə simvolu axtarıb, digər simvol və ya söz ilə əvəz 
etmək tələb olunarsa, bu zaman açılmış pəncərənin Replace 
whith sətrində  yeni dəyişdirilən simvol və söz daxil 
edilməlidir. Pəncərənin  Replace düyməsini sıxdıqda axtarış 

                                                 
1 Реэистри нязяря алмаг рeжими цчцн мцяййян олунур. 
2 Там сюзцн ахтарылмасы рeжими цчцн мцяййян олунур 
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nəticəsində sənəddə tapılmış simvol və söz yeni simvol, söz ilə 
əvəz olunacaqdır. Axtarışı davam etdirmək tələb olunarsa, Find 
Next düyməsini sıxmaq lazımdır. Replace All düyməsi isə 
mətndə olan axtarılan  simvol, söz və ya söz birləşməsinin 
hamısını avtomatik olaraq   yeni simvol, söz və ya söz 
birləşməsi ilə əvəz edəcəkdir. Əgər tapılmış simvolu və ya sözü 
yeni simvol, söz və ya söz birləşməsi ilə əvəz etməyə ehtiyac 
duyulmursa, Find Next  düyməsini sıxmaqla axtarışı davam 
etdirmək lazımdır.  

• Mətn sahəsində mətnlərin orfoqrafik yazılışının 
yoxlanılmaq. Bunun üçün Tools→CheckSpelling əmrini 
yerinə yetirmək lazımdır.  Əmri yerinə yetirdikdə əgər səhv 
varsa, orfoqrafiyanın yoxlanılması öcön dialoq pəncərəsi açılır 
və bu dialoq pəncərəsinin variantlar bölməsində səhv hesab 
olunan sözün düzgün variantları əks olunur (şək.2). Bu 
variantlardan birini seçib, Change düyməsini sıxmaqla səhv 
sözü həmin sözlə əvəz etmək olar. Bəzi hallarda (termin, şəxs 
adı, coğrafi adlar və s.) sözün düzgün yazılışına baxmayaraq 
kompüter onu səhv kimi qəbul edə bilər. Bu halda Ignore  
düyməsini sıxmaq kifayətdir. Add  düyməsini sıxmaqla isə 
kompüterin lüğət bazasını «səhv qəbul etdiyi» sözlə 
zənginləşdirmək olar.  

 
Şək.2. 
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• Sənədə daxil edilmiş hiperistinadları redaktə etmək; 
Bunun üçün Edit→ Hyperlinks əmrini yerinə yetirmək və 
açılan Hyperlink Editor dialoq pəncərəsində siyahıdan 
hiperistinadı qeyd edib Edit düyməsini sıxmaq lazımdır (şək.3). 
Açılan növbəti pəncərədə hiperistinadı  redaktə etmək olar. 

•  Sənəddə bütün yerinə yetirilən sahələri və qeyd 
olunmuş sahələri yenidən hesablamaq. Bunun üçün müvafiq 
olaraq Edit →Execute Worksheet və Edit→Execute 
Selection əmrlərini yerinə yetirmək lazımdır.   
 

 
Şək.3. 

• Yerinə yetirələn sahələrdə əmrin və ya hesablamanın 
nəticəsini ləğv etmək.  Qeyd olunmuş yerinə yetirilən sahələrdə 
əmrin və ya hesablamanın nəticəsini ləğv etmək üçün 
Edit→Remove Output →From Selection əmrini, sənəddə 
bütün yerinə yetirilən sahələrdə əmrin və ya hesablamanın 
nəticəsini ləğv etmək üçün Edit→Remove Output → From 
Worksheet əmrini yerinə yetirmək lazımdır. 
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• Sənəddə kursorun durduğu sətrdən əvvəl və sonra yeni 
yerinə yetirilən sahəni daxil etmək. Bunun üçün müvafiq olaraq 
İnsert→ Execution Group→ Before Cursor və  İnsert→ 
Execution Group →After Cursor əmrini yerinə yetirmək 
lazımdır. 

• Sənəddə kursorun durduğu sətrdən əvvəl və sonra yeni 
mətn sahəsini daxil etmək. Bunun üçün müvafiq olaraq 
İnsert→ Paragraf→ Before Cursor  və İnsert→ Paragraf→ 
After Cursor əmrini yerinə yetirmək lazımdır. 
 

2.1.9. Sənəd üzərində  formatlaşma əməliyyatları 
 

Sənəd üzərində formatlaşma əməliyyatı aparmaq üçün 
Format menyusu nəzərdə tutulmuşdur. Format menyusu 
aşağıdakı əmrlərdən ibarətdir: 
 Styles. Əmr yeni obyekt stillərinin yaradılmasını, seçilmiş 

stilin redaktə olunmasını, qeyd olunmuş sənəd hissəsinə 
seçilmiş stili tətbiq etməyi təmin edir.  Əmri yerinə 
yetirdikdə Style Management dialoq pəncərəsi açılır (şək.1). 
İstifadəçi yeni stil yaratmaq üçün  Create Character və 
Style Create Paragraph Style düymələrini sıxıb, yeni stilə 
ad verdikdən sonra, stilin şrifti və abzas üçün parametrləri 
müəyyən etməlidir. Stili redaktə etmək üçün isə onu stil 
siyahısından seçmək, Modify düyməsini sıxmaq və açılan 
növbəti dialoq pəncərəsində şrift və abzas üçün parametrləri 
dəyişdirmək lazımdır. Sənəd hissəsinə stil tətbiq etmək 
üçün tələb olunan stili siyahıdan seçdikdən sonra Apply 
düyməsini sıxmaq lazımdır. 
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Şək.1. 

• Character→Italic (Ctrl+I). Əmr şrift üçün maili 
yazılış formasını müəyyən edir. 

•  Character→Bold (Ctrl+B). Əmr şrift üçün tünd 
yazılış formasını müəyyən edir. 

•  Character→Underline (Ctrl+U). Əmr şrift üçün qeyd 
olunmuş yazılış formasını müəyyən edir. Bu stil şriftin 
altından xətt çəkilməsini nəzərdə tutur.  

• Character→Color. Əmr şrift üçün rəng müəyyən edir. 
Rəng əmri yerinə yetirildikdə açılan rəng palitrasından 
seçilir.  

• Character→Attributes. Əmr cari və ya qeyd olunmuş 
sahə üçün şriftin stilinin müəyyən edilməsini təmin edir. 
Əmri yerinə yetirdikdə açılan Character Style dialoq 
pəncərəsindən şriftin adı, ölçüsü, şriftin və fonun rəngi, 
yazılış formaları  seçilir (şək.2). 
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Şək.2. 

 Paragraph Left Justify, Paragraph Center Justify, 
Paragraph Right Justify əmrləri müvafiq olaraq cari 
sahədəki obyektləri mərkəzə, sol və sağ tərəflərə görə 
nizamlayır.  

 Paragraph Atributes əmri çari sahə üçün sətirlərarası 
intervalının, nizamlama parametrlərinin, sahənin 
kənarlarından buraxılan boş məsafələrin dəyişdirilməsini 
təmin edir. Yeni parametrlər əmri yerinə yetirdikdə açılan 
Paragraph Style dialoq pəncərəsində müəyyən edilir 
(şək.3). 

 
Şək.3. 

 Page Numbers əmri sənədin səhifələrinin 
nömrələnməsini təmin edir. Əmri yerinə yetirdikdə açılan 
Page Numbers pəncərəsində səhifədə nömrənin yerləşmə 
istiqamətini, başlanğıc qiymətini və digər parametrləri 
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müəyyən etmək lazımdır (şək.4).   

 
Şək.4. 

• Convert to. Əmr cari sahənin tipini dəyişir. Məsələn, 
Maple İnput sahəsini mətn sahəsinə  dəyişmək üçün   
Convert to Pain Text əmrini yerinə yetirmək lazımdır. 
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2.2. GRAPH DIGITIZER 
 
Proqram cari qrafikdə 20-yə qədər əyrinin nöqtələrinin 

koordinatlarının tapılmasını təmin edir. Bu əməliyyat 3 
rejimdə: avtomatik, oblastda qiymətləndirmə və qeyd etmə 
rejimlərində həyata keçirilə bilər. Əyrinin ədədi qiymətlərinin 
tapılması üçün ilk öncə qrafik işçi sahənin Digitization 
bölməsinə çağırılmalıdır. Bunun üçün Файл Открыть файл 
с графиком  (Fayl Qrafik faylını açmaq) əmrini yetirmək 
və açılan dialoq pəncərəsində qrafik faylının ünvanını müəyyən 
edib Открыть (Açmaq) düyməsini sıxmaq lazımdır (şək.1).  

 
Şək.1 

Qeyd edək ki, qrafiki fayl bmp, jpg, tif formatlarına 
malik olmalıdır. Qrafik həmçinin kompüterə qoşulan skaner 
vasitəsilə kağız üzərindən də daxil  edilə bilər. Bunun üçün 
Файл Сканировать (Fayl Skanerləşdirmək) əmrini 
yerinə yetirmək və skanerləşdirmə əməliyyatını aparmaq 
lazımdır. Bundan sonra qrafikin real koordinatlarını təyin 
etmək lazımdır. Bunun üçün Оцифровка (Qiymətləndirmə) 
menyusunun Правязка к координатом графика (Qrafikin 
koordinatına uyğunlaşdırmaq) əmrini yerinə yetirmək və 
açılan dialoq pəncərəsində X və Y oxu boyunca qrafikin 
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başlanğıc və son real koordinatlarını  daxil etmək və Да (Bəli) 
düyməsini sıxmaq lazımdır1 (şək.2).   

 
Şək.2. 

Açılan növbəti pəncərədə əyrinin ədədi qiymətlərinin tapılma 
rejimini müəyyən etmək lazımdır (şək.3). Avtomatik rejimi 
müəyyən etmək üçün Оцифровка (Qiymətləndirmə) 
bölməsində  авт.  (avt.) rejim bölməsini aktivləşdirmək və 
orada bölgü nöqtələrinin sayını müəyyən etmək lazımdır. Daha 
sonra qrafiki əyrinin rəngini müəyyən etmək lazımdır. Rəngi 
Оцифровка (Qiymətləndirmə) menyusunun Выбрать цвет 
кривой из палитры (Əyrinin rəngini palitradan seçmək) 
əmrini yerinə yetirməklə rəng palitrasından seçmək lazımdır. 

 düyməsini sıxdıqda əyrinin qrafikin qiymətləndirilməsi baş 
verir. Avtomatik rejimdə dəqiq qiymətlər əldə etmək üçün 
дополн. (əlavə) bölməsində Одназночность (Birqiymətli) 
variantını  seçmək məsləhətdir (şək.4). Əks halda seçilmiş 
rəngə uyğun bütün nöqtələrin ədədi qiymətləri tapılır və 

                                                 
1 Бу ямялиййаты  алятляр панелинин  дцймясини сыхмагла да йериня 
йетирмяк олар. 
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tapılmış ədədi qiymətlər Таблица  (Cədvəl) bölməsində cədvəl 
şəklində əks olunur. 

    
  Şək. 3.                                     Şək. 4. 

Qeyd edək ki, avtomatik rejimdə qrafikin qiymətləndirmə 
oblastını    aləti vasitəsilə də qeyd etmək olar.   

Oblastda qiymətləndirmə  və qeydetmə rejimlərində 
qiymətləndirmə aparmaq üçün ilk öncə Общие (Ümumi) 
bölməsinin Размер маркера (Markerin ölçüsü) sahəsində 
markerin ölçüsünü müəyyən etmək lazımdır. Oblastda 
qiymətləndirmə rejimində qiymətləndirmə aparmaq üçün   
düyməsini sıxmaq və siçanın sol düyməsini sıxmaqla kursoru 
əyri üzərində hərəkət etdirmək lazımdır. Qeydetmə rejimi 
istifadəçiyə əyrinin konkret nöqtələrinin koordinatlarını təyin 
etmək imkanı verir. Bunun üçün   düyməsini sıxdıqdan 
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sonra, kursoru əyrinin konkret nöqtəsinin üzərinə qoyub siçanın 
sol düyməsini sıxmaq kifayətdir.   

Bütün rejimlərdə əyrinin koordinatları cədvəl 
bölməsində əks olunacaqdır. Cədvəldə əks olunan əyrinin 
koordinatlarını nizamlamaq olar. Bunun üçün Таблица 
menyusunun Сортировка по Х (X-ə görə nizamlamaq) 
əmrini yerinə yetirmək lazımdır. Файл (Fayl) menyusunun 
Сохранить данные из таблицы (Cədvəl verilənlərini 
yaddaşda saxlamaq) əmrini yerinə yetirməklə  cədvəli dat və 
ya txt formatında fayl kimi yaddaşda saxlamaq olar. İstifadəçi 
həmçinin, Таблица (Cədvəl) menyusunun Формат данных 
(Verilənlərin formatı) əmrini yerinə yetirib açılan dialoq 
pəncərəsində müvaifq format növünü seçməklə  cədvəldə əks 
olunan koordinatlar üçün müxtəlif formatlar müəyyən edə bilər 
(şək.5). 

 
Şək. 5. 

Таблица (Cədvəl) menyusunun Заменить (Əvəz 
etmək) əmrini yerinə yetirməklə cari sütunda həqiqi ədədin 
yazılışında nöqtəni vergüllə və ya əksinə dəyişmək, 
parametrlərini müəyyən etmək olar. Ehtiyac olduqda, 
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menyunun Вычислить (Hesablamaq) əmrini yerinə yetirib, 
açılan pəncərədə sütunu, ədədi və əməliyyatı müəyyən etməklə 
seçilmiş sütundakı qiymətlərin konkret ədədlə cəmini, fərqini, 
hasilini və qismətini tapmaq olar (şək.6).  

 
Şək.6. 

Очистить всю таблицу (Cədvəli silmək) əmri 
vasitəsilə cədvəldəki bütün ədədi qiymətləri Удалить строки 
(Sətirləri ləğv etmək) əmri vasitəsilə isə yalnız dialoq 
pəncərəsində müəyyən edilmiş sətirlər ləvğ olunur. 
Копировать в буфер (Buferə köçürmək), Таблицу в Excel 
(Cədvəli Excel-ə) əmrləri vasitəsilə müvafiq olaraq cədvəldəki 
informasiyanı  mübadilə buferində saxlamaq, Excel sənədinə 

daxil etmək olar. Cədvəl böyük olduqda istifadəçi  
sahəsi vasitəsilə əks olunacaq sətirlərin sayını tənzimləyə bilər. 
İstifadəçi cədvəldə ədədi qiymətlər üzərində redaktə apardıqdan 
sonra əyriyə baxış Графер bölməsində həyata keçirilir. Bunun 
üçün  düyməsini sıxmaq lazımdır. İstifadəçi Графер 
(Графер) menyusunun График  Символ 
(Qrafik Simvol), График Линия (Qrafik Xətt) əmrləri 
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vasitəsilə əyrinin nöqtəvari və ya xətt şəklində olmasını 
tənzimləyə bilər. Увеличить размер символа (Simvolun 
ölçüsünü artırmaq), Уменьшить размер символа 
(Simvolun ölçüsünü azaltmaq) əmrləri vasitəsilə isə simvolun 
və xəttin qalınlığını müəyyən etmək olar. Koordinat 
müstəvisində şəbəkənin əks olunması График Сетка 
(Qrafik Şəbəkə) əmrilə, koordinat oxları üçün loqarifmik 
şkala isə müvafiq olaraq  Логарифмическая шкала по Х 
(X-ə görə loqarifmik şkala) və  Логарифмическая шкала 
по Y (Y-ə görə loqarifmik şkala) əmrləri ilə təyin olunur1. 
Qurulmuş qrafiki yaddaşda saxlamaq üçün istifadəçi Файл 
(Fayl) menyusunun Сохранить график из графера (Qrafer 
qrafikini yaddaşda saxlamaq) əmrini yerinə yetirib, açılan 
dialoq pəncərəsində faylın ünvanını müəyyən etdikdən sonra 
Сохранить (Yaddaşda saxlamaq) düyməsini sıxmalıdır. 
Qrafiki çap etmək üçün isə График Печать (Qrafik Çap 
etmək) əmrini yerinə yetirməlidir. 

 
  

2.3. ADVANCED GRAPHER 
 

Advanced Grapher proqramı digər Windows  əlavələri  
kimi Baş menyunun Proqramlar bölməsindən yüklənir və bu 
zaman ilk öncə proqramın loqotipi, sonra isə proqramın əsas 
interfeys pəncərəsi ekranda əks olunur. İnterfeys pəncərəsi 
başlıq və menyu sətrlərindən, standart, qrafik və hesablama 
alətlər panellərindən və sənəd pəncərəsindən ibarətdir (şək.1).  
Sənəd pəncərəsi proqram yükləndikdə avtomatik olaraq,  
istifadəçi  Файл Новый (Fayl Yeni) əmrini yerinə 
yetirdikdə və ya standart alətlər panelinin ilk düyməsini 
sıxdıqda açılır. Yeni sənəd pəncərəsində  Dekart koordinat 
sistemi  əks olunur.  

                                                 
1 Ямрлярин адынын гаршысында √ ишаряси олдугда координат шкаласы логарифмик, 
якс щалда ися хятти  олур. 
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Şək. 1 

Ümumiyyətlə isə interfeys pəncərəsinin görünüşü  Вид 
(Görünüş) menyusu vasitəsilə tənzimlənir. Belə ki, Вид → 
Панель “Стандартная” (Görünüş→“Standart” alətlər 
paneli), Вид→Панель “График”( Görünüş →“Qrafik” 
alətlər paneli), Вид→Панель “Вычисления” (Görünüş → 
“Hesablama”  paneli) əmrləri müvafiq alətlər panelinin 
interfeys pəncərəsində əks olunmasını, Вид→Полный екран 
(Görünüş→Tam ekran) əmri isə ekranda yalnız sənəd 
pəncərəsinin əks olunmasını tənzimləyir. 

Funksiyanın qrafiki düstur və ya cədvəldə əks olunmuş 
ədədi informasiyalar əsasında qurulur. Düstur əsasında qrafiki 
qurmaq üçün Построение Добавить график (Qurulma → 
Qrafik əlavə etmək) əmrini yerinə yetirmək, Добавить 
график (Qrafik əlavə etmək) adlı açılaın pəncərədə qrafikin 
tipini (koordinat sistemini), funksiyanın düsturunu, qrafikin 
rəngini, əyrinin qalınlığını və stilini, ehtiyac olarsa qrafik 
haqqında məlumatı müəyyən edib, OK düyməsini sıxmaq 
lazımdır (şək.2).  
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Şək. 2. 

Cədvəl əsasında qrafik qurmaq üçün Построение  
Добавить  график из таблицы (Qurulma →Cədvəl 
vasitəsilə qrafik əlavə etmək) əmrini yerinə yetirmək, açılan 
pəncərədə X və Y üçün ədədi qiymətlər daxil etmək, qrafikin 
rəngini, əyrinin qalınlığını və stilini, ehtiyac olarsa qrafik 
haqqında məlumatı müəyyən etmək və OK düyməsini sıxmaq 
lazımdır (şək.3). 
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Şək. 3. 

Qeyd edək ki, dialoq pəncərəsinin Работа с таблицей 
(Cədvəllə iş) sahəsində yerləşən alətlər, cədvələ daxil olunmuş 
ədədi informasiyaları redaktə etmək üçün nəzərdə tutulmuşdur. 
Bu alətlər vasitəsilə cədvəlin müəyyən sətirlərinin surətini 
almaq, yerini dəyişmək, konkret ədədi qiyməti digər ədədlə 
əvəz etmək, cari sətri ləğv etmək, cari sətirdən əvvələ yeni sətr 
əlavə etmək, ədədləri artma və azalma ardıcıllığına görə 
nizamlamaq və s. əməliyyatlar yerinə yetirmək olar.  

 Построение Добавить график (Qurulma→ 
Qrafik əlavə etmək) və ya Построение  Добавить 
график из таблицы (Qurulma → Cədvəl vasitəsilə qrafik 
əlavə etmək)  əmrlərini təkrar yerinə yetirməklə bir koordinat 
müstəvisində bir neçə qrafikin əks olunmasına nail olmaq olar. 
Həmçinin, bir koordinat müstəvisində bir neçə qrafik əks 
olunduqda Построение Список график (Qurulma → 
Qrafik siyahısı) əmrini yerinə yetirməklə konkret qrafikin 
xassələri ilə (məsələn, qurulduğu düstur və ya cədvəllə) tanış 
olmaq olar. 

İstər cədvəldə əks olunmuş ədədi informasiyalar, istərsə 
də düstur əsasında  qrafik müəyyən edilmiş parametrlər 
əsasında qurulur. İstifadəçi bu parametrləri dəyişməklə 
qurulmuş qrafiki öz təlabatına uyğun formatlaşdıra bilər. Belə 
ki, Параметры→Параметры построения (Parametrlər → 
Qurulma parametrləri) əmrini yerinə yetirməklə açılan eyni 
adlı dialoq pəncərəsində qrafikin təyin və qiymətlər oblastını, 
bölgü nöqtələrinin sayını dəyişmək, koordinat oxları üçün 
loqorifmik şkala müəyyən etmək olar (şək.4-5). 
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                  Şək. 4.                                       Şək. 5. 

Həmçinin, Параметры→Оси (Parametrlər→Oxlar) əmrini 
yerinə yetirdikdə açılan Параметры осей (Oxların 
parametrləri) adlı dialoq pəncərəsində  koordinat oxlarının 
istiqamətini, stilini, rəngini, adını dəyişmək, bölgü nöqtələri 
üçün yeni parametrləri, qrafik üçün ad və koordinat 
müstəvisinin görünüşünü və hər bir əyri göstəricisini müəyyən 
etmək olar (şək. 6). 
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Şək. 6. 
 

Koordinat müstəvisində şəbəkənin əks olunması 
Параметры→Сетка (Parametrlər→Şəbəkə) əmrilə, sənəd 
pəncərəsinin fonu isə Параметры→Фон (Parametrlər→ 
Fon) əmri vasitəsilə tənzimlənir. Müəyyən edilmiş yeni 
parametrləri proqram tərəfindən yeni qurulacaq bütün qrafiklər 
üçün avtomatik müəyyən edilən parametrlər kimi təyin etmək 
üçün Параметры→Сохранить параметры (Parametrlər 
→ Parametrləri yaddaşda saxlamaq) əmrini yerinə yetirmək 
kifayətdir.  Praktikada triqonometrik funksiyaların qrafiklərinin 
qurulmasında adətən triqonometrik şkaladan istifadə olunur. 
Koordinat oxları üçün triqonometrik şkala müəyyən etmək 
üçün istifadəçi Параметры Наборы параметров  
Тригонометрический набор (Parametrlər  Parametrlər 
toplusu  Triqonometrik toplu) əmrini yerinə yetirməlidir.   

Proqram vasitəsilə eyni zamanda aşağıdakı əməliyyatları 
da yerinə yetirmək olar: 
• Düstur ilə verilmiş funksiyanı arqumentin konkret 

qiymətində hesablamaq olar. Bunun uçün Вычисление  
Калькулятор (Hesablama  Kalkulyator) əmrini yerinə 
yetirmək, açılan pəncərədə düsturu və arqumentin qiymətini 
daxil edib, Считать (Hesablamaq) düyməsini sıxmaq 
lazımdır.  Funksiyanın qiyməti açılan pəncərənin Итог 
(Yekun)  sahəsində əks olunacaq (şək.7). 

 
Şək.7. 

• Funksiyanın qiymətini müəyyən intervalda, konkret 
addımla hesablamaq olar. Bunun üçün Вычисление 

Fəsil 2 Riyazi proqram paketləri 

 

170

Таблица значение (Hesablama Qiymətlər cədvəli) 
əmrini yerinə yetirib, açılan pəncərədə funksiyanın 
düsturunu, arqumentin dəyişmə intervalını və addımı 
müəyyən etmək lazımdır.  Считать (Hesablamaq) 
düyməsini sıxdıqda funksiyanın qiyməti açılan cədvəldə əks 
olunacaq. 

• Funksiyanı tədqiq etmək; Bunun üçün Вычисление 
Исследование функции (Hesablama Funksiyanı 

tədqiq etmək) əmrini yerinə yetirib, açılan pəncərədə 
funksiyanın düsturunu, arqumentin dəyişmə intervalını və 
addımı müəyyən etmək lazımdır (şək. 8). Bundan sonra OK 
düyməsini sıxdıqda açılan növbəti pəncərədə funksiyanın 
böhran və ekstrumum nöqtələrinin qiyməti əks olunacaqdır. 
Ehtiyac olarsa Сохранить (Yaddaşda saxlamaq) düyməsini 
sıxmaqla nəticəni mətn faylı şəklində yaddaşda saxlamaq 
olar. 

 
Şək. 8. 

• Düsturla verilmiş qrafiklərin kəsişmə nöqtələrinin 
hesablanması. Bunun üçün Вычисление Пересечение 
(Hesablama Kəsişmə) əmrini yerinə yetirib açılan 
pəncərədə funksiyaların düsturlarını daxil edib, arqumentin 
dəyişmə intervalını müəyyən etmək lazımdır. OK 
düyməsini sıxdıqda açılan növbəti pəncərədə funksiyanın 
kəsişmə nöqtələrinin koordinatları əks olunacaqdır. Ehtiyac 
olarsa Сохранить (Yaddaşda saxlamaq) düyməsini 
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sıxmaqla nəticəni mətn faylı şəklində yaddaşda saxlamaq 
olar. 

• Qrafiki qurulmuş funksiyanın törəməsini hesablamaq və 
qrafikini qurmaq. Bunun üçün Вычисление  
Производная (Hesablama Törəmə) əmrini yerinə 
yetirdikdə  açılan pəncərədə funksiyanı siyahıdan seçmək 
lazımdır. Funksiyanın törəməsi avtomatik olaraq pəncərənin 
Производная (Törəmə) sahəsində əks olunacaqdır (şək. 9). 

 
Şək. 9. 

Добавить график (Qrafik əlavə etmək) duyməsini sıxdıqda 
açılan eyni adlı pəncərədə (şək. 2.) törəmənin qrafiki üçün 
müəyyən olunan parametrləri: qrafikin rəngini, əyrinin 
qalınlığını və stilini, ehtiyac olarsa qrafik haqqında 
məlumatı müəyyən etmək olar. Bundan sonra OK 
düyməsini sıxdıqda qrafik ekranda əks olunacaqdır.  

• Qrafikə toxunan və normalı qurmaq. Bunun üçün 
Вычисление Касательная или нормаль (Hesablama 

Toxunan və ya normal) əmrini yerinə yetirdikdə açılan 
pəncərədə normal və ya toxunan variantını seçmək və 
toxunma nöqtəsini daxil etmək, Добавить график (Qrafik 
əlavə etmək)  düyməsini sıxmaq lazımdır (şək.10).  
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Şək. 10. 

Bu zaman açılan  Добавить график (Qrafik əlavə 
etmək) adlı dialoq pəncərəsinin Формула (Düstur) 
sahəsində avtomatik olaraq toxunanın və ya normalın 
düsturu əks olunur (şək.2). İstifadəçi OK düyməsini 
sıxdıqda toxunan və ya normal qrafikə əlavə olunur. 

• Cədvəl əsasında verilmiş ədədi informasiyanı reqressiv 
təhlil etmək. Bunun üçün Вычисление Регрессивный 
анализ (Hesablama Reqressiv təhlil) əmrini yerinə 
yetirmək və açılan dialoq pəncərəsində reqressiya tipini 
seçmək lazımdır (şək.11). Alınmış  nəticənin əsasında 
qrafik qurmaq tələb olunduqda Добавить график (Qrafik 
əlavə etmək)  düyməsini sıxmaq lazımdır. 

 
Şək. 11.             
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